Voltaje de entrada al pic demasiado bajo.

#1
Buenas amigos.

Estoy haciendo un proyecto que trata de implementar un cuenta-revoluciones para un motor de 2T con un pic16f877A. Ya tengo hecho el programa en ensamblador y funciona muy bien.
El motor tiene un sensor que le manda una señal al pic por cada vuelta que realiza, esta señal la llevo al RA4 que es la entrada del TIMER0 en modo contador.

El problema es que la señal que me manda el motor es de solo 1,5V y el pic no la detecta. necesito amplificar esa señal y no tengo ni idea de como, he estado leyendo mucho pero no llego a ninguna conclusión clara. A ver si ustedes me pueden arrojar algo de luz.

La frecuencia de la seña es de 250Hz como máximo por si hay algún problema con delays en el posible amplificador.

Un saludo y gracias!
 
#3
Un motor mas grande seria una solución .. posible peor seguro hay una forma de amplificar ese voltaje quizas con un transistor!
 
#4
amplificador a transistores clase A o B o un amplificador operacional....
el amplificador operacional lo estudie hace unos años y todavía me acuerdo de algo, de todas formas, mi miedo es si el tiempo de respuesta del amplificador es demasiado alto y confunda los pulsos, o es instantaneo??

de lo otro que me has dicho ni idea.

muchas gracias por responder

Un motor mas grande seria una solución .. posible peor seguro hay una forma de amplificar ese voltaje quizas con un transistor!
jeje, claro pero lo que quiero es precisamente medir las revoluciones de ese motor no de otro.
muchas gracias de todos modos.
 
#5
para 250 Hz no tienes problemas aun usando operacionales "viejos" como el 741 o el LM324, pero si la velocidad es un problema siempre puedes usar amplificadores de video que soportan varios cientos de megahertz :LOL: :LOL:
 
#6
el amplificador operacional lo estudie hace unos años y todavía me acuerdo de algo, de todas formas, mi miedo es si el tiempo de respuesta del amplificador es demasiado alto y confunda los pulsos, o es instantaneo??

de lo otro que me has dicho ni idea.

muchas gracias por responder



jeje, claro pero lo que quiero es precisamente medir las revoluciones de ese motor no de otro.
muchas gracias de todos modos.
Hola... y si pruebas con esto que adjunto..
Saludos.

Ric.
 

Adjuntos

#7
para 250 Hz no tienes problemas aun usando operacionales "viejos" como el 741 o el LM324, pero si la velocidad es un problema siempre puedes usar amplificadores de video que soportan varios cientos de megahertz :LOL: :LOL:
Bueno entonces me quedo mucho mas tranquilo, muchísimas gracias, a ver si mañana me acerco a la tienda de electrónica y me compro un opamp para probarlo bien antes de montar el pic.

Hola... y si pruebas con esto que adjunto..
Saludos.

Ric.
Buff asi da gusto! gracias por tomarte la molestia, voy a ver que tal va simulando con el proteus y a entender un poco el funcionamiento que la electrónica analógica la tengo bastante olvidada.
 
#8
Revisa bien el numero de parte.. si usas un opamp "viejo" como el LM324 necesitas alimentarlo con una fuente de voltaje mas elevada ya que el voltaje maximo a la salida es menor al de la fuente de alimentacion ( tipicamente 1.5V menos para el 324)

La opcion para esta situacion es usar un operacional rail to rail, pero hay que averiguar que numeros de parte manejan en la tienda de electronica de tu localidad...
 
Arriba