voltaje de xbee vs micro

#1
hola a todos como estan, estoy desarrollando un proyecto que involucra micro y modulos xbee,

la alimentacion del micro y del xbee ya estan listas pero el problema esta en el voltaje de las señales tx y rx ya que el micro se alimenta a 5v y el xbee a 3.3 si la informacion que le envio al xbbe en amplitud es mayor a 3.3 v lo quemaria este problema lo solucione con un divisor de voltaje. pero cuando la informacion va del xbee al micro este me envia datos con amplitud de 3.3v y el micro no las reconoce ya que deben ser de 5v.

como puedo solucionar este problema sin que el retardo sea muy grande para no alterar los datos que me envia el xbee,
que tipo de circuito utilizar

me podran ayudar..


muchas gracias
 
#2
lo he conectado directo del xbee a pic y no me ha dado problemas ahora si quieres puedes utilizar algun buffer para que te ayude
 
#3
Del lado del Xbee, si es 5V tolerant, no tenés problema en conectarlo directamente.

Del lado del micro, para estar seguro tenés que ver si el estado alto de la entrada es reconocido incluso para el voltaje más bajo que puede sacar el Xbee. En general, anda bien pero hay que verificar el datasheet del micro.
 
#5
intentare con los opto. muchas gracias por su aporte. creo que es lo mejor yo estaba pensando en utilizar una compuerta lm7414.

sera que el tiempo de respuesta de la compuesrta me afecta la informacion,
otra idea era utilizar amplificadores operacionales pero el problema ya radica en el la velocidad de la informacion. es muy alta no podre asegurar los 5v que me entrega al micro

si conoce alguna referencia de AO que se pueda trabajar a una frecuencia muy alta te lo agradeceria.
pero la idea con los optoacopladores me sono mucho.

gracias
 
#8
Hola, ya solucionaste tu problema?; la verdad no entiendo por que no te funciona,yo he estado trabajando con los modulos y no he tenido problemas con la información que el xbee entrega al pic.
lo que si te puedo decir es que ensayé con varias velocidades de transmisión, y con la unica que me funcionó fué con 1200 baudios,

saludos!
 
Arriba