¿Flip-Flop Tipo D?

#1
Hola os escribo para exponeros una duda que tengo, tengo que hacer un proyecto de fin de curso en el cual tengo que encender un led desde dos pulsadores. Al pulsar cualquiera de ellos se encendería, y al pulsar de nuevo cualquiera de los dos se apagaría. (como un telerruptor)
He llegado a la conclusión de que creo que necesitare un Flip-Flop tipo D. Pense que de la salida de Q negada deberia llevarla a la entrada de D. Y en Clock los pulsadores (con un puerta OR para poder poner los dos) pero e probado a montarlo dos veces y no me funciona :eek:.

Me gustaría que me dijeseis si ese circuito es el indicado o simplemente estoy haciendo algo mal :rolleyes:

Gracias de antemano!
 
#2
los pulsadores tienen antirebote? Y tienes un circuito de inicio? Es lo que se me ocurre que puede fallar
 
#3
Los pulsadores son normales, mientras los pulsas pasa corriente. (Son los de la protoboard) Y el circuito de inicio nose que es :confused:
 
#4
Ajam pero esos pulsadores normales tienden a fallar. A veces lo usas por un largo tiempo y no pasa nada, otras veces echan broma desde el principio. Eh visto algunos protoboards en youtube que ya tienen pulsadores, leds y otras cosas incluidos, te refieres a esos? De todas maneras tienes que averiguar si tus pulsadores tienen rebote y quitarselo, hay varias maneras de hacerlo pero la más facil para mi es usar una compuerta schmitt trigger, una resistencia y un condensador.
Y con el circuito de inicio...nose si asi lo llaman en todas partes, es solo "algo" que haga que tu circuito realmente empieze desde cero o desde donde necesites.
Cuando alimentas el circuito es posible que no empieze desde tu combinacion cero, una solucion a esto es usar una resistencia y un condensador en los reset de cada FF.
 
#5
Si, mi protoboard tiene pulsadores, leds... Los pulsadores estan alimendatos a 5v, simplemente cojo un cable y lo envio a la entrada de la OR, y con el otro pulsador lo mismo. Mañana me enterare que tipo de pulsadores son y te comento.

El flip-flop lo hago con puertas Nand, estoy por probar a hacerlo con otras puertas porque me parece muy extraño que no me funcione, generalmente no me suelen ocurrir estas cosas :rolleyes:

Y supuestamente no deberia dar lo mismo que el circuito se iniciase en 0 o en 1 ? Si se iniciase con el led encendido seria darle un pulso al pulsador y se apagaria, no?:confused:
 
#6
No puedes usar un integrado tipo D? y no es lo mismo que empiece en 0 o en 1, en este caso es un led y se ve insignificante, pero si fuera una alarma, seria molesto que sonara cuando alimentas el circuito. O si fuera algun contador y empieza en 3?

Que problemas tuviste al montarlo?
 
#7
Lo de los pulsadores es fácil, imaginatelo, al pulsar un botón, rebota un poquito y eso puede dar un par o tres picos, y esto hará que el Flip Flop detecte el pulso varias veces.
Pon un capacitor desde la señal del pulsador hacia tierra, y esto "filtrará la señal y no habrá picos"

Por cierto, si tienes dos pulsadores, puedes usar una puerta or, nose si lo aplicabas

Y asegurate de que tienes los flip-flops bien conectados.
Espera ayudar ^^
 
#8
Usa una puerta OR como bien as dicho. Y mañana mismo probare lo del condesador. El flip-flop no puedo cojer uno integrado, el proyecto se trata de hacerlo con chips 7700 y 40... Los TTL y los otros no me acuerdo el nombre :LOL:

Gracias por la ayuda
 
#9
Ok. Recuerda tomar en cuenta el rebote del pulsador.
Una vez probe un laboratorio y funcionaba bien, sabiendo que tenia que ponerle el antirebote no lo hice y llame a la profesora para que me revisara, y adivina? Cada vez que lo pulse hubo rebote :LOL: De alli mas nunca pues jejeje
Otra cosa, implementar un FF tipo T es mas corto que un tipo D, aunque no recuerdo bien.
 
#10
Hoy e vuelto a intentarlo, y no me sale, lo raro es que lo e montado 2 veces, y unos compañeros tambien. Y ninguno lo consigue, estamos desesperados... Porque generalmente nos suelen salir a la primera bien, y si no es asi los correjimos o los volvemos a montar y listo, pero esta vez...
 
Arriba