[Aporte] Clase D 2.1 fuente simple 12v basado en TL494

Quisiera aclararles que para hacer algo simple el TL494 esta muy bien pero su frecuencia portadora maxima va a ser de 200 khz. Sirve pero no es hi-fi y tiene un problema (mas bien por diseño porque es para fuentes) que no puede ir al 100% del duty cycle. En mi esquematico evito eso con un diodo que genera un bias "negativo" con respecto a GND del integrado.

Ahora, en mi opinion, si nos ponemos a agregar un driver de mosfet como el IR2110 etc, etc, etc entonces yo fabricaria los class D de ejtagle que son hi-fi y profesionales. Es decir, para complicarla mejor me voy a algo con mas prestaciones. (no es que los de ejtagle sean dificiles, para nada)

Tambien se puede hacer lo mismo con un operacional generando una onda triangular y un comparador.

El TL494 es una solucion "ya armada" digamos para hacer un ampli pero nunca hay que olvidar que es un integrado diseñado para fuentes.

PD: Lean :), el que quiera hacer esto con fuente partida puede usar el esquematico del link en el post #1 que es este: http://geekcircuits.com/wp-content/uploads/2010/07/tl494-class-d-power-amp1.png
 
Última edición:
Buenas noches, estoy armando este amplificador solo una etapa pero tengo una duda ese driver totem pole puede manejar esos mosfet a 40 Vcc ?

otra duda: por que el circuito que adjunto a 20v funciona pero a 40v la señal en los gate se invierte?
 

Adjuntos

  • driver 2.jpg
    driver 2.jpg
    628.5 KB · Visitas: 112
  • driver p n.rar
    159.3 KB · Visitas: 64
Última edición:
No me han hecho falta. Por supuesto, seria bueno ponerlos pero se puede evitar ese problema ;)



En full bridge, mientras medio puente esta a positivo, el otro medio tiene que estar a negativo. Esto se puede lograr poniendo cada transistor del TL494 de forma diferente (uno en emisor comun y otro emisor seguidor) con lo cual tenes un PWM normal y uno inverso. La mejor forma seria dejarlo como esta, y adicionar dos compuertas XOR (CD4030) en las cuales 1 entrada de cada una va al PWM del TL494 y las otras dos entradas, 1 a positivo, otra a negativo. Con esto tendria un PWM normal y otro inverso en las salidas de las XOR para manejar el full bridge. El feedback se tomaria de uno de los pares de mosfets (aquel cuya salida sea inversa a la entrada de audio del tl494)

Si nos ponemos mas exquisitos, se toma de ambas mitades del half bridge a un AO puesto como diferencial y esa salida puede ir al feedback (esto ya es mucho lio... con tomarlo de una mitad anda perfecto! mis primeras pruebas con este integrado fueron en full-bridge)



IMPORTANTE: Si, exactamente como decis! aca adjunto el esquematico corregido. Quedo feo ahora jeje el livewire no tiene para invertir verticalmente un componente

Gracias eza, dosme! (estuve a punto de hacer el tuyo de 3 transistores! muy bueno! pero queria clase D)

Recien me encuentro con este excelente post....
No he analizado todo lo dicho en el post, pero anticipo que si lo quieren hacer full bridge, no usaria una cimpuerta normal (CD4030), sino su equivalente HCT con la conversión de nivel correspondiente, ya que la linea CD es media lentona. Igual, si alguien le interesa la idea, vemos de calcularla. Saludos y muchas gracias por el aporte!!
 

DOSMETROS

High 2m Modereitor
Mensajes temporales ambos , con el diagrama haces la lista de componentes , con el mismo diagrama y siguiéndolo en el circuito impreso , montas los componentes.
 
Mensajes temporales ambos , con el diagrama haces la lista de componentes , con el mismo diagrama y siguiéndolo en el circuito impreso , montas los componentes.
gracias es que como yo no trabajo el pcb wizard y hay unos archivos que no me abren entonces pense que algo me faltaba, perdon el inductor de que valor es no lo veo en el esquematico.
 
Tampoco leiste el texto porque del inductor se habló
querido amigo dosmetros quisiera que me colaboraras con esta resistencia que no aparece en el esquema y el capacitor aparece con polaridad contraria en el equematico , estan marcados en rojo. gracias de antemano.
 

Adjuntos

  • tl494---2.1-pcb-real.jpg
    tl494---2.1-pcb-real.jpg
    277.6 KB · Visitas: 57

DOSMETROS

High 2m Modereitor
Sigue el esquemático y pon la polaridad correcta según esquemático , sinó el electrolítico pegará contra el techo :LOL:.

No entendí cual es la resistencia , por favor marcala dibujándola en el esquemático. Gracias
 
Gracias por tu pronta respuesta querido amigo esta subrayado con circulo rojo, lo de la reistencia en la board, la que esta en medio del electrolitico y el no polarizadoy esta no aparece en el esquematico debe ir etre los pines 11,12 y 8 del tl 494 y el colector del bc337 segun la pcb ; de que valor sera esta resistencia adjunto imagenes.
gracias de antemano.
 

Adjuntos

  • esquematico.jpg
    esquematico.jpg
    181.2 KB · Visitas: 90
  • tl494---2.1-pcb-real.jpg
    tl494---2.1-pcb-real.jpg
    291.2 KB · Visitas: 81
Lo del capacitor es correcto , el garabato de la resistencia no lo entiendo
Disculpa pero no soy bueno editando imagenes, en el esquemático no aparece ninguna resistencia entre los pines 11,12 y 8 del tl494 y el colector del bc 337 subraye con rojo el nodo en donde debía ir la resistencia en el esquemático; además indiqué en la pcb la resistencia, espero que me entiendas mira bien no se de que valor es eaa resistencia.

Por favor alguien puede colaborar, no lo he podido montarlo por eso; hay un condensador no polar y una resistencia en serie que va a el colector del bc 337 no se como montaron eso el esquemático esta incompleto por favor alguien podria darme esos valores.
Fiíense en la foto estan.
Gracias
 

Adjuntos

  • pcb1.jpg
    pcb1.jpg
    284.8 KB · Visitas: 41
  • pcb2.jpg
    pcb2.jpg
    419.2 KB · Visitas: 65
  • esquematico.jpg
    esquematico.jpg
    181.2 KB · Visitas: 74
  • ampli21_terminado.jpg
    ampli21_terminado.jpg
    92.6 KB · Visitas: 56
Última edición por un moderador:
por favor no he podido terminar el proyecto por que no se el valor de esta resistencia y el condensador alguien podria colaborarme adjunto imagen,ampli21_terminado.jpg es la que esta dentro del circulo negro estoy que lo pongo a sonar y no he podido
 
Buenas tardes, en esta cuarentena obligatoria que hay en algunos países incluyendo este, me puse a montar este amplificador pero en full-bridge en el protoboard ver primera foto, este suena bien tiene buenos bajos etc.
Segunda foto es una onda de 60 Hz estoy obteniendo 10wrms con 12vdc y trabaja frío aunque tengo un pequeño ringing en la salida antes del filtro Ver 3ra foto pero no tengo mayor inconveniente con eso.
Se me presenta un inconveniente con este amplificador tal vez sea por la simpleza de su diseño y es que cuando no tengo música a la entrada suena con un silbido de alta frecuencia viendo en el osciloscopio tengo un ruido de 2vpp aprox ver última foto, me preguntaba que es ese ruido y que lo produce?, por qué solo suena cuando no hay música?, puede ser batido de frecuencia con la fuente de pc? Otra cosa ese driver no creo que sea muy sano para los mosfet a un voltaje mayor, como limitó el voltaje de gate sin complicar el diseño, pues como lo dice el autor no vale la pena complicarlo.

Gracias por leerme.
 

Adjuntos

  • IMG_20200423_170747952.jpg
    IMG_20200423_170747952.jpg
    326.1 KB · Visitas: 26
  • onda seno.jpg
    onda seno.jpg
    68.9 KB · Visitas: 25
  • salida.jpg
    salida.jpg
    78.4 KB · Visitas: 19
  • ruido.jpg
    ruido.jpg
    82.9 KB · Visitas: 20
Última edición:
por favor no he podido terminar el proyecto por que no se el valor de esta resistencia y el condensador alguien podria colaborarme adjunto imagen, es la que esta dentro del circulo negro estoy que lo pongo a sonar y no he podido

@higuita: Hace anios que no ingreso al foro, me mude de pais y logicamente no me traje las cosas. Realmente no recuerdo mucho pero es muy posible que esa resistencia es realmente un inductor de 10mH, o podes usar una R de unos pocos ohm (digamos 10 ohm maximo) era, creo, un simple filtro RC.
El capacitor esta bien en el esquematico. El terminal + esta a GND porque el terminal negativo esta a -0.2v

Desde esa epoca hasta ahora aprendi muchisimo mas, y tambien a usar mejores soft como Kicad :) pero ya no tengo tiempo para seguir mi hobby, lamentablemente.
Buenas tardes, en esta cuarentena obligatoria que hay en algunos países incluyendo este, me puse a montar este amplificador pero en full-bridge en el protoboard ver primera foto, este suena bien tiene buenos bajos etc.
Segunda foto es una onda de 60 Hz estoy obteniendo 10wrms con 12vdc y trabaja frío aunque tengo un pequeño ringing en la salida antes del filtro Ver 3ra foto pero no tengo mayor inconveniente con eso.
Se me presenta un inconveniente con este amplificador tal vez sea por la simpleza de su diseño y es que cuando no tengo música a la entrada suena con un silbido de alta frecuencia viendo en el osciloscopio tengo un ruido de 2vpp aprox ver última foto, me preguntaba que es ese ruido y que lo produce?, por qué solo suena cuando no hay música?, puede ser batido de frecuencia con la fuente de pc? Otra cosa ese driver no creo que sea muy sano para los mosfet a un voltaje mayor, como limitó el voltaje de gate sin complicar el diseño, pues como lo dice el autor no vale la pena complicarlo.

Gracias por leerme.

Correctisimo! mucho despues de este ampli aprendi mas y definitivamente subir el voltaje no va a ser sano para los gate de los mosfets. Minimamente habria que ponerle un zener a cada uno (para seguir con la filosofia de sencillez)

Sobre el ruido, no lo recuerdo. En esa epoca solo disponia de un multimetro asi que tampoco tuve oportunidad de evaluarlo demasiado, mas que a oido.
 
Arriba