Ayuda con transmisor y receptor 433 mHz

Hola amigos.
Tengo un pequeño problemita con un circuito. tengo una fuente de 5V-1A, y a ésta fuente estoy conectando un receptor 433mHz para prender un rele de 5V.
Mi problema es que de el receptor sale una corriente de 13.6mA y el rele necesita minimo 60mA para funcionar.
Intenté conectar un transistor 2n2222a para poder permitirle al rele que tome mas corriente desde la fuente pero pasa algo muy raro, la corriente sube a 64mA por un segundo y vuelve a bajar, y sube otra vez por un segundo y vuelve a bajar.

Adjunto una imagen y les dejo un link de un video de algunos segundos para que vean lo que está pasando, tal vez me pueden ayudar.


Gracias de antemano.
 

Adjuntos

  • WhatsApp Image 2020-07-11 at 22.16.18.jpeg
    WhatsApp Image 2020-07-11 at 22.16.18.jpeg
    141.4 KB · Visitas: 9
Hola, gracias por responder tan rapido, éstas son las conexiones, todavía no aprendo rápido como hacerlas un digital con Proteus, entonces te las mando a mano
 

Adjuntos

  • WhatsApp Image 2020-07-11 at 23.16.02.jpeg
    WhatsApp Image 2020-07-11 at 23.16.02.jpeg
    86.1 KB · Visitas: 13
Pero sucede que el Rx entrega una trama de datos. No puedes así nomás inyectarle a un transistor, debe primeramente ingresar a "algo" que decodifique esa trama y luego accionar el relé.
Por otro lado, investiga cómo polarizar un transistor, falta una resistencia de base.
Y cómo protección cuándo usas cargas inductivas, cómo un relé, se requiere de un diodo volante.
 
Correcto amigo, traté con resistencias de base para el transistor de 10K, 1K, 330, 220, pero no me prendía ni siquiera un segundo, por eso opté por no usar resistencia, y con respecto al diodo si lo voy a poner solamente quería probarlo antes de ensamblarlo en rele, y perdón por mi ignorancia en todos éstos temas pero según yo el transmisor y receptor que compré es para ponerle un rele o directamente o con un transistor, te dejo el link del video en dónde se muestra conectado del Rx al transistor y de ahí al rele

MINUTO 12

Éste es el link del micro receptor Control Remoto Emisor Y Receptor Rf 4 Canales 315mhz - $ 79.00

M e parece que ya trae un decodificador integrado, pero en todo caso si me equivoco podrías decirme por_favor hacia que lo tengo que conectar para decodificar la señal o el input por_favor

Muchísimas gracias
 
Comprueba que integrado posee la placa. Según el datasheet (amigo siempre del ignorante) hay dos tipos: PT2272-Mx o PT2272-Lx. La diferencia esta en las ultimas letras: Mx = momentáneo, osea la salida estará activa mientras pulses la tecla (momentary) y Lx = La salida quedara activa hasta que presiones otra tecla (Latch).
Y, como dijeron mas arriba, no olvides la resistencia de base y el diodo en el relé.
 
Comprueba que integrado posee la placa. Según el datasheet (amigo siempre del ignorante) hay dos tipos: PT2272-Mx o PT2272-Lx. La diferencia esta en las ultimas letras: Mx = momentáneo, osea la salida estará activa mientras pulses la tecla (momentary) y Lx = La salida quedara activa hasta que presiones otra tecla (Latch).
Y, como dijeron mas arriba, no olvides la resistencia de base y el diodo en el relé.
En efecto el chip que trae el Rx es el PT2272-M4

Ya agregué la resistencia de base según lo que trae el fabricante del Rx de 3.7K y el diodo para el rele, pero ningún cambio, sigo sin poder activar el rele.

Aviso del moderador : 05) Escribe de manera correcta y legible para todos. Estás en un Foro no en un Chat.
Esto incluye emplear signos de puntuación e interrogación, comenzar un renglón nuevo con mayúscula, Etc. No nos gusta la escritura "En Bloque"
 
Última edición por un moderador:
Como te dijeron, el integrado que tienes es momentaneo, por ende solo va activar por un lapso minimo de tiempo, luego desactiva.
Si quieres que encienda o apague con CADA pulsacion, puedes o cambiar el receptor por uno con lacth, o colocar a la salida algun integrado flip flop, o discreto, como el que sigue...

Biestable.png

Biestable - Wikipedia, la enciclopedia libre
 
Última edición:
Llevemos todo a lo mas básico. Cambia el motor por un led con una resistencia de 220ohm en serie.

- Si se mantiene presionada la tecla del transmisor, el LED ¿ Queda prendido mientras se presiona, o lo hace brevemente ?
- Desconecta la base del transistor del modulo receptor y conectala, mediante una resistencia de 1k, a positivo. ¿ Se prende el LED ? Si ahora conectas el relé, ¿ también se activa ?
 
Llevemos todo a lo mas básico. Cambia el motor por un led con una resistencia de 220ohm en serie.

- Si se mantiene presionada la tecla del transmisor, el LED ¿ Queda prendido mientras se presiona, o lo hace brevemente ?
- Desconecta la base del transistor del modulo receptor y conectala, mediante una resistencia de 1k, a positivo. ¿ Se prende el LED ? Si ahora conectas el relé, ¿ también se activa ?

Hola amigo gracias por contestar. el led queda prendido todo el tiempo que yo presiono en botón en el control, cuando dejo de presionar se apaga el led en ese instante.

Respecto a conectar la base del transistor con una resistencia de 1K a positivo el rele si funciona perfecto, también se prende el led, es solamente cuando conecto la base del transistor a la salida del Rx que funciona como debería
Muchas gracias de antemano.
 
Agrega otro transistor conectándolo en una configuración darlington y no olvides de la resistencia de base en el primer transistor.
Según el datasheet el integrado entrega maximo 6ma y el 2n2222 no es de gran ganancia que digamos, quizá ahí se encuentra el error.
 
Arriba