Circuito LM3914 + 4N25 + CD4001

Hola,

los molesto para saber si alguien logra darse cuenta del error del circuito que estoy implementando. El mismo lo estoy implementando como sensado de nivel de batería y sería la entrada digital a un PLC Siemens.

Se trata de dos circuitos, uno que indica el nivel de batería a través de una serie de leds conectados al LM3914 (el cual está funcionando perfecto, 11,5v solo un led prendido y con 14,3 los 10 ldes prendidos) y enganchado a la salida de LM (pines A1/A2 ó B1/B2) un circuito que supuestamente generaría un "1" (5v) o un "0" (0v) compuesto por un 4N25 junto con una CD 4001.

El ciruito asociado al LM funciona perfecto y el segundo circuito no funciona, no genera nada.

Cualquier información será bienvenida!!.

Gracias de antemano!!!
 

Adjuntos

  • sensado de Nivel.jpg
    sensado de Nivel.jpg
    176 KB · Visitas: 57
  • MEDIDOR_Y_CONTROLADOR_DE_CARGA_DE_BAJO_COSTO_PARA_ACUMULADORES_UTILIZADOS_EN_PEQUENAS_CENTRALES_.pdf
    404.7 KB · Visitas: 24
Debes colocar un Transistor entre la salida del LM y los optos, deseas activarlo con el estado bajo y si miras tu circuito del LM cuando sucede, la tension en ese pin seria la del LEd, pero esa misma tension se la envias al LED del opto + una resistencia, ahi esta tu error, coloca un Tr que se sature con el estado bajo del LM y este a su vez coloque un + para tu opto, chauuuuu

PD, mirando tu circuito no veo el pq usar OPTOs si no hay aislamiento, podes colocar directamente la señal del LM al latch SET-RESET en cuestion y listo.

PD2 mirando aun mas tu circuito ese latch set reset con compuertas NOR mmmm no creo, creo que seria con compuertas NAND CD4011, mmmm
 
Última edición:
Gracias por la respuesta,

te cuento que el circuito está armado y lo que me desorienta un poco es que cuando yo le entrego una tensión baja que prenda, por ejemplo, el led 1 la tensión en todas las salidas del LM son aproximadamente 8,5v y cuando le entrego una tensión mayor que por ejemplo prenda 8 leds, la tensión en todos los terminales asciende a 10v o más. Es decir,todas las salidas trabajan igual.

Mi necesidad es colgarme del circuito LM y poder indicarle al plc con un "1" o con un "0" si la tensión estaba bien o mal; pero creo que si el LM trabaja con todas las salidas iguales lo veo dificil.

Saludos
 

Dr. Zoidberg

Well-known-Papá Pitufo
Pregunta:
Cuando van a entender que las salidas del LM3914/15/16 son FUENTES DE CORRIENTE CONSTANTE y no trabajan "por tensión"????
De que sirve medir voltaje en las salidas del LM si esa tensión depende la caída en uno o más diodos LED????
 
Arriba