Creación de documento diagnóstico para circuitos en PCB

Buen día, tengo que realizar un documento diagnóstico para el siguiente circuito.
El U1 es un 74HC540
El U2 es un TD62083
El U3 es un 74HC06
Ya cree un documento diangóstico, el cual es el que adjunto.
El problema que tengo es que cuando conecto la pcb, esta a veces truena, otras veces no, pero no sé a que se deba, esto solo pasa cuando tengo conectada la fuente de 5v y la de 12v al mismo tiempo, adjunto video.
Algo que también pasa, es que al energizar las terminales llamadas Relay1-8, este debería energizar el U1, que a su vez, energiza el U2, y este hace que los relevadores conmuten, lo cual no hace desde las terminales Relay, pero si lo hace directamente si pones los 5v en las entradas del U2, otra cosa, es que al poner 5v al U1, no pasa nada, pero si pongo una punta de multimetro, empieza a energizarse, como un corto, algo extraño, adjunto video, en el video se ve como el cambio en la potencia en la fuente de 12v, pero está raro, porque la de 12v y la de 5v no tienen nada que ver, no sé si esté haciendo un corto, pero les agradecería mucho su ayuda, estaré pendiente por si les surge una duda.
 

Adjuntos

  • Foros 2.rar
    9.6 MB · Visitas: 10
  • Foros.rar
    5.1 MB · Visitas: 13
Primeramente tienes un error en el esquema, el pin 10 de U2 va a GND no a 12v. Como está conectado ahora están sufriendo los transistores internos al conmutar los relés, vas a terminar rompiendo U2. Cortar la pista y corregir con un cable es la solución rápida y fácil.

Verifica que el pin8 de U3D esté a GND sino no se habilita U1 y que la alimentación del mismo llegue bien a sus respectivos pines.

Por ultimo, U1 es un inversor, esto quiere decir que todos sus pines deberían estar a 5V para apagar los relés y a GND para encenderlos que, por cierto, ahí veo un segundo error al no colocar resistencias de pull-up. Tal vez de ahí que "oscilen" los relés puede que sea por el ruido de linea captado cuando conectas la punta de prueba.
 
Primeramente tienes un error en el esquema, el pin 10 de U2 va a GND no a 12v. Como está conectado ahora están sufriendo los transistores internos al conmutar los relés, vas a terminar rompiendo U2. Cortar la pista y corregir con un cable es la solución rápida y fácil.
Mmm, pero el pin 9 ya lo tengo a tierra, el COMM va a 12v, el pin 10 en la datasheet del componente va a 12v

Verifica que el pin8 de U3D esté a GND sino no se habilita U1 y que la alimentación del mismo llegue bien a sus respectivos pines.
No entiendo lo del U3D, o sea, en el pin 9, lo tengo a 5v, en la salida lo mando a tierra y a su vez al pin 19 del U1?, así?

Por ultimo, U1 es un inversor, esto quiere decir que todos sus pines deberían estar a 5V para apagar los relés y a GND para encenderlos que, por cierto, ahí veo un segundo error al no colocar resistencias de pull-up. Tal vez de ahí que "oscilen" los relés puede que sea por el ruido de linea captado cuando conectas la punta de prueba.
Sí, es un inversor, pero el U2 también lo es, entonces sería tipo, A * A = A, o sea, el valor que metas, va a salir igual.
 
Última edición:
Mmm, pero el pin 9 ya lo tengo a tierra, el COMM va a 12v, el pin 10 en la datasheet del componente va a 12v

Tienes razón, error mio. Ese pin va a 12V.

No entiendo lo del U3D, o sea, en el pin 9, lo tengo a 5v, en la salida lo mando a tierra y a su vez al pin 19 del U1?, así?

Esa placa tiene "dirección" para funcionar, parece que esta diseñada para ser conectada junto con otras para ampliar el sistema. Si no la seleccionas -colocando la dirección de la misma-, nunca aceptará las entradas. Por eso decía que compruebes que esta todo correctamente seleccionado y que los niveles de entrada y salida sean los correctos para que los circuitos integrados estén habilitados.

Sí, es un inversor, pero el U2 también lo es, entonces sería tipo, A * A = A, o sea, el valor que metas, va a salir igual.

Todo muy lindo pero aquí mi pregunta: ¿ Que nivel lógico (En este caso es de lógica de 12V) necesita el relé para activarse ?. Ahora aplica lo que expones de la doble negación ¿ Que nivel lógico de entrada a la placa activa el relé ? (Que, por la doble negación, es el mismo que activa el relé).
 
Todo muy lindo pero aquí mi pregunta: ¿ Que nivel lógico (En este caso es de lógica de 12V) necesita el relé para activarse ?. Ahora aplica lo que expones de la doble negación ¿ Que nivel lógico de entrada a la placa activa el relé ? (Que, por la doble negación, es el mismo que activa el relé).
Cuando yo meto los 5v, directo a las entradas del U2, ahi si activa la conmutacion de los relays, pero no se porque no lo hace desde el U1
 
Todo eso sucede porque sacas conclusiones sin tener "TODOS LOS DATOS" a la mano:

1.- Debes tener delante los esquemáticos (Data-Sheet) de los integrados involucrados en esa placa: 74HC540, TD62083, 74HC06.
2.- Debes leer los Data-Sheets de cada uno y entender exactamente cómo funciona cada uno.
3.- Luego puedes comenzar a jugar.

U2 es un conjunto de Transistores Darlington que se usan para poder soportar la carga de 3 bobinas de relay c/u. Solo requieren recibir un "I" Lógico (+5V en tu caso) en cada entrada para que su salida se vuelva "0" lógico (Digamos que GND), para que se activen los relays conectados a la correspondiente salida.

U1 no funciona directamente, como tú piensas. Es un "Octal buffer/line driver; 3-state; inverting", el cual requiere el cumplimiento de "TRES CONDICIONES LÓGICAS" para que funcione, y estas están representadas en la página 4 del Data-Sheet. Mientras esa condiciones no se cumplan, no habrá "Is" Lógicos en las entradas de U2 que activen que activen los relays.

Los pines 1 y 19 de U1 corresponden a "2 señales Lógicas" que sirven para activar las salidas "Ynn" de tu placa y esas entradas son controladas por la señal de control indicada en el conector de la placa, como ADDR1. Mientras ADDR1 permanezca a "I" Lógico, no habrán "I"s Lógicos en las salidas "Ynn" de U1.
Para que eso ocurra, deberás poner a "0" Lógico (GND, masa) ADDR1, luego aparecerán activados los relays, según sean seleccionados vía conector "Relay-n".

NO ES NECESARIO utilizar una fuente externa para activarlos. Solo debes conectarlos uno a uno al conector "+5V", despues de haber conectado ADDR1 a "0" Lógico (GND).

Prueba y nos cuentas...

P.D.: Cuando se habla de LÓGICA, se habla de Niveles Lógicos, NO VOLTAJES.
" Is y 0S" (unos y ceros).
 
Arriba