Duda con tansmisor-receptor RF

#1
Buenas tardes expertos, les comento que arme el circuito E-R RF que esta adjunto, resulta que después de matarme la cabeza un buen rato buscando el por qué no funcionaba, me di cuentan con el multímetro que cuando accionaba el emisor en el receptor tenía un 0v y cuando dejaba de accionar el receptor tenia 5v, mi duda es: es así como en realidad debería funcionar el circuito?
De antemano gracias y saludos!!!
 

Adjuntos

Daniel Lopes

Miembro Geconocido
#2
Hola Yorman Godoy, ! saludo cordiales ! , ? en que punto del circuito receptor usteds tiene esa medicione que describes ?
Att.
Daniel Lopes.
 
Última edición:
#3
hola daniel lopes!, en la salidas del receptor (pin 10, 11, 12 y 13 del HT12D), es decir si coloco los leds de manera invertida es que funciona puedes ver en el archivo que esta adjunto que en cada salida del HT12D tiene un led, a mi lo que me extraña es que esos pines tienen 5v y cuando activo el emisor (HT12E) los pines del receptor (HT12D) se ponen en 0v... no se si me entiendes!... saludos!
 
#4
Para activar los leds deberías enviar todos 0's, de esa forma cerrás el circuito de leds.

Suponiendo que está todo bien conectado hacé esta prueba:

1- Poné la dirección del codificador en 0 (transmití en el canal 0), no dejes en el aire ningún pin (no recuerdo si era el deco o el cod el que tenía pull-up interno).

2- Poné la dirección del decodificador en 0 (recibí en el canal 0), no dejes en el aire ningún pin (no recuerdo si era el deco o el cod el que tenía pull-up interno).

3- Así como tenés el circuito, el transmisor manda tooooodo el tiempo datos, si estás usando protoboard, te recomiendo en el codificador, hacer que /TE vaya a Vcc usando un pull-up y mediante un pulsador o cable mandarlo a masa c/vez que quieras enviar un dato.

4- Usando el pin VT del decodificador, verificá que llegó bien el dato.
 

Daniel Lopes

Miembro Geconocido
#5
hola daniel lopes!, en la salidas del receptor (pin 10, 11, 12 y 13 del HT12D), es decir si coloco los leds de manera invertida es que funciona puedes ver en el archivo que esta adjunto que en cada salida del HT12D tiene un led, a mi lo que me extraña es que esos pines tienen 5v y cuando activo el emisor (HT12E) los pines del receptor (HT12D) se ponen en 0v... no se si me entiendes!... saludos!
Bueno con certeza las salidas del receptor (HT12D) son colectores abiertos y quando activos estan saturados a tierra , portanto para que se acienda el LED ese tiene que tener su anodo a el positivo y el catodo a el salida "colector abierto" , si quieres la logica inversa , canbie el LED por uno resistor de 1Kohmios ( tanbien conocido como resistor "pull-up" )y adicione una puerta logica inversora tipo 7404 en cada bit del dato.
Att.
Daniel Lopes.
 
#6
gracias @cosmefulanito04 y daniel lopes, entoces para concluir la forma en que esta funcionando el circuito es la correcta, es decir, el diagrama del cual copie el circuito trabaja como les mecione?
De antemano gracias!
 

Temas similares

Arriba