Duda inversor usando Arduino

#1
Buenas noches, este inversor utiliza el arduino en reemplazo de un generador de ondas (555, lm's) , la cual hace oscilar en una frecuencia regulable con un potenciometro, le coloqué unos leds para diferenciar cuándo la frecuencia es alta o baja (el código y el esquema lo dejo adjunto para que lo revisen) y estos leds van directo a los mosfets switcheando la corriente y llegando a un transformador de 12 volts- a 220 volts, mi circuito inversor (adjuntado) lo alimento con una batería recargable de 12V y 7AH.
Para la conexion del esquema del arduino al circuito del inversor conecté del catodo de un led (que vendría a ser la señal que viene del arduino) al Gate de un mosfet, y al otro led le hice lo mismo (con el otro mosfet), al final no logro invertir nada, me sale 0 volts en la salida y no sé en que me esté equivocando, por favor ayúdenme :confused: , gracias



Si van a probar la programacion del arduino cambien las salidas digitales por el 3 y 4 en la misma programacion.
 

Adjuntos

Última edición:
#2
Hablas de mosfet pero en el esquema hay bipolares, pones los led sin resistencia limitadora...
Lo raro sería que funcionase y que no rompieses nada.

Por favor, pon el esquema real y el conexionado real que empleaste. Ahora mismo solo puedo imaginar que es lo que está pasando. Así a bulto me imagino que no polarizas bien los transistores.
 
#3
Claro, le puse a cada led una resistencia de 330 ohms y al gate de los mosfets una de 100 para conectarlas a la señal de salida de los leds , todo mi armado esta tal como esta solo que obvie estas resistencias, saludos
 

Temas similares

Arriba