Eliminando ruidos durante el apagado de equipos de audio

Dr. Zoidberg

Well-known-Papá Pitufo
#1
Nota del Modereitor.

Este tema es una derivación de este otro tema:

https://www.forosdeelectronica.com/f31/diseno-amplificador-ocho-canales-109738/


Resulta que desde que armé el NMP, ya casi no he vuelto a usar el CD Player Technics ni el sintonizador Sansui, pero como tengo tres amplificadores stereo diferentes (por que aún no armo este de ocho canales :oops: :oops:) mas el ecualizador para el sistema 2.1, estaba teniendo algunos problemas con la PC que oficia de NMP, por que ocasionalmente se colgaba la placa de red cuando encendía alguno de los amplificadores. El que mas problemas traía era el de los subwoofers y el de los tweeters. El de los subwoofers también solía meter ruido en los midwoofers y en los subwoofers cuando lo apagaba. La secuencia de apagado es tweeters, subwoofer, ecualizador, preamplificador y midwoofers. Esta secuencia no tiene ninguna ciencia (bueno... en realidad apago las fuentes de señal al final)... solo lo hago así por que me queda cómodo recorrer los switchs on-off en ese orden :unsure:, pero al apagar el ampli de los subs, los mids aún está activos y suelen hacer ruido unos u otros.

Yo me imaginaba que el problema venía por los pulsos que generaba el bobinado de los trafos al activar/desactivar el switch on-off de cada equipo.. lo que es una cosa a la que nunca le presté atención, y por supuesto... empezó a molestar. Consulté un compañero de trabajo con mucha experiencia en sistema industriales y casi que me confirmó el diagnóstico y me mostró un aparatejo de marca Siemens (limitador de sobretensión o algo así) que es una red RC que se coloca en paralelo con la bobina de los contactores para que no se generen los impulsos derivados del efecto de la inductancia de la bobina del contactor, que parece que provoca muchos problemas, y es una cosa parecida a esta:



Bueno... preparé una simulación en Simetrix para que ver que onda con el trafo del ampli de los subs, así que le medí la resistencia y la inductancia del primario, que me resultaron 5.2 Ω y 0.563 Hy. El circuito de la simulación es el que sigue:

simu-trafo-2x80.png

y la primera prueba la hice solo con el transformador y el switch activado luego de 105 ms de iniciada la simulación y cerrado durante 110 ms. El resultado fué este:

pico-trafo-2x80.png

Vean el picacho de 2.8 kV durante 1 ms :eek: :eek:... como se imaginarán, los protectores de parlante aún no se han dado cuenta que desaparecieron los 220V :cry: y el pico ya pasó metiendo ruido.
Luego pensé en probar con un varistor de 250 Vrms (325 de pico).. y no pude conseguir el modelo PSPICE del varistor Bourns que venden por acá, pero encontré uno de TDK-Epcos bastaaaaante parecido y lo probé con ese:

pico-trafo-2x80-Varistor.png

El varistor lo clava en 500V de pico, pero la oscilación generada por la bobina se vuelve insoportable... así que el varistor solo no es buena idea
.
Luego ensayé solo con redes RC, y me gustó lo que conseguí con 1K y 470nF (me gustó por que también la probé con otros modelos de trafos y anda igual de bien... completamente lo contrario que sucede usando el típico par 100nF y 100Ω... por que oscila igual que con el varistor :eek:). Esto es lo que resultó:

pico-trafo-2x80-RC.png

Fíjense que ataja el pico en mas o menos 570V pero la oscilación dura medio período y el pico se ensancha, lo que baja la cantidad de interferencia por RF :aplauso:. Ahora lo probamos con el varistor y la red RC para ver si mejora:

pico-trafo-2x80-RC-Varistor.png

Como ven, el pico ahora se atenúa en 100V más (queda en 450V .. mas o menos) y la atenuación de la red RC se mantiene, así que vamos bien. El varistor también queda por otro motivo: el trafo no tiene fusible térmico que lo proteja contra una sobretensión mantenida a la entrada (como cuando se corta el neutro y LPMQLP :() y si esto sucede, el varistor se pondrá en corto y volará el fusible que está a la entrada, así que me gusta!!! :babear:

Bien, ahora hay que armarlo para probar que tal va en la vida real. Primero juntamos los componentes:

06-componentes.jpg

Armamos un engendro para sujetar todo esto sobre el par de cables del primario del trafo:

07-montaje1.jpg

Le ponemos un poco de cinta aisladora para evitar "problemas"...

08-aislados1.jpg

Y le metemos termocontraíble del gordo para proteger los componentes...

09-aislado-termo.jpg

Me falta otra foto en la que cubrí de nuevo con cinta las partes potencialmente expuestas y luego tuve que rearmar el amplificador. Cuando pueda reconectar todo vuelvo con los resultados.

PD: El .zip adjunto contiene la simulación en Simetrix 7.2

PD2: Estuve un rato escuchando música y jugando con el ampli de los subwoofers. Le cortaba la alimentación en el medio de la reproducción y no se escuchaba ningún ruido en ningún parlante. También lo hice siguiendo la secuencia normal de apagado... y nada... ni un ruido. Parece que el coso anda!!!
Lo unico malo es que con el simulador recalculé la potencia que disipa la resistencia y resulta ser 1.2W (yo usé una resistencia de 2W... a ojo) y parece que hay que cambiarla por una de mayor capacidad de disipación. Por desgracia cerré el ampli ante de usar el dedo para medir la temperatura... así que me parece que voy a tener que desarmarlo nuevamente.
 

Adjuntos

Última edición por un moderador:

Dr. Zoidberg

Well-known-Papá Pitufo
#2
Confirmado: La resistencia calienta "bastante" (no quema pero se siente pesada al tacto), así que probé cambiando los valores RC y manteniendo constante su producto --> R=4K7 y C=100nF.
El resultado - en simulación - es casi exactamente el mismo (de hecho la onda se amortigua un poco más rápidamente) pero la disipación de potencia en la resistencia es la cuarta parte (mas o menos), así que voy a tener que cambiarlos...

snubber-220V-menosPotencia.png

El problema es que el valor elevado de la resistencia no alcanza para amortiguar el pico si se usa sin el varistor, entonces este se vuelve obligatorio. Ver la siguiente figura:

11-pico-trafo-RC-4K7y100n.png
donde el pico se ataja un poco pero continúa elevado por arriba de 1 kV :eek:. Parece que la resistencia tiene que ser mas pequeña y probamos con 1K5 y 330 nF (que dicen que son los valores que traen los limitadores industriales :confused:). Veamos que sale sin el varistor:

12-pico-trafo-RC-1K5y330n.png
... un poquito peor que con 1K, pero con el varistor ni se nota:

13-pico-trafo-RC-1K5y330nyVaristor.png

Si graficamos la potencia para cada combinación RC se tiene lo siguiente:

14-potencia-supresores.png

donde el rojo es 4K7+100nF, el azul es 1K5+330nF y el morado es la 1K+470nF.
Saquen ustedes las conclusiones...

PD: En el peor caso, la resistencia ni siquiera cambia de color luego de 30 minutos conectada a 220V la red RC, solo calienta mas de lo debido como para estar encerrada en una funda termocontráctil. No le tengan miedo a ese valor por que no va a agarrar fuego ni nada por el estilo, pero no me sorprendería que degenerara un poco su comportamiento.

Bueno... me hice un rato y conecté cada red RC a los 220V :eek:. Pretendí medir la temperatura de las resistencias con un termómetro infrarrojo UT300S que le compré a los amigos chinos por un precio muuuuy ventajoso (lo compré para medir la temperatura de los disipadores), pero la medida no anduvo por que el área del foco es mas grande que la resistencia de 2W y toma la temperatura alrededor... o sea, del aire.. y estaba fresco.. a mas o menos 16ºC. Por eso, la medí con el dedo :cool:.
Tomen esto solo como una indicación mas o menos aproximada:

R=1K --> Temp ≈ 50ºC (o quizás un poco mas)
R=1K5 --> Temp ≈ 30ºC (tibia)
R=4K7 --> Temp ≈ 20ºC (casi fría)

La decisión entonces es usar la pareja 1K5 y 330nF para los próximos supresores de picos.

Moraleja: Por tres trumps me he divertido como 10 hs... no es buena la electrónica???
 
Última edición:
#4
Buen dia,

Estoy viendo de armar un ampli, pero creo que me va a llevar dos transformadores con bastante filtrado cada uno y por lo que entiendo, me va a convenir colocar un soft-start para cada trafo (o podra ser uno solo :unsure: en total 700va)

Mi duda con esta protección es si tengo que colocarla en cada primario o solo colocar una en la entrada principal...

gracias!
andres
 

shevchenko

Well-known-Ruso
#5
Buen dia,

Estoy viendo de armar un ampli, pero creo que me va a llevar dos transformadores con bastante filtrado cada uno y por lo que entiendo, me va a convenir colocar un soft-start para cada trafo (o podra ser uno solo :unsure: en total 700va)

Mi duda con esta protección es si tengo que colocarla en cada primario o solo colocar una en la entrada principal...

gracias!
andres
calcula que te conviene más...
si 2 de menor potencia o 1 solo más grande... ya sea por precio/disponibilidad
 

Fogonazo

Exorcista & Moderador eventual
#6
Este tema se llama: "Eliminando ruidos durante el apagado de equipos de audio"

No se comenta nada en el sobre "soft-start", ¿ Por que la consulta aquí ?

También se debe considerar si los 2 transformadores alimentan el mismo circuito, por ejemplo uno el rail positivo y el otro el rail negativo. Si fuera este el caso deben encender y conectarse a un mismo tiempo, no sería bueno un delay de uno respecto al otro.
 
#7
Este tema se llama: "Eliminando ruidos durante el apagado de equipos de audio"

No se comenta nada en el sobre "soft-start", ¿ Por que la consulta aquí ?

También se debe considerar si los 2 transformadores alimentan el mismo circuito, por ejemplo uno el rail positivo y el otro el rail negativo. Si fuera este el caso deben encender y conectarse a un mismo tiempo, no sería bueno un delay de uno respecto al otro.
Hola,

El comentario del soft-start fue solo para poner en situación, perdón si se entendió otra cosa. Los trafos alimentan etapas diferentes.

Lo que pasa con estos picos en los tranformadores seria lo mismo que pasa en los relays en donde la proteccion es un diodo que actua al apagarse el relay, cierto?

Por eso, vuelvo a la pregunta, si en este caso la proteccion va en cada trafo o se puede usar una en general?

gracias
Andres.
 

Fogonazo

Exorcista & Moderador eventual
#8
Hola,

El comentario del soft-start fue solo para poner en situación, perdón si se entendió otra cosa. Los trafos alimentan etapas diferentes.

Lo que pasa con estos picos en los tranformadores seria lo mismo que pasa en los relays en donde la proteccion es un diodo que actua al apagarse el relay, cierto?

Por eso, vuelvo a la pregunta, si en este caso la proteccion va en cada trafo o se puede usar una en general?

gracias
Andres.
Sigue como válida la respuesta de shevchenko, hay que hacer un pequeño análisis de costos.

Se me ocurre que al alimentar etapas distintas con un solo circuito y reforzando el relee estará bien.
 

Dr. Zoidberg

Well-known-Papá Pitufo
#9
Antes de decidir haria una simulacion con la inductancia de los dos trafos y con la de uno y veria el pico que se produce y la mejor combinacion RC para atenuarla.
Hasta donde he probado, el par 1K5 + 330nF anda muy bien en la mayoria de los casos, pero vale la pena verificarlo/reajustarlo por simulacion. Esto es por que los varistores se van dañando por los picos y es bueno conocer la cantidad y tamaño de los picos para que duren lo mas posible.
Mi ampli de 40+40W tiene dos trafos, uno de 150VA y otro de 20VA para el pre, y le puse un solo mata-pulso y anda joya....
 

Dr. Zoidberg

Well-known-Papá Pitufo
#10
Estoy viendo de armar un ampli, pero creo que me va a llevar dos transformadores con bastante filtrado cada uno y por lo que entiendo, me va a convenir colocar un soft-start para cada trafo (o podra ser uno solo :unsure: en total 700va)
:confused: :confused: :confused:
No se si vale la pena....
Son trafos toroidales???

Lo que pasa con estos picos en los tranformadores seria lo mismo que pasa en los relays en donde la proteccion es un diodo que actua al apagarse el relay, cierto?
Si, pero con corriente alterna y por eso no valen los diodos...
 
#14
Consulta.
Volviendo al soft-start, dónde conviene colocar el aparatejo, tanto la red RC, como el varistor?, Ya que las resistencias del soft-start variarian el funcionamiento del mismo, no?
 
#16
Me referia a que si esta como;
Entrada220v----llave----aparatejo---softstart----trafo
Quedaria el aparatejo en serie con las resistencias del soft-start, y creeria que no haria de mata-filtro, sino que quizas haga una amortiguacion mas amplia del pico...
Solo especulo en mi mente retorcida... :devilish:
 
#19
Saludos Zoidberg.
Qué combinación de resistor-capacitor (No usar varistor) se debería usar en 110V-60Hz. (Red eléctrica de Cuba)
Gracias de antemano por la respuesta.
 

Dr. Zoidberg

Well-known-Papá Pitufo
#20
Saludos Zoidberg.
Qué combinación de resistor-capacitor (No usar varistor) se debería usar en 110V-60Hz. (Red eléctrica de Cuba)
Gracias de antemano por la respuesta.
El tema importante es la frecuencia, no la tension, asi que podes usar los mismos valores que para 220V.
O podes simular tu caso y ver que sucede.
 

Temas similares


Arriba