GLCD funciona bien en protoboard pero en placa no

Hola.

He estado haciendo pruebas con un GLCD de 128x64 y un 18F4550 en protoboard funcionando perfectamente, con el jaleo de puentes de cables y todo eso.
Llegó el día en que lo quise pasar todo a un PCB y me hice la plaquita, taladré agujeros y soldé componentes, en este caso sólo los componentes básicos, el micro, el cristal (4Mhz) con sus dos condensadores, otro condensador entre más y menos y la resistencia en el MCLR, y el display (nada más pues era sólo para probar), pues resulta que 1 de cada 20 veces funciona bien, el resto, el display no inicializa y muestra puntos aleatorios, como que no arranca como debe.

La cosa es que a veces funciona bien, como en la protoboard, pero la mayoría de las veces no.

¿Alguien sabe qué puedo mirar o en qué hacer hincapié? Las conexiones tengo las mismas que en la protoboard...

Gracias.
Un saludo.
 
No, las mismas conexiones seguro que no tienes.
Si algo no funciona no es porque te tiene manía, es porque hace mal contacto.
Revisa todas las conexiones, recalienta soldaduras, limpia el flux...
 

Daniel Lopes

Miembro Geconocido
Hola a todos , jo creo que faltan aumenta un poco mas la capacitancia de los dos capacitores ceramico disco (lentejas) de 22pF , sendo cada uno conectado en cada estremo del Cristal de Cuartzo para la masa o tierra.
Es possible que la capacitancia parasictica del protoboard tenga ayudado en ese sentido , o sea lo relogio del PIC sienpre arranca (parte) de premera.
No debemos tanbien olvidar del capacitor de desacople de alimentación del PIC , generalmente su valor es de 100nF y si queda lo mas proximo que possible for de los pinos de alimentación (Vdd y Vss).
Quizaz tanbien tengas problemas de "power on reset" , debes estudiar detenidamente la hoja de datos tecnicos del PIC para saper como inplementar un circuito mas eficiente.
!Suerte!
 
Última edición:
He probado y comprobado las cosas un montón de veces y no funciona, así que voy a empezar de cero.
H
aré otra plaquita con algún cambio y así renovaré ideas porque igual estoy repitiendo los mismos fallos todo el rato de las veces que he remirado las cosas.
De hecho he retrocedido, pues ahora ya ni hace amago de inicializarse el display.

¿Cómo hago para quitar el zócalo del PIC? ¿Qué se utiliza para desoldar tantos pines unidos entre sí?

Gracias.
Un saludo.
 
Arriba