Precauciones en simulaciones con Electronics Workbench 5.12

#1
He detectado un inconveniente en el simulador Electronics Workbench 5.12. Precisamente cuando estaba simulando el ripple de una simple fuente de alimentación.

Sucede que la frecuencia de la señal alterna de entrada al puente de diodos la fijé en 50 Hz y su voltaje en 36,3 V RMS correspondiendo a la tensión del secundario de un transformador. Elejí un puente de diodos por default ideal. Fijé una resistencia de carga de 5,5 ohmios y una capacidad de filtrado total de 61.000 uF. Hasta aquí nada raro: fuente de señal alterna + puente rectificador + capacitor + resistencia. Cuando dispongo un osciloscopio virtual en paralelo a la capacidad y/o resistencia (que se encuentran en paralelo a su vez) para visualizar el ripple me encuentro con que en la onda cuasi triangular que constituye el formato del rizado hay algo muy casual y llamativo: la duración de la rampa descendente (que en rigor debiera ser una exponencial decreciente) mide exactamente 7,5 mseg. Pero como esa duración puede situarse por debajo de los 10 mseg no le presté mucha atención en un primer momento: de hecho puede darse ese valor. Luego, modifiqué sólo la capacidad a un valor arbitrario de 100.000 uF, para probar. Entonces, me encuentro con que la duración de esta rampa descendente sigue siendo de 7,5 mseg exactos cuando debiera haber aumentado seguramente por encima de los 7,5 mseg y acercándose poco a poco a casi los 10 mseg a medida que aumentaba la capacidad!!!. Como no sonaba lógico aumenté la capacidad y la duración de esta rampa descendente seguía en 7,5 mseg exactos:enfadado:.

El modelo matemático que utiliza el soft considera un ciclo de descarga fijo de 7,5 mseg para rectificación de onda completa y 50 Hz de frecuencia de línea, es decir, un 75 % del semiciclo. No verifiqué otras condiciones pero lo dejo para uds. probarlas.

Este modelo, en mi humilde opinión, no creo que arroje resultados confiables a no ser que el conjunto R y C (considerando en el cálculo de R las resistencias de los diodos y de perdidas en los cables y transformadores) den 7,5 mseg exactamente.

Pronto subiré una forma de salvar esa situación.

Saludos

PD: sé que hay mejores y más evolucionados simuladores pero quería advertir a quienes lo usan actualmente, como yo. Además, no creo que sea justo mi versión de soft que dé este problema. Si alguien no reporta este problema con la versión 5.12, favor lo comunique.
 
Última edición:
#2
El EWB me gusta mucho porque es tremendamente fácil de usar, pero como simulador deja bastante que desear; puedes hacer cortocircuitos y no pasa nada, algunos integrados están mal definidos etc.
 
#3
No consigo conectar un 7447 con un dispaly de 7 segmentos y hacerlo funcionar en EWB.

Conecto BI LT Y RBI a VCC

y alimento las entradas con VCC las que quiero activar y a GND las que no.

El display siempre se ilumina todos los segmentos.

He leido muchos foros y ya no se q mas probar, para que el circuito me funcione con el Electronics Worbench.


A ver si me puedes echar un cable
 
#8
Esto es lo q leo en la ayuda:

he seven-segment display actively shows its state while the circuit is running. The seven terminals control segments a to g.

a
f | g | b

e | | c
d
When the value at a terminal is high (1), the corresponding segment lights up.
See also:
 
#9
Esto es lo q leo en la ayuda:

he seven-segment display actively shows its state while the circuit is running. The seven terminals control segments a to g.

a
f | g | b

e | | c
d
When the value at a terminal is high (1), the corresponding segment lights up.
See also:
En castellano, es un display de cátodo común que funciona por niveles lógicos, para simular no se quemará si no pones resistencias.
 

Temas similares

Arriba