Proteus , no funciona correctamente el generador de señales o funciones.

#1
Hola.
Buenas tardes, tengo una duda en cuanto a un circuito de Generador de Señales, lo que pasa es que al conectarlo al osciloscopio no veo cambio alguno, solo al conectarlo en la salida del opam numero 3 veo una salida pero solo es senoidal y solo varia en amplitud, y quisiera ver si esteme sirve para variarlo en frecuencia, tipo de señal (entiendase ,cuadrada, diente de sierra y claro senoidal)

bueno estoy muy interesado con esto, el opam que utilice es el ua741
espero y me puedan ayudar con esto, he buscado distintos opams pero el mas economico y el que ya consegui es ese, les dejo el diagrama, espero su pronta respuesta, muchas gracias por su tiempo

saludos
 

Adjuntos

#2
Y si mejor optas por algún integrado que te haga todo el trabajo?

porque no es algo muy simple de hacer...pero con el XR2206 de Exar Microelectronics lo haces al toque
 
#3
No soy muy ducho pues me falta mucha experiencia y se que la experiencia de un aficionado tiene en cierto modo mucha ventaja con los que apenas nos estamos graduando de alguna ingeniería pero intentaré ayudarte...

La primera pregunta es: el diseño lo hiciste tu??

Porque noté varias cosas que en realidad no se si son errores, o tal vez como digo mi falta de experiencia en ver alguna configuración distinta a las que he visto.

Entiendo que el primer AO lo tienes en configuración astable con frecuencia variable a través del potenciómetro, bueno el punto es que envías el pin central a un poco mas allá de la salida del amplificador =S... creo que es más fácil si simplemente cortocircuitas ese pin a algún extremo y utilizas el potenciómetro como una resistencia variable que modificara el tao de tu oscilador

Luego haces un integrador, para obtener supuestamente una señal triangular, esto en teoría está bien si el integrador fuera ideal, pero para que se comporte como un integrador se que el T de entrada (período de oscilación) debe ser mucho menor al tao del integrador, cuando logras obtener una señal aproximadamente triangular, puedes ver que la señal de salida es siempre pequeña, claro luego se puede amplificar, pero siempre tienes problemas con niveles DC y esas cosas.

Con el último integrador definitivamente no vas a obtener ninguna señal senoidal, es una señal cuadrática en realidad, que puede aproximarse a una onda senoidal, y ocurre lo mismo que te mencionaba con el primer integrador.

Si estás empeñado en hacerlo tu mismo, te recomiendo que pruebes poco a poco cada etapa, y que no utilices integradores si mas bien filtros, si a la señal cuadrada le extraes la componente fundamental de frecuencia habrás conseguido una onda senoidal pura... si extraes unas 3 o 4 componentes y las sumas de forma adecuada puedes conseguir la triangular o la diente de sierra... Claro esto requiero un poco de conocimiento en filtros y transformada Fourier... Además de que debes estar consciente que esos amplificadores no soportan mucha frecuencia.

Si quieres ir por el camino más fácil sigue el consejo de DJ DRACO ;)
 
#4
Estoy generando una señal con 5V de amplitud y la mido con el osciloscopio y con un voltímetro DC y me arrojan 1.2V a.c aunque en generador diga que la amplitud es de 5V. ayuda gracias ^^ ...
 

DOSMETROS

High 2m Modereitor
#5
Adivinando , que generador , que circuito , que mide , cómo lo mide , con que impedancia tiene cargado el generador ?

 
Última edición:
#6
Hola Roberto Sánchez

Puede ser por más de una razón.
El generador no sirve, está descompuesto.
La impedancia de salida del generador es mucho más grande que la impedancia del dispositivo a donde estás aplicando esa señal.
Los instrumentos de medición que estás utilizando no funcionan correctamente.
Etc.

Qué generador es: marca y modelo.
A qué le estás aplicando esa señal del generador ?

saludos
a sus ordenes
 
#8
Buenos días.


Roberto Sánchez ha comentado... +

Estoy generando una señal con 5V de amplitud y la mido con el osciloscopio y con un voltímetro DC y me arrojan 1.2V a.c aunque en generador diga que la amplitud es de 5V. ayuda gracias ^^ ...

Cuando hablamos de "Generar una señal", lo normal es que nos estemos refiriendo a una señal AC, pero ...
la mido con el osciloscopio y con un voltímetro DC y me arrojan 1.2V a.c Sic. :eek:

Por favor, aclara...


Sal U2
 
Última edición:
#9
Hola Roberto Sánchez

Que raro, nunca había visto ese defecto en el ISIS de Proteus.
Parece que están alterados los parámetros del Osciloscopio.
Si estas midiendo tambien esa señal con el voltímetro del simulador éste te dará la lectura RMS.

Hice unas pruebas a 5 y 11 volts. Mi osciloscopio da una lectura correcta. Fíjate en las imágenes adjuntas.

Has una prueba con el archivo que te adjunto por favor. Contenido en el .ZIP.
Si te da lecturas correctas es que el osciloscopio, de tu simulador, tiene cambado alguno de sus parámetros.
O probablemente tengas que instalar de nuevo ese SoftWare.

saludos
a sus ordenes
 

Adjuntos

#11
Hola MrCarlos gracias por tu ayuda.
Al parecer si es un problema de mi software, pero podrías hacerme el favor de mostrarme las propiedades del generador para esa simulación que hiciste en la foto? yo adjunto la mía con las propiedades que tiene cuando la amplitud de onda es de 11.4. Jajajjajaj por lo de voltímetro Dc lo siento, escribí mal, es que como no sabía si el problema era el osciloscopio use un voltímetro AC para saber por medio del RMS si la amplitud que arrojaba para la onda estaba mal.
 

Adjuntos

DOSMETROS

High 2m Modereitor
#12
En general los voltajes de los generadores se expresan en Vpp (pico a pico)

Entonces 5 Vp (pico a pico) , es 2,5 Vp (pico) y llevado a rms serìa 1,76 Vrms (si fuera una onda seno)

Saludos !
 
#15
Perdón por lo novato, pero es que en mi informe me piden medir el RMS de una onda cuadrada sin parte negativa aumentandole el offset pero no recuerdo haber mirado cuánto era el voltaje pico :LOL:. Y las mediciones me dieron así : AC: 7.79V y DC: 8.06V mr piden el valor RMS y el valor DC pero calculados analíticamente. Pero no sé cómo se halla eso en la onda cuadrada y sobre todo porqeu los valores son muy parecidos. PDTA: no sé integrar así que no me es de ayuda fórmulas con integrales.

Muchas gracias a quien me pueda colaborar. ...
 
#16

Adjuntos

Última edición:
#17
Saludos!

amigos observen el siguiente circuito generador de señal a continuacion


la señal triangular al correr se pierde, miren aqui:

1)


2)


3)


por que se estara perdiendo la señal triangular?
 
Arriba