Quitar ruido a fritura en parlante.

#1
Hola amigos. Escribo porque tengo un problema con un parlante el cual reproduce mucho ruido a fritura. Es un parlantecito bien pequeño: de 8 Ω / 1 Watt. Lo estoy usando con un pic para que reproduzca tres pitidos de medio segundo entre cada uno cuando un determinado puerto esta en alto (activado) (al presionar un pulsador).
Al circuito general lo estoy alimentando con un cargador de celulares ya que no cuento con otra fuente. Eso tiene que ver con el problema? El cargador es de 6 v. y la corriente No llega a 1 A.

Queria saber si ese ruido a fritura puede ser ocasionado por el cargador como mencione, ya que es una fuente switching. Es la unica fuente que tengo de ese valor y necesito de esos valores.
Y no tengo otro parlante de las mismas caracteristicas.
Coloque un capacitor de 680 µF (electrolitico) en serie con el parlantecito (ver imagen) y el ruido se fue pero cuando presiono el pulsador el sonido que produce es muy tenue y casi no llega a oirse la secuencia de pitidos de manera completa. (Al segundo pitido disminuye el nivel casi a cero).
Revise las soldaduras pero parece estar en orden. Los cables para el audio son de alambres de cobre.. Los comunes.

Hace dos años lo hice andar sin ningun problema, con la misma electronica, la misma placa.
Probe con una bateria de 9 V. y sin capacitor de filtro, pero el problema persiste. al mismo nivel de sonido sigue esa fritura.
Todo lo anterior lo probe, pero No consigo dar con el problema, ni la solucion :confused:

Que puede provocar esto?

Adjunto circuito de conexion del parlante.

Notas:

1). El circuito original no tenia el capacitor conectado. Quizas estoy conectando mal el capacitor. en el capacitor del proteus, el rectangulo a rayas significaria el negativo, verdad? no uso mucho el proteus jaja :D

2). B6 significa que ingresa la señal del puerto B6 del PIC, al circuito del parlante.


Gracias por su ayuda, de antemano :)
 

Adjuntos

#2
Tengo duda, en tu primer intento ¿alimentabas igual al PIC con 6V?, y ¿luego con 9?.

El capacitor así no debe colocarse para el fin que buscas, si no entre la base del transistor y la señal del PIC pero no creo que eso ayude con el problema.

Ahora, como consejo ¿porqué no usar un buzzer?
 
#3
Tengo duda, en tu primer intento ¿alimentabas igual al PIC con 6V?, y ¿luego con 9?.
Si, por? :confused:
EDIT: Lo hice para saber si era la fuente switching de 6v la que metia ruido, probando con la bateria de 9 v.

El capacitor así no debe colocarse para el fin que buscas, si no entre la base del transistor y la señal del PIC pero no creo que eso ayude con el problema.
Ah, el capacitor en paralelo con la resistencia de 4k7? Por qué crees que no?

Ahora, como consejo ¿porqué no usar un buzzer?
Buena idea. Buzzer te referis al de los de computadora de mesa?

Gracias y Saludos!! (y)
 
Última edición:
#4
Con esa tensión de alimentación quizá ya te mandaste al PIC, descarta esto último haciendo una prueba de lectura con tu programador y en caso de que siga vivo ármate un reguladorcito a 5V para su alimentación.

Sobre el buzzer, sip de esos, son para la aplicación que traes en mente, pero busca los que ya tienen un circuito de oscilación integrado porque de lo contrario tendrás que hacer esto último con el PIC y será un poco de lío.
 
#5
Con esa tensión de alimentación quizá ya te mandaste al PIC, descarta esto último haciendo una prueba de lectura con tu programador y en caso de que siga vivo ármate un reguladorcito a 5V para su alimentación.
Uh, lamentablemente no cuenton con el programador, lo programo un amigo. pero mañana hare las pruebas para ver si funcionan las otras entradas y salidas que tengo programadas. es una maqueta de ascensor en realidad jeje..

Sobre el buzzer, sip de esos, son para la aplicación que traes en mente, pero busca los que ya tienen un circuito de oscilación integrado porque de lo contrario tendrás que hacer esto último con el PIC y será un poco de lío.
Ok, mañana lo busco y te comento. ahi tengo una compu que no se usa. donde se ubica el circuito de oscilacion integrado que comentas? porque si se ubica en la mother seria complicado desmontarlo jeje..
 
#7
Ok, ya me fije, y encontre este de la imagen, decime por favor si tiene lo que tiene que tener..
Que tengo que hacer ahora? modifico algo del circuito? :)

EDIT: no tienen la misma apariencia, pero sé que este reproduce los pip de la pc. jajaa
 

Adjuntos

#8
Ese de la imagen no es un buzzer es una bocinita común que debe de someterse a una señal alterna (oscilador) para que suene. Si quieres usar esa en tu diseño puedes armarte un oscilador para la bocina con un 555 y activarlo o desactivarlo para emitir o no el sonido. Ármate este circuito



Al pin 4 del 555 lo desconectas de +5V y en su lugar conectas al PIC, si está en 1 la bocina sonará, en 0 no emitirá sonido.

Recuerda que todo alimentado a 5V ;)
 
#9
Prueba a quitar el condensador de ahí y ponlo junto a la patilla de alimentación del pic. Es decir, el positivo de electrolítico conectado a la patita de alimentación del pic y junto a él físicamente. El negativo del condensador al gnd del pic. Pruébalo.
 
#10
ah, ok. estoy buscando algo que sea sencillo porque el ascensor ya esta funcionando y la plaqueta ya esta montada y con los espacios realmente a medida para que se coloque todo justo. el ascensor ya esta andando pero el problema es ese del parlante.

jsemari voy a probar de hacer lo que sugeris. y luego comento!


Gracias
 
#11
Lo sencillo es buscar el buzzer que te menciono, incluso puedes obtenerlo de un horno de mircroondas, hacer lo del 555 es más complejo pero esa es la opción si es que quieres usar la bocinita que conseguiste
 
#13
Porque ese capacitor sólo altera la impedancia de salida del sistema y desacopla la CD. El problema se soluciona haciéndole llegar una corriente oscilatoria al parlante y no CD. Por eso te recomendaba el buzzer, tú tan sólo te preocuparás por alimentarlo y el internamente oscilará y provocará un pítido continuo.
 
#14
ah, gracias, por aclararmeló. por ahora no mete más ruido con el parlante original, pero si es que lo vuelve a hacer pruebo colocarle el capacitor entre la alimentacion del pic y luego comento que tal me fue. el pic sigue andando le hice unas pruebas de funcionamiento. la bateria que yo use tenia 7 volts en vez de nueve, "zafé" jaja..

Saludos!
 
#16
Disminuye los valores de R1, R2 o C1. Eso aumentará la frec y el sonido será más agudo. Los circuitos se encuentran en la hoja de datos del 555. Saludos
 

Temas similares

Arriba