Transistor y Relay

#1
Hola es mi primer mensaje asi que intentare ser lo mas claro posible.
Tengo un Integrado que cada tanto manda un Pulsito (5V). Lo que necesito es que cuando mande ese pulsito me active un relay. la cuestion es la siguiente. EL relay es de 12V y el mismo activa una carga de 220V. la cuestion es que creo que entre el pulsito y el relay debere conectar un Transistor para activar los 12V.
He probado unos cuantos transistores pero se me queman al rato, recuerdo que habia unos calculos pero no me sale ninguno y ni idea de por que se quema. Alguna idea o algun modelo de transistor para este invento? Muchas Gracias.
 
#2
Hola, yo tuve que solucionar un problema similar al tuyo hace unos días. Y lo hice de la siguiente manera: a la salida del integrado pones una resistencia de 100ohm y ésta, a la base de un transistor (bd437 en mi caso). En el colector del transistor, a modo de resistencia de colector, usas la de la bobinadel rele, y el emisor a masa. El transistor se alimenta con 12V. Ten en cuenta que yo lo hice asi porque la resistencia de la bobina de mi rele es de 250ohm, y es adecuada para este montaje.

Si tienes alguna duda, me la comentas. Y respecto a lo que dices que se te queman los transistores, antes de probarlos usa la ley de ohm y mira los datasheet de los mismos, te ayudaran.

Saludos
 
#3
El problema no esta en el transistor, con un transistor tipo bc547 y una resistencia de 1k deberia funcionar, el gran problema es el rele. Chicos que es una bbobina y tiene muy mala leche cuando se desactiva, me explico

En el instante en que el rele le quitas la corriente (transistor en corte), como bobina que es intenta mantener la corriente y esto lo hace que en los extremos de la bobina surja una tension inversa de unos cientos de voltios que aunque de poca potencia si de voltaje que destruyen el transistor a la larga.

Solucion metes un diodo en pararelo a la bobina pero al reves para que se coman los picos, puede ser un simple 1n4148 o el que tengas a mano.

Mira esquemas por internet y fijate en este detalle, todos tienen el diodo
 
#5
Muchas Gracias a los dos por los consejos.

Medí el omeage de la bobina y me dio 254ohm.
con esto debería de funcionar no?
Aca les muestro un esquema de como creo yo que tiene que ser la cosa. Corríjanme si me equivoco, es que hace mucho que no toco nada.

 

Adjuntos

#6
excelente, yo tengo un pic que manda una serie de pulsos para mover un motor paso a paso, pero el problema es que el motor consume 1.1A, entonces el circuito anterior me sirve?
 

Temas similares