Tv como osciloscopio

Hola amigos del foro.
Tengo el siguiente problema:
Armé el generador de disparo que me dijo sherar. Este:

http://asherar.unlugar.com/DSD/OSC_ANA/generador_disparo_y_barrido.htm

Para provarlo inserté una senoidal de 50Hz (Transformador y a 220 jeje)
El caso es que todo va muy bien hasta la salida del operacional,
Aparece una señal cuadrada, como dice la descripción, y variando la perilla de level, varía el duty cicle de esta señal.

Peero, después del condensador de 1nF (1000pF) no queda nada de esa señal.
Sólo una corriente continua de -1V aproximadamente.

Alguien sabe a que se deve esto?

Sherar, tu armaste ese generador de disparo? tuviste el mismo problema?
Qué devo hacer?

Desde ya, gracias

Saludos
 
He gravado este vídeo, en el que se explica todo.
El video lo hice antes de cambiar C2 y C3 por los de 3.3uF, que pone en la página que puso sherar.

YouTube - generador de trigger

Después de poner los condensadores de 3.3, en V1, obtenía un pulso de 3V seguido de uno de 0.5V
Y en V2 unos pulsos de 0.5V todo el rato.

Cómo he de poner los condensadores? con el - hacia el transistor o hacia el diodo?
 
Hola:

El operacional que usé es un LM308.
Los diodos OA81 son diodos rápidos de Germanio y son obsoletos (difíciles de conseguir), por eso los reemplacé por 1N4148.

Respecto de los filtros pasa-alto:
Las reactancias Xc de los capacitores de salida deben ser bastante menores que las resistencias "pull down",
o de recuperación a tierra para que R6 y R7 no maten los pulsos.
Los tiempos de subida de los pulsos resultantes a la salida son: T1 ~ R5 C3 y T2 ~ R4 C2.
El tiempo de bajada debe ser más largo.
La frecuencia para el cálculo de Xc2 y Xc3 es del orden de 1/2Tn (Tn = duración del flanco más corto => subida).

R7 > Xc2 ~ 2 T2/( 6.28 C2) = R4/ 3.14 ~ R4/10 => R7 > R4/10

R6 > Xc3 ~ 2 T1/( 6.28 C3) = R5/ 3.14 ~ R5/10 => R6 > R5/10

El signo (-) del electrolítico va para el lado que está más tiempo a menor tensión, en este caso GND.

Los diodos seleccionan los pulsos positivos, por eso corregí el dibujo de la revista, que estaba mal.

Recomendación: Cuando hagas pruebas usá valores no muy diferentes, para ver hacia dónde se corren los resultados.

OTRA POSIBILIDAD
También se te pueden estar colando pulsos de consumo de la fuente. En condiciones normales eso se debería
resolver con capacitores de desacople de 100nF a la salida de los reguladores 7805, hacia tierra.
Pero al no ver el esquemático de tu fuente no se puede saber.
Es estable tu nivel de GND ?
 
Buff, monté el circuito tal y como lo pusiste, y ahora si que no obtengo salida.
R6 y R7 tienen que tener valores tan altos?

Podrías poner una foto, porfavor?
Para ver como lo hiciste
 
Mi fuente es la típica, con 7812, 7912, 4 electrolíticos de 4800uF y condensadores de 100nF a tierra antes y depués de los reguladores.
Pero la fuente que estoy usando para el ensayo es una fuente normal, creo que de un cargador de celular

(Usando 2, claro)
 
Lo siento, no te puedo mostrar fotos.
Monté el circuito en un protoboard como el tuyo, y grabé los oscilogramas.
Unos días después reciclé todo. :LOL:

Solo puedo decir que revises el circuito, y emprolijes lo más que puedas.
Luego andá descartando de a uno los posibles problemas aunque parezca "de gusto":
* Conexiones equivocadas
* Protoboard que hace mal contacto ("estirado" u oxidado)
* Componentes quemados o fallados
* Fuentes bien filtradas
* Nivel de tierra estable (ante pulsos rápidos)
* Cables no demasiado largos
* Cortocircuitos
* Ancho de banda del osciloscopio vs. frecuencia de la señal observada

Te aseguro que lo que publiqué, anda.

En una semana lo tengo que armar en pcb.
 
R6 y R7 te asegura que los tiempos de bajada estén acotados:

T1(bajada) < R6 C3

T2(bajada) < R7 C2.

De lo contrario ese tiempo lo determina alguna otra R que ande por ahí, fuera de tu control.
 
Ya te dije para qué son.
Sí, yo las puse, ... y te mostré el oscilograma de la señal que obtengo

Aparte ... son requete importantes, importantísimas, fundamentales !
El LHC no va a funcionar hasta que no les pongan unas resistencias de salida como esas ! :LOL:

Solo por curiosidad.
Cómo estás viendo la señal ? Con las puntas del osciloscopio en x1 o en x10 ? :evil:
 
Hola amigos, ya me funciona el generador de trigger, mi problema era que los diodos que usaba
(el 4007) se comían mucha señal, así que he comprado los diodos que dijo sherar, y ahora obtengo unos pulsos perfectos desfasados 180º.
Mis pulsos son como los de la revista, no como los de los oscilogramas de sherar, yo obtengo solo el semiciclo positivo, mientras que en la foto salen uno positivo seguido de uno negativo.

Ahora que ya comprendo (y me funciona) el generador de disparo empecemos con la base de tiempos
 
elosciloscopio dijo:
Hola amigos, ya me funciona el generador de trigger, mi problema era que los diodos que usaba
(el 4007) se comían mucha señal, así que he comprado los diodos que dijo sherar, y ahora obtengo unos pulsos perfectos desfasados 180º.
Mis pulsos son como los de la revista, no como los de los oscilogramas de sherar, yo obtengo solo el semiciclo positivo, mientras que en la foto salen uno positivo seguido de uno negativo.

Ahora que ya comprendo (y me funciona) el generador de disparo empecemos con la base de tiempos
Qué foto ? No entiendo muy bien qué es lo que querés tener.

Lo que sincroniza el disparo es una subida de tensión positiva a partir de cero (GND).
La idea del circuito que armamos es poder seleccionar entre dos pulsos POSITIVOS:
uno SINCRONIZADO con el flanco POSITIVO y el
otro SINCRONIZADO con el flanco NEGATIVO.
 
Como les había anticipado, estoy montando el circuito del disparador de mi placa de captura a 32 MHz. Les muestro una foto de la placa SMD donde se ve el circuito de trigger. En los enlaces de más abajo se ve la placa completa.
Lo único que he verificado hasta ahora es que en durante la soldadura no me hayan quedado pistas en corto.

Placa completa: Vista reducida (baja resolución) - Vista completa (alta resolución) - Rutas SMD

El trigger es la mitad de arriba. En la mitad de abajo está el circuito de adaptación de la señal analógica. Eso no lo terminé de montar porque me faltan algunos componentes.

Salutes :apreton:

PD: No pude cargarlo desde el gestor de adjuntos por un "error al cargarlo en la memoria temporal".
 
Última edición:
Felicidades por el resultado Alejandro Sherar, sigamos avanzando.

Estando en el mes numero 8 de la construcción de mi osciloscopio, (el mes que viene me toca parir :LOL:) he complatado satisfactoriamente una buena parte del proyecto, faltando únicamente terminar el amplificador de entrada y hacer andar la base de tiempos.

Me he visto obligado a diseñar los amplificadores de salida y el de entrada, ya que los esquemas que publicó KARAPALIDA en el post 23 de este hilo no funcionan (amplificador operacional mal conectado y divisor resistivo mal hecho) así que he tenido que empezar esa parte desde cero.

por otro lado el generador de disparo de alejandro sherar funcionó más o menos bien (Gracias ;)(y) ) y como ya comenté la base de tiempos no llegó a funcionar,
así que me he ido a lo fácil (sistema patentado "elosciloscopio") y me he decantado por usar el XR2206 configurado como generador de dientes de sierra, que aparte de darme un increible rango de frecuencias de barrido desde 1Hz hasta 1Mz espero obtener una subida totalmente lineal.

demasiado bueno para ser verdad, no?

exacto. 10 minutos después de comprar el integrado, me acordé de que no tiene entrada de sincronismo, así que estoy buscando la forma de conseguirlo.
estoy abierto a todo tipo de sugerencias Y/O insultos, siempre que tengan intencion de ayudar.

Para finalizar les dejo un anticipo del proyecto terminado:

oscilpeq.jpg


Muy bonito... pero muy largo

saludos :)
 

Temas similares

Arriba