Tv TCL L32D2710 no enciende, led standby fijo

Tengo éste tv marca TCL mod: L32D2710 el cual no enciende al presionar el botón power y el led standby queda fijo en rojo. La main pcb es TP MS3393. Espero puedan ayudarme, gracias de antemano.
 

Adjuntos

  • 1613087864982-1333947137.jpg
    1613087864982-1333947137.jpg
    473.3 KB · Visitas: 7
  • 16130879076441601552382.jpg
    16130879076441601552382.jpg
    400.8 KB · Visitas: 7
  • 1613087933757-1527418884.jpg
    1613087933757-1527418884.jpg
    444.7 KB · Visitas: 7
  • 1613087960991521938958.jpg
    1613087960991521938958.jpg
    261.3 KB · Visitas: 8

D@rkbytes

Moderador
Esa falla suele pasar debido a un error de datos en la memoria SPI Flash.
Con la reprogramación se puede comprobar.

Adjunto el archivo de recuperación.
Recordatorio: Siempre se debe realizar una copia antes de reprogramar la memoria.
 

Adjuntos

  • TP.MS3393T.PB710 MS39PV Smart.rar
    2.6 MB · Visitas: 38
Gracias D@rkbytes, estoy empezando en estos TVs, éste es mío y no me preocupa experimentar, aqui mi pregunta, cual seria la SPI flash y si debo tener algún programador para reprogramar la misma, o si hay algún circuito casero para hacer el programador ?
 

D@rkbytes

Moderador
La memoria SPI Flash es la que está enmarcada en esta imagen.
SPI Flash.jpg

No conozco programadores caseros que sirvan en computadoras de escritorio o laptops actuales, porque suelen ser para puerto serie o paralelo.
El programador más sencillo y económico es el CH341A y es por USB
 
Tv lcd l32d2710 chassis tp-ms3393 con síntoma no enciende y mantiene el led standby fijo (rojo). Le cargué una salva que obtuve aquí en el foro del amigo D@rkbytes pero el tv sigue sin responder. Cuando le reali la carga; borré la memoria, luego la escribí y finalmente le di la opción de verificar y todo salió bien, salvo que el tv sigue sin encender y con el led en rojo fijo. Espero alguna sugerencia. Gracias de antemano.

Nota del moderador :

05) Escribe de manera correcta y legible para todos. Estás en un Foro no en un Chat.
Esto incluye emplear signos de puntuación e interrogación, comenzar un renglón nuevo con mayúscula, Etc.
No nos gusta la escritura "En Bloque"
 

D@rkbytes

Moderador
Ante esa falla he realizado lo siguiente:
1.- Si al regrabar la memoria el TV continúa sin responder, se debe probar con otros archivos para el mismo modelo de tarjeta.
Esto es para comprobar que el procesador reacciona a la botonera.
Aunque se vea mal o de plano no muestre imagen, sirve para determinar que el procesador se encuentra en buen estado.
Por lo tanto, esto significa que el archivo que estamos grabando no es el correcto y habrá que buscar el adecuado.

2.- Verificar la continuidad de las pistas que van hacia la botonera y hacia el sensor IR del control remoto.
A veces los cables suelen tener falsos contactos y puede haber pistas rotas o componentes dañados.

3.- Resoldar perfectamente el chip MSD3393LX
Con perfectamente me refiero a que se debe retirar y limpiar muy bien tanto la tarjeta como el chip.
Esto es porque suele haber corrosión en las pistas y pueden llegar a no hacer contacto aunque se vean bien estañadas.

4.- Cambiar el chip MSD3393LX
Tras comprobar que no existe nada dañado, voltajes correctos en sub fuentes y que el archivo para la SPI Flash es correcto, lo que resta es reemplazar el chip.
Es muy común que falle, pero por suerte es barato y fácil de conseguir.

Otro dato a tener en cuenta:
Me he encontrado con memorias que "se graban bien" según el programador, pero esto no es así, pues siguen conservando los datos anteriores.
Esto lo he comprobado comparando los archivos, el de lectura post grabado, con el que se va a grabar.
Deberían ser iguales, pero existen diferencias, por lo cual... SPI Flash (n)
 
muy buena su ayuda. Tratare de hacer todo lo que recomienda y luego comento. Gracias
Mensaje automáticamente combinado:

D@rkbytes tendras alguna salva para esa tarjeta solo para poder probar lo recomendado?. Podras subirla?. Gracias de antemano
 
Última edición:
muy buena su ayuda. Tratare de hacer todo lo que recomienda y luego comento. Gracias
Mensaje automáticamente combinado:

D@rkbytes tendras alguna salva para esa tarjeta solo para poder probar lo recomendado?. Podras subirla?. Gracias de antemano
Pues espero comente su experiencia, yo estoy en las mismas con un tv marca TLC modelo LED32D2700A (tarjeta main: TP.MS3393T.PB710 MS39PV) del cual no he encontrado el firmware (utilizare el que han puesto para su modelo) y me presenta la falla de que al conectarlo a la red electrica tarda como 3 segundos en encender el led de standby, el cual se queda encendido permanentemente (ni parpadea) y sin embargo el tv no enciende ni emite sonido (no responde ni a los botones del tv ni al control remoto) ya revise mosfets, capacitores e inclusive voltajes y todos estan bien...asi que sospecho que es problema de firmware.

Espero comparta sus avances.
 

D@rkbytes

Moderador
D@rkbytes ¿tendrás alguna salva para esa tarjeta solo para poder probar lo recomendado? ¿Podrás subirla?
Puedes probar con este archivo.
Ten en cuenta que es similar, para otra marca, y podría ser que no funcione con el mismo control remoto.
Otros problemas que se pueden presentar son: Imagen solarizada o invertida, lo cual se soluciona en el modo de servicio.
 

Adjuntos

  • Atvio ATV-32 (TP.MS3393.PB710 W25Q32) .rar
    2.6 MB · Visitas: 16
Gracias nuevamente, le comento las pruebas que hice;
-revise con el osciloscopio el cristal oscilador, y vi que esta oscilando.
-revise el pin 6 de la SPI Flash, hay oscilacion.
-revise todos los voltajes de las fuentes y subfuentes... 38V, 12v, 5v, 3.3v, etc.
-tome la temp. del micro dando 38 grados centrigrados.
-resolde el micro.
todo esto es a modo de complemento para un mejor analisis de la falla. Luego trate de encender el Tv y sigue presentando la misma falla. lo que me queda por hacer es cargarle a la SPI Flash esta salva nueva para ver si reacciona. Tambien tratare de cambiar la SPI Flash por otra y finalmente ver la posibilidad de cambiar el micro. sdls
 

Adjuntos

  • 20210224_223323.jpg
    20210224_223323.jpg
    242.5 KB · Visitas: 4
  • 20210224_224648.jpg
    20210224_224648.jpg
    227.4 KB · Visitas: 4
  • 20210224_223351.jpg
    20210224_223351.jpg
    212.3 KB · Visitas: 4
D@rkbytes, cargé la primera salva que usted subió y el tv encendió, pero no es para eéste modelo, adjunto imagen para que corrobore. Si puede buscar le agradeceré eternamente. Saludos
 

Adjuntos

  • 20210301_163011.jpg
    20210301_163011.jpg
    410 KB · Visitas: 3
Nota del moderador :

05) Escribe de manera correcta y legible para todos. Estás en un Foro no en un Chat.
Esto incluye emplear signos de puntuación e interrogación, comenzar un renglón nuevo con mayúscula, Etc.
No nos gusta la escritura "En Bloque"
Estas jugando a que te manden al F29.

Si el funcionamiento es correcto, y solo cambia el logo, entonces tienes 3 opciones;

1) lo dejas asi, y le explicas al cliente que es producto de la reparacion.

2) seguis buscando el firmware exacto.

3) busca en el foro que Darkbytes subió gentilmente un programa para cambiar los logos, e intentas de esa forma
 

D@rkbytes

Moderador
D@rkbytes, carg la primera salva que usted subió y el TV encendió, pero no es para este modelo.
Adjunto la imagen para que corrobore. Si puede buscar le agradeceré eternamente. Saludos.
El detalle con el archivo que subí es que es Multi Logo, o sea, contiene varias imágenes.
El sistema debe estar programado para cargar la imagen desde cierto Offset y no carga la que contiene el logotipo de TCL, que por cierto, es bastante feo. (Imagen "Logo 004.jpg")
Como esto puede ser complicado cambiarlo desde el modo de servicio, adjunto el archivo con el logotipo modificado e insertado en el offset que carga tu sistema.

También adjunto las imágenes que contiene el archivo y la que usé para modificarlo.

3) busca en el foro que D@rkbytes subió gentilmente un programa para cambiar los logos, e intentas de esa forma
Esa es una buena opción, pero aún no lo termino de actualizar para que pueda procesar archivos Multi Logo.
Casi no he tenido tiempo de programar y espero poder darme un tiempo para terminarlo y subir la actualización.
 

Adjuntos

  • Logo 001.jpg
    Logo 001.jpg
    60.7 KB · Visitas: 4
  • Logo 002.jpg
    Logo 002.jpg
    55.2 KB · Visitas: 5
  • Logo 003.jpg
    Logo 003.jpg
    100.3 KB · Visitas: 5
  • Logo 004.jpg
    Logo 004.jpg
    81.8 KB · Visitas: 5
  • TCL 1366 x 768 - 24 bits.jpg
    TCL 1366 x 768 - 24 bits.jpg
    107.1 KB · Visitas: 5
  • TCL Logo (TP.MS3393T.PB710 MS39PV Smart).rar
    2.6 MB · Visitas: 9
No se qué lenguaje usas, pero si queres puedo colaborar. No pido nada a cambio, solo que esté disponible para el foro...
 

D@rkbytes

Moderador
No sé qué lenguaje usas, pero si queres puedo colaborar. No pido nada a cambio, solo que esté disponible para el foro...
Gracias por la propuesta, pero eso también sobrepone un compromiso más a mis labores.
Ya otras personas también me lo han propuesto, y algunas con fines comerciales.
Compartir el código me resulta complicado, pues contiene claves de uso personal para acceso a un servidor, y por supuesto, librerías propias.
El hecho de estar revisando y explicando ciertos detalles del programa me quitaría tiempo y a este programa solo le dedico mis ratos libres, los cuales son muy pocos.
No es un programa sencillo, ya que utiliza algoritmos complejos para el procesamiento de imágenes basado en GDI Plus.
También tiene rutinas y funciones que involucran el acceso y creación de archivos, las cuales deben ser precisas, pues con tan solo un error, el archivo final resultaría inservible.
Te agradezco bastante el querer colaborar, pero hay programas con los cuales soy bastante celoso, y este es uno de ellos.
 
Te entiendo perfectamente, y me parece excelente que lo mantemgas asi...

Te sugiero, por si te interesa para que podamos colaborar, que hagas una especie de plugins, asi todo lo privado queda como tal, y no necesitas compartir informacion sensible.
Digamos que puedas acceder a DLL, por ejemplo, de forma dinamica, y que éstas DLL contengan lo necesario para cargar los datos faltantes.
Otra es con archivos de texto, por ejemplo XML..

Sugiero nomas, asi quitas un poco el peso de programar. Se que es dificil, pero bueno.

Yo solo me ofreci para la parte de menor peso de privacidad, digamos no todo el codigo, sino lo escencial para sumar lo que necesite el programa. Mi intencion es solo ayudar, no busco remuneracion ni creditos, como lo hice en el capacimetro que solo añadí que fue modificado por mi, para dejar en claro que puede contener errores de mi parte.
 
Al final como no tenia a la mano el programador para grabar el archivo.... logre conseguir otra placa...la instale y problema solucionado.... el tv funciona correctamente (quedo pendiente de grabar el archivo a la placa original)
 
Arriba