¿Por qué se daña un PIC16F628A en mi circuito?

Hola, creo que el problema son corrientes inversas derivadas de las bobinas de los relay. Los diodos en paralelo a esas bobinas yo los pondría del tipo Ultra Fast Recovery, por ejemplo UF4004. Quizás también para la linea que alimenta el pic, un diodo en serie tipo 1N4148 para tener la certeza que una corriente transitoria de polaridad inversa no llegue al IC. En caso de persistir el problema alimentaría los relays como sugieren antes del regulador. (opcional usar otro regulador para los relays)
 

Dr. Zoidberg

Well-known-Papá Pitufo
La forma comunmente aceptada para alimentar microcontroladores y relays es la de la figura:

uc-supply.png
La resistencia R1 forma un filtro PI para minimizar el ripple aplicado al relay y para reducir la tensión que llega al mismo si fuera superior a su tensión nominal. Con un trafo de 9V debería funcionar medio jugado si la corriente de los relays no esmuy alta. Como hacer bobinar un trafo es costoso, yo usaría uno de 12V con R1 calculada para hacer caer la tensión necesaria y con una R en serie con la entrada al 7805 para que no tenga que regular desde los (12V * 1.41) - 1.4 = 15.6V
 

pandacba

Rocker Bear
Electrónica Argentina es un negocio de electrónica de la city, que tiene cosas buenas y de las otras, ese negocio no vende micros de ese tipo.
Tenía fama de marcar componentes para vender.
Básicamente "fíjate donde compras tus micros....."
 
No estaras comprando los pic en Electronica Argentina no ? eso es lo primero a solucionar
no no los compro en electronica arg. los compro en electrocomponentes.
Mensaje automáticamente combinado:

Colocar un zener de 5.1 es más que nada para recortar cualquier pico que pudiera generarse en la apertura y cierre de los relay.
Se comete el eterno error de buscar un relay que trabaje a 5V.
Porque la insistencia de que el relay trabaje a 5V? un relay no necesita tensión regulada.
El relay debería ser de 12V no regulados por tanto deberían ir antes del regulador.
Con solo hacer eso se evita miles de problemas
como ya comente hace años q coloco rele de 6 v y el circuitos anda perfectamente hace de años pero resulta q por ahi me salta este problema. pero si obvio voy a probar con rele de 12v con alimentacion antes del regulador como vos me decis y voy a colocar el zener tambien para envitar quemar pic.
Mensaje automáticamente combinado:

La forma comunmente aceptada para alimentar microcontroladores y relays es la de la figura:

Ver el archivo adjunto 167544
La resistencia R1 forma un filtro PI para minimizar el ripple aplicado al relay y para reducir la tensión que llega al mismo si fuera superior a su tensión nominal. Con un trafo de 9V debería funcionar medio jugado si la corriente de los relays no esmuy alta. Como hacer bobinar un trafo es costoso, yo usaría uno de 12V con R1 calculada para hacer caer la tensión necesaria y con una R en serie con la entrada al 7805 para que no tenga que regular desde los (12V * 1.41) - 1.4 = 15.6V

ok no lo hay visto nunca a se haga asi. ya lo voy a implementar tambien
Mensaje automáticamente combinado:

gracias por todos sus comentarios ...por esta semana no creo probar todo lo q me dicen por mis tiempos. pero si creo q estoy sacando conclusiones a sus comentarios y el problema esta en la alimentacion de los rele y en corrientes inversas.

ahora se me ocurre de hacer este mismo circuito pero directamente eliminar transistor y rele y hacerlo con moc triac ... nose solo se me ocurre sin hacer las otras pruebas del circuito anterior y ver realmente donde esta mi falla.

gracias y apenas tenga novedad se las voy a comentar.
 
Última edición:
Gente, les comento que estoy haciendo dos pruebas.

Una la del esquema que me paso Dr. Zoidberg
O_sea, separé las etapas de alimentación de PIC y relevador, y otra que me comentó un amigo, la de bajar la resistencia de base del transistor.
L
e coloqué una de 82 Ohm. (Tenía de 1 K puesta)

Programé el PIC, lo coloqué y por 3 horas me anduvo joya joya!
Lo quiero tener unas 8 horas que es el uso diario que se le da, pero creo que el problema estaría en la separación de la alimentación.
Pero la duda siempre va quedar porque en los anteriores y que hace años que andan, nunca se quemaron.

Otra consulta. Ese diagrama tiene resistencia de 0.5 W. ¿Sí o sí tiene que ser así, o_sea de cerámica?
 
Última edición por un moderador:
Hola, una resistencia de base de 82ohms es muy baja. Pues estás cargando la salida del PIC. Con 1K es más que suficiente, ya que el transistor de ese tipo tiene buena ganancia, cómo para manejar al relé sin problemas.

Sí, es que la cambié porque me dijeron que probara así, como también he probado lo otro.
¿Vos qué me recomendas que ponga, la de 1 K o superior?
 
Última edición por un moderador:
Siempre tienes que tener en cuenta la max. corriente que puede manejar un puerto del PIC. Si miras la hoja de datos aparece. Que estimadamente yo nunca sobrepaso los 4 o 5mA.
Si calculamos el valor de corriente con 82ohms sería:
I=(Vo-Vbe)/R
I=corriente drenada
Vo=Tensión salida puerto
Vbe=Tensión base-emisor
R=Resistencia de carga
El valor nos arroja 52mA aprox! Estás matando al puerto!!!
Has el cálculo para una corriente de 2mA. Que será más que suficiente para saturar al transistor.
 
Siempre tienes que tener en cuenta la max. corriente que puede manejar un puerto del PIC. Si miras la hoja de datos aparece. Que estimadamente yo nunca sobrepaso los 4 o 5mA.
Si calculamos el valor de corriente con 82ohms sería:
I=(Vo-Vbe)/R
I=corriente drenada
Vo=Tensión salida puerto
Vbe=Tensión base-emisor
R=Resistencia de carga
El valor nos arroja 52mA aprox! Estás matando al puerto!!!
Has el cálculo para una corriente de 2mA. Que será más que suficiente para saturar al transistor.

decime si estoy en lo correcto.
hice el calculo para 2mA
me da q use una resistencia 2150 ohm
 
Hola gente.. bueno vuelvo con malas noticias jaja

Volví a calentar pic para hacer huevo frito ja

Les comento, hice varias pruebas pero al cabo de 3 horas seguida de andar se me quemaron

Lo primero que hice fue separar la alimentación como el diagrama que me pasaron.. luego probé con un trafo de 6 v 300 ma.. rele 6 volt.. y resistencia de 1k ( bueno éste me anduvo 4 horas o_sea que este estaría andando en teoria ja))
Pero también probé con trafo 9vol 300ma. relé 12 volt resistencia 1k.. y éste anduvo por 3 horas y se calentó pic!! éste caso los relé accionaban pero no_se si con 9 vol al no ser 12 consume mas la bobina.. aunque la fuente están separadas con el regulador del pic..

La verdad no entiendo!!

Estuve buscando info para ver la resistencia para ponerle en la base de bc337 y supuestamente me daba una de 4k o 5k pero no_se si mis cálculos y esa formula están bien.

Era Vol salida de pic - 0.7 vol dividido corriente ( de lo que queremos accionar o-sea el relé) sobre hfe de transistor
5 - 0.7
---------- =
I
------
hfe

Estoy de un celular por eso no me sale hacer de otra manera la ecuación.


Nota del moderador : escribe acorde a un Foro Técnico , los celulares tienen mayúsculas y acentos , de ser necesario instala un corrector ortográfico !

05) Escribe de manera correcta y legible para todos. Estás en un Foro no en un Chat.
Esto incluye emplear signos de puntuación e interrogación, comenzar un renglón nuevo con mayúscula, Etc. No nos gusta la escritura "En Bloque"
 
Última edición por un moderador:
Arriba