Alimentacion para Valvula Solenoide 24V

Saludos, por aqui me encuentro con un problema para poder hacer que actue una valvulaSelenoide de 24V (Primera y Segunda imagen de la valvula).

Me base a un circuito con el LM317 para tener una salida de 24V (Tercera y Cuarta Imagen )
sin embargo al conectar la salida de ese circuito a la solenoide , no logra abrir para nada.

en cambio si tomo la salida desde el puente de diodos donde llego a medir 31.6V :unsure: es poco lo que llega a abrirse la valvula, pero actua...

:rolleyes: me podría señalar algo que no este considerando ó como es la forma correcta de alimentar estas válvulas ?
 

Adjuntos

  • IMG_20170414_212402 (Small).jpg
    IMG_20170414_212402 (Small).jpg
    147.3 KB · Visitas: 43
  • SELENOIDE.png
    SELENOIDE.png
    148.8 KB · Visitas: 43
  • circuito.png
    circuito.png
    26.7 KB · Visitas: 104
  • IMG_20170417_033810 (Small).jpg
    IMG_20170417_033810 (Small).jpg
    173.2 KB · Visitas: 39
Buenas, ¿cuando le das tensión a la válvula se sigue manteniendo esa tension (24'6v)?
¿Y a la salida del transfornador se mantiene los 24ac?
Saludos
 
Última edición:

pandacba

Rocker Bear
Tenes un solo dato, 24Vdc y que corriete consume??? es evidente que el trafo es chico, ya que decis que apenas habre la válvula, tenes problemas de corriente/consumo, vas a tener que agregar un transistor de paso al 317, para aumentar la corriente
 

DOSMETROS

High 2m Modereitor
Panda , primero fijate los valores de resistencias que le puso al pobre LM317

La pata de ajuste necesita una corriente mínima que ese valor de resistencia (7k7) no puede suministrar , aqí que vaya a saber que sale de ahí.
 
No es que ocupe una corriente mínima, sino que se afecta la medida por esa corriente que fluye, generalmente se usa un valor de corriente más grande haciendo que dicho error sea despreciable, yo trabajaba en una librería para esos cálculos y tengo una demo precisamente con el LM317, mi librería incluye la corriente en el calculo, las calculadoras online calculan 2,01V en mi programa arroja 2,24V
eTools.PNG

Lo que no comprendo es de donde está midiendo 24,6V :eek:
 
Yo veo que lo hace después de una resistencia, lo cual no tiene sentido colocarle una resistencia en serie al solenoide, pero con tantos cables no tengo idea de donde proviene ese voltaje en primera, pero del regulador no parece.
 
Quizás , y muy quizás , sin carga ?¿?¿?

De hecho asi fue como tomé la medida de 24v sin nada conectado.

Gracias por sus comentarios... me puse a hacer pruebas en el simulador Proteus y después de pelearme un poco con el programa ( para poner un generador de 120v en proteus y el transformador y calcular la inductancia para simular el transformador que tengo de 127v a 24v)

me dí a la tarea de simular al LM317 , sin embargo sigo sin exito de tener un voltaje de salida de 24V~.

en este caso los valores de las resistencias las saque de una calculadora Online y lo compare con la aplicación que "Nuyel" :D gracias por la app pude comprobar.

pero en la simulación metiendo esos valores aun no consigo esos 24V :unsure: y aun no he atacado el problema de "La Corriente" (amperaje).

adjunto la imagen de como esta el diagrama y como esta configurado la fuente AC y el transformador con su calculo de inductancia junto con las pruebas de las resistencias y mi salida de voltaje en proteus.

Estamos en contacto. se agradecen sus comentarios.
 

Adjuntos

  • Esquema.jpg
    Esquema.jpg
    100.5 KB · Visitas: 26
Por lo que llego a apreciar en la imagen de tu captura de pantalla, al lm317 le estan llegando 19v en su entrada. No esperes que a su salida entrege 24v porque es algo imposible, el lm317 no puede dar mas tension de la que recibe. Como maximo puede dar a su salida unos 2v menos que su tension de entrada.

Y los puntos de conexion de C3 y del primer voltimetro dc los veo un poco fuera de lugar.

Se me olvidaba, el valor del condensador de filtrado del puente de diodos es muy pequeño (Condensador C3 de tu esquema). Como norma general se suele usar mil microfaradios por cada amperio de consumo.
 
Última edición:
en mi aplicación puedes escribir vo y el siguiente dato ser el voltaje de salida, en realidad hay varios parámetros
vi voltaje entrada
io corriente salida
vo voltaje salida
r1 y r2 según la hoja de datos, por ejemplo podrías usar

eTools LM317 vo 24 vi 32 io 0.2 r1 220 get r2

El programa indica también la potencia a disipar bajo esas condiciones y te devuelve el valor adecuado a R2, en este caso 3969 y 1,6W.

En la simulación se ve que el voltaje de entrada es inferior a los 26V que es el mínimo recomendado para ello, (mi programa advierte si el valor vi es inferior a vo+2), lo que significa que tu transformador no puede entregar la corriente requerida, la válvula es de 5W, serían al rededor de 220mA cuando menos para el transformador.

No lo había notado pero ese condensador en los diodos, normalmente se usa 1000uf por cada 500mA, con ese valor se rectifica pero no se almacena suficiente, tendrás el valor subiendo y bajando constantemente.
 
Última edición:
Saludos... (De nuevo)

Pues adjunto el diagrama a como tengo actualmente el circuito y junto con sus valores reales (y los más aproximados que pude simular) en realidad el diagrama es más que nada para que puedan visualizar como esta cableada la protoboard (ya que era un asco todo el cablerio que tenia junto con las resistencias que tengo en serie para obtener el valor calculado)

con el circuito actual tengo un comportamiento acorde a sus comentarios :cool:

... Como maximo puede dar a su salida unos 2v menos que su tension de entrada.

No lo había notado pero ese condensador en los diodos, normalmente se usa 1000uf por cada 500mA, con ese valor se rectifica pero no se almacena suficiente, tendrás el valor subiendo y bajando constantemente.


A como tengo el circuito simulado y el real tengo una salida de unos 2v menos que de su entrada (ahi tuve problemas en la simulacion en obtener el mismo valor que mido en el circuito despues del puente de diodos [en el circuito mido 27.8V y en la simulacion manda 22V])

y cuando conecte la valvula selenoide me empezo a vibrar (a lo que yo creo que es el bastago que se desplaza dentro de la bobina) por la subida y caída de corriente.

adjunté las fotos siendo lo más descriptivo posible.

todavia me falta sacar bien el voltaje de 24V pero aun así a 26V me arriesgue a conectar la valvula y ver como actuaba.

espero seguir recibiendo sus comentarios y/o correcciones para lograr armar el circuito (sé que es básico - en sí es una fuente de 24V fija pero ando bastante oxidado en la electrónica :oops: y me ha ayudado para refrescar ciertas cosas)

:unsure: bueno quedo pendiente... y si me gustaria saber un poco sobre los faradios para mantener constante la corriente. investigaré por mi parte aun así, hasta entonces :p me despido.

P.d: el LM7824 no lo encuentro disponible en las tiendas de electronica que tengo cerca.
 

Adjuntos

  • Diagrama.jpg
    Diagrama.jpg
    26.2 KB · Visitas: 14
  • 1= entrada VAC (Medium).jpg
    1= entrada VAC (Medium).jpg
    301.7 KB · Visitas: 15
  • 2= Voltaje de Entrada (Medium).jpg
    2= Voltaje de Entrada (Medium).jpg
    180.4 KB · Visitas: 14
  • 3= Valor R1 (Medium).jpg
    3= Valor R1 (Medium).jpg
    283.1 KB · Visitas: 12
  • 4= Valor R2 (Medium).jpg
    4= Valor R2 (Medium).jpg
    255.2 KB · Visitas: 11
  • 5= Voltaje de Salida (Medium).jpg
    5= Voltaje de Salida (Medium).jpg
    270.9 KB · Visitas: 9
  • 6= Voltaje en paralelo con Valvula Selenoide (Medium).jpg
    6= Voltaje en paralelo con Valvula Selenoide (Medium).jpg
    294.4 KB · Visitas: 6
  • 7= Medicion de Amperaje con Valvula Selenoide.jpg
    7= Medicion de Amperaje con Valvula Selenoide.jpg
    120.9 KB · Visitas: 5
Te etsá vibrando porque no tenes ningún electrolitico en ningún lado, a la electrovalvula le estan llegando tensión pulsante sin rectificar, y hasta es posible que el lm317 puede auto-oscilar, es muy basico eso como para tener demaciados errores.

No conseguis un 7824?? si conseguis un lm317 deberias poder conseguir el otro, son de la misma familia solo que el otro es fijo.
 
Viendo que es trato de steren creo que el mínimo es 24@500mA así que ahí va bien, pero sin el condensador tendrás el voltaje subiendo y bajando a 120Hz y eso es lo que provoca la vibración.
 
Si quieres 3mf esta bien, para tu aplicación sobra, respecto a C2, el valor de 1uf es adecuado para capacitor de tántalo según la hoja de datos, si usas electrolítico seria de 10uf aparte el cerámico de 100nf no está mal agregarlo como extra, pero igual no es muy critico el voltaje en el solenoide.
 
Arriba