Altium Designer Release 10 Visualización en 3D

#41
Hola!
Uso altium 10 desde hace unos meses y como que ya le entro bien, estoy en estos momentos tratando de hacer simulaciones, pero a un estoy tratando de comprender sus interfaces.
uno de los principales problemas es que mis timer 555s no tienen el archivo para realizar la simulación,
alguien que pueda compartir su 555 o decirme cual es la ruta adecuada para descargarlo gratuitamente de la web Altium?
adjunto un pantallazo de todos mis 555s

saludos
Hola Comet, allí te adjunte el modelo de simulación del LM555, y en el siguiente link esta el manual de protel DXP que te puede servir para la configuración de la simulaciónes en altium.

https://www.forosdeelectronica.com/f13/manual-protel-dxp-espanol-865/

PD: Altium Designer 10 es un programa pago así que no vas a poder descargarlo libremente, mas sin embargo, en la pagina de altium puedes descargar una versión de prueba, con una licencia de un mes.

Saludos...
 

Adjuntos

#42
Hola Comet, allí te adjunte el modelo de simulación del LM555, y en el siguiente link esta el manual de protel DXP que te puede servir para la configuración de la simulaciónes en altium.

https://www.forosdeelectronica.com/f13/manual-protel-dxp-espanol-865/

PD: Altium Designer 10 es un programa pago así que no vas a poder descargarlo libremente, mas sin embargo, en la pagina de altium puedes descargar una versión de prueba, con una licencia de un mes.

Saludos...


Gracias Joryds.
por compartir tu archivo
Ya puedo hacer muchas cosas con este programa que esta súper, lo único que me falta es dominar el modo Simulación, y estoy seguro que lo conseguiré dentro de poco

PD : lamentablemente tengo la Vs demo y siempre tengo que descongelar mi PC cada mes para borrar el registro del demo
 
#43
Hola a todos: estoy leyendo todos estos mensajes y veo que hay movimiento en cuanto al " Altium" yo uso el "Altium Designer 10 " la ultima versión, y la verdad que está pero que muy bien. Yo he usado, creo que todos los programas de diseño de pcb que existen, y al final me quedo con "Altium". Quisiera preguntar, si alguien sabe la manera de importar footprint de Eagle 3d a "Altium". Aunque hay bastantes librerías de ellos en "TraceParts" y en "3d contentcentral" no suelen tener muy buen acabado y de todo no se encuentra. No se si a vosotros os pasa, que al importar footprint 3d y abrirlos con el altium los mismos salen en blanco. Estoy venga darle vueltas y no entiendo lo que me pasa, en "Solidworks" los veo como tienen que ser y los exporto en formato Step y AP214 y en "Altium" se ven en blanco.
Yo estoy creando mis propias librerías y si os pudiesen interesar ya me diréis como bajarla para que las tengáis. Un saludo para todos.
 
#44
Quisiera preguntar, si alguien sabe la manera de importar footprint de Eagle 3d a "Altium". Aunque hay bastantes librerías de ellos en "TraceParts" y en "3d contentcentral" no suelen tener muy buen acabado y de todo no se encuentra.
Hola Alex Oteiza, todavía no conozco la forma de exportar los modelos en 3D de Eagle a Altium pero puedes crear una PCB en Eagle y le agregas los componentes que necesites luego con un archivo ulp lo exportas a altium, posteriormente al crear tus footprint solo copias y pegas los componentes de Eagle.

No se si a vosotros os pasa, que al importar footprint 3d y abrirlos con el altium los mismos salen en blanco. Estoy venga darle vueltas y no entiendo lo que me pasa, en "Solidworks" los veo como tienen que ser y los exporto en formato Step y AP214 y en "Altium" se ven en blanco.
Al comienzo me pasaba lo mismo, pero el problema era el formato con que guardaba el archivo, lo recomendable es AP214, pero en ocasiones el problema son los colores del modelo que estés creando en solidWorks.

PD: si deseas me envías el modelo 3D que sale en blanco pero en el formato de solidworks, y yo reviso

Saludos...
 
#45
Hola, Joryds: muchas gracias por tu contestación. Me dices sobre el tema de importar componentes de Eagle, que habría que crear una PCB con Eagle y agregar los componentes que queramos copiar, pero claro solo serán componentes de formato "footprint", pero no el de 3D.Luego exportar con "ULP" a 2Altium" copiar y pegar los mismos. como se hace para importar
el "ULP" de Eagle? . Nunca lo he usado y ni sabía que se pude hacer. Serías tan amable de explicarlo?.
Te adjunto el archivo en Rar de un teclado de 4x4 que como te decía no consigo verlo en color en Altium. No se si es problema de Altium ó del SolidWorks, hace mucho tiempo que no uso el mismo y no se como se puede hacer. Te lo adjunto y haber si puedes hacer algo con el y si lo consigues ya me explicarás como lo has hecho.
Muchas gracias de antemano y espero que sigamos comunicándonos. Un placer.
 

Adjuntos

#46
Hola!

Creí que Eagle tenia mejores gráficos en lo que es 3D, de hecho quiero probar Eagle, pero solo en modo 3D
cuando puedas importar de Eagle a Altium nos cuentas tus comparaciones

suerte(y)
 
#47

bueno

en mi Altium 10 si lo puedo editar tu diseño de Solid Works, pero no se notan los números (me gustaría saber cómo lo haces) tengo componentes que he diseñado en SW y solo me falta ponerle mi nombre:D

Yo lo hice así

1- En SW Guardar como archivo STEP AP214(*.step;*.stp)
2-en Altium 10 en el modo 3D
3- Place
4- 3D body
5- te sale 1 ventana que por defecto esta marcado "Extrude"
6- marca "Generic STEP Model" y habilitaras la opción "Embed STEP Model" click
7- te sale otra ventana para abrir el archivo Step donde lo guardaste anteriormente
8- y así lo hago yo, pero hay otros métodos mejores que a un no lo se


por cierto tu Altium 10 "quizá" lo ve blanco, cuando hay colisiones con la placa, en mi caso lo veo color verde fosforescente, a un sin colisionar
por si acaso prueba esto;)

1- en el modo 3D clik en "Tools
2- click en "Reset Error Markers"


saludos
 

Adjuntos

#48
Hola Comet: gracias por tu interés, yo hago como tu lo haces, pero antes de pasarlo a la librería ya lo veo en blanco. Como bien esplicas cuando vas a colocar un componente en 3d vas a Body place y entonces te sale la ventana de "3D Body", y aquí activas "Generic Step Model" y después
pinchas en "Embed Step Model" para poder buscar el componente en 3D de los archivos "Step", bueno cuando se habre esta ventana en donde poder buscar los mismos, me imagino que sabrás que arriba a la derecha pone "Step Preview" y si la activas (se pone una flecha en verde), verás el componente con la forma correspondiente en la ventana de abajo antes de colocarlo en el "Pcb" de la librería. Yo aquí ya veo el componente con el color que va a salir y el teclado ya lo veo en blanco, por lo menos a tí te sale en color oscuro y se distinguen las teclas y los pines en color. Lo del color verde cuando los colocas en el Pcb es otro tema que se soluciona con los "Rules". Voy a esperar haber que dice "Joryds" del archivo SW del teclado porque yo creo que le falta algo en el acabado. De todas las maneras muchas gracias por el interés y seguiremos estando al corriente de todo esto. Un saludo de Alex desde Pamplona España.
 
#49
Hola Comet: gracias por tu interés, yo hago como tu lo haces, pero antes de pasarlo a la librería ya lo veo en blanco. Como bien esplicas cuando vas a colocar un componente en 3d vas a Body place y entonces te sale la ventana de "3D Body", y aquí activas "Generic Step Model" y después
pinchas en "Embed Step Model" para poder buscar el componente en 3D de los archivos "Step", bueno cuando se habre esta ventana en donde poder buscar los mismos, me imagino que sabrás que arriba a la derecha pone "Step Preview" y si la activas (se pone una flecha en verde), verás el componente con la forma correspondiente en la ventana de abajo antes de colocarlo en el "Pcb" de la librería. Yo aquí ya veo el componente con el color que va a salir y el teclado ya lo veo en blanco, por lo menos a tí te sale en color oscuro y se distinguen las teclas y los pines en color. Lo del color verde cuando los colocas en el Pcb es otro tema que se soluciona con los "Rules". Voy a esperar haber que dice "Joryds" del archivo SW del teclado porque yo creo que le falta algo en el acabado. De todas las maneras muchas gracias por el interés y seguiremos estando al corriente de todo esto. Un saludo de Alex desde Pamplona España.
Hola Alex Oteiza, disculpa por la demora, pero hace poco le di formato al disco de mi PC y no había instalado SW, lo que hice es abrir el archivo que me pasaste, y genere el .STEP y salio como se observa en la imagen, los números del teclado no salen por que te falto volverlos Extrusiones salientes es decir las letras debían sobresalir un poco para que se pudiera rellenarlo de color blanco.

Cual versión de altium esta utilizando ? yo uso Altium Designer 10.1181.24817, en ocasiones el problema esta con la versión.

tambien te voy a adjuntar el archivo .step, revisalo y me comentas.

Saludos...
 

Adjuntos

#50
Hola, Joryds: la versión que tengo de "Altium" es la misma que la tuya. Sobre el archivo que me envías te digo que por lo menos ahora lo veo en color y el circuito impreso en verde y los pads en color oro, como debiera de ser, ya me dirás lo que le has hecho para ahora verlo así. Este archivo lo encontré en una página de internet (grabcad.com) y por eso decía que le faltaba algo de acabar. tu serías capaz de hacer que se viesen los números y poderla incluir en las librerías de a"altium" para el las quiera?. Yo tengo el "SolidWorks" 2008 y no me deja abrirlo, estoy intentando instalar el del 2010 y llevo dos día para instalarlo y no acabo de instalarlo, no me ha pasado nunca esto.
Espero tus gratas noticias. Un saludo.
 
#51
Hola, Joryds: la versión que tengo de "Altium" es la misma que la tuya. Sobre el archivo que me envías te digo que por lo menos ahora lo veo en color y el circuito impreso en verde y los pads en color oro, como debiera de ser, ya me dirás lo que le has hecho para ahora verlo así. Este archivo lo encontré en una página de internet (grabcad.com) y por eso decía que le faltaba algo de acabar. tu serías capaz de hacer que se viesen los números y poderla incluir en las librerías de a"altium" para el las quiera?. Yo tengo el "SolidWorks" 2008 y no me deja abrirlo, estoy intentando instalar el del 2010 y llevo dos día para instalarlo y no acabo de instalarlo, no me ha pasado nunca esto.
Espero tus gratas noticias. Un saludo.
Hola Alex Oteiza, lo que hice con el archivo fue simplemente abrirlo, como fue creado con una versión anterior le di guardar con SolidWorks 2012 SP4 y luego lo visualice con Altium, así pude ver que faltaba el color de los números.

También intente fijarle un color a los números, pero no pude, no soy experto en modelos 3D, pero trato con dificultad hacer algunos componentes que necesito en algún momento.

te recomiendo que instales la versión SW 2012 sp4 o sp5 para ver en que cambia la visualización, revisa mensaje privado..

En el transcurso de la semana tratare de modificar el archivo para ver si consigo mostrar el color blanco de los números.

PD: Normalmente antes de hacer un modelo 3D, busco en la pagina de SolidWorks http://www.3dcontentcentral.es/Default.aspx allí puedes encontrar muchos componentes de electrónica.

Saludos...
 
#52
Hola, Joryds: recibido el mensaje y comenzado a descargar 2012, yo lo tengo de otro sitio pero me da problema algún archivo y no me deja descargar. Cuando lo tenga en marcha intentaré modelar el teclado, hace mucho tiempo que no uso el Solidworks y me cuesta ponerme al día pero lo intentaré. anteriormente hice algún componente (Tranformadores) y lograba extrusionar y me quedaban bien, lo que o por lo menos me lo parece es poner texto a los mismos. Con el 2010 estuve enrredando pero en cualquier momento me dejaba colgado y me bloqueaba el ordenador y lo tenía que reiniciar, y ya estaba bastante quemado.
Bueno seguiremos al corriente de esto y muchas gracias por todo.
Un saludo.
 
#53
hola,
Bueno de nuevo a qui a la carga con una simulación muy simple, el famoso Timer 555.
Resulta que en Multisim si corre la simulación
pero con Altium Designer 10 estoy teniendo dificultades

por favor alguien que pueda correr este sencillo Astable de 10 Hz
adjunto también mis archivos

saludos a todos!




Siempre que activo la simulación me da este error que adjunto

y a pesar que aumento el tiempo "Timestep" siempre me bota el mismo mensaje "doAnalyses: Timestep too small":unsure:
Debo de estar haciendo algo mal o mis archivos no están bien, por favor alguien que simule este sencillo circuito para poder comparar
gracias
 

Adjuntos

Última edición:
#55
Hola Comet, te adjunte el archivo de simulación y 2 capturas donde se muestra las formas de ondas y la configuración del tiempo de simulación.

a la simulación le faltaba un componentes que bien en las librerías con el nombre Simulation y dentro esta Simulation Sources.

Cualquier duda me comentas

Saludos...
 

Adjuntos

#56
a la simulación le faltaba un componentes que bien en las librerías con el nombre Simulation y dentro esta Simulation Sources.

Cualquier duda me comentas

Saludos...




Perfecto!!!
Gracias Joryds, por fin pude correr esta simple simulación, No conocía ese componente que pusiste en el "Trigger"
imagino que cuando se usa un archivo .ckt invitado, siempre se debe usar este componente "Control Statement"?
bueno lo digo porque con otras simulaciones que probé con 2 simples transistores y 2 Capacitores logre pulsos cuadrados, pero sin agregar ningún control

voy a seguir experimentando y aquí adjunto los resultados

gracias
 

Adjuntos

#57
Amigos del foro, estoy un poco perdido :confused: y quisiera solicitarles su ayuda.
Necesito para un diseño que estoy implementando en Altium el modelo de un Display LCD 2x16 y un teclado matricial de 3x4. La verdad que estuve buscando bastante en librerias pero no encuentro estos componentes. Agradecería si alguien en algún momento los utilizó me pueda decir en que librerías puedo encontrarlos.

Por supuesto muchísimas gracias!!(y)
 
#58
Hola !!!

Bueno después de 1 semana de arduo trabajo con SolidWorks, pude hacer mi 1er solido: 1 resistor de 1k - 1/4w para Altium Designer (Res1):D
y lo quiero compartir con Uds.

Espero les guste? ;)


Res1 echo en SolidWorks



Res1 Renderizado en SolidWorks



Res1 colocado en Altium Designer 10



La verdad en Solid Works al renderizar queda muy bien los solidos, he intentado importar la PCB pero no pasa con todos los atributos

Saludos a todos
 

Adjuntos

#59
Hola Alxtor:
estoy teniendo el mismo problema que vos y el link esta caido. Podrias subir el archivo nuevamente y en algun formato como .rar o .zip ? Gracias
 

Temas similares

Arriba