Amplificador ACR 2020 :P

Hola gente…
Bueno aquí otro proyecto mas y se trata de mi version-evolución del amplificador RCA 130 de siempre.
La idea era hacer unas mejoras, pero quería mantenerlo simple...así que saque algunas ideas de "aquí y allá" y quedo esto.
Los cambios que hice: usar 2sc5200 en vez de los 2n3055 (cuasi complementario como el original), como drivers use tip41c y tip42c para el VA use BD140, y tiene un bc546b para ajustar el bias.
Agregue unos filtros en -vcc y +vcc y en la entrada para minimizar la posibilidad de oscilaciones.
Tiene una entrada “balanceada” para poder usar con equipos profesionales (mi motivación principal), un protector contra corto del tipo PERMANENTE (el original era momentáneo como lamentablemente pude comprobar
:P
) y un indicador de recorte (del lado positivo y negativo de la onda).
La ganancia es de 22 aprox. Y con 1.13 Vp esta al mango, tiene un pote para ajustar el volumen.
La protección se activa con una carga de 2 ohms con una Radj1 y Radj2 de alrededor de 160 ohms …
En el emulador da la siguiente perfomance:
con +-50V de fuente
en 4 ohms y con 20khz tenemos
VpPot WTHD(20)
0.5046.47340.053921%
0.7092.88850.068071%
1185.4890.123292%
1.13236.5870.200778%

en 4 ohms y con 1khz tenemos
VpPot WTHD(1)
0.547.38430.015054%
0.7094.5710.016781%
1188.9490.035407%
1.13241.1180.049819%


en 8 ohms es un poquito mejor todavía.

Dejo la imagen del simulador en 20khz..
El amp. esta andando pero no como esperaba...
Por ahora lo que mas me preocupa es una oscilación en 600khz, del lado negativo de la onda...
Es por eso que recurro a la sapiencia del foro: en T4 tengo el capacitor C9 (creo compensación miller) de 100Picos que es un valor aceptable para mis expectativas de distorsión en alta frecuencia, el tema es que con ese valor el amp oscila....con 150picos la zafa pero arruina un poco el thd en alta frecuencia...
Estoy convencido que mi layout de mi PCB no es tan bueno y por allí viene la mano.
También vi que algunas veces cuando corto la señal queda oscilando (linda calentada que le pega a los tr de salida)
Una cosa que noté en una placa comercial de otro amp. es que sus "T1 y T2" están pegado a su "T4 y su capacitor"... puede ayudar a hacer mas estable el amp.?
Dejo aquí el esquema y el layout por si alguien me tira un dato o un consejo de como hacerlo mejor, estaré eternamente agradecido!!
gracias y saludos
 

Adjuntos

  • ACR-simul.png
    ACR-simul.png
    52 KB · Visitas: 69
  • sch141.png
    sch141.png
    177.9 KB · Visitas: 79
  • layout141.png
    layout141.png
    332.1 KB · Visitas: 70
  • placa2.jpg
    placa2.jpg
    119.1 KB · Visitas: 46
  • placa1.jpg
    placa1.jpg
    92.6 KB · Visitas: 35
Buenas tardes! Probar insertando un capacitor de 1nF entre base y colector del TIP42 (T8) .Cordial saludo!
Muchas gracias por la ayuda!
Con el capacitor de 1nf se va las oscilaciones, pero lamentablemente se arruina un poco el thd 20khz= 4.48%
No se si mi una mejor PCB ayudaría a mermar los problemas
muchas gracias!
 

Dr. Zoidberg

Well-known-Papá Pitufo
No se si mi una mejor PCB ayudaría a mermar los problemas
Y para saberlo deberías simular el circuito agregando las inductancias parásitas de las pistas y las capacidades parásitas entre los tracks --> es un bodrio importante para un diseño discreto.

Si con 1nF se te escapa la distorsión a 20kHz (lo que es algo que ahora no importa) ponele uno mas chico, y reducilo hasta que la distorsion sea razonable y el amplificador se mantenga estable.

Te aviso que con un circuito nacido tipo Frankestein no podes esperar maravillas. Tenes que analizarlo y depurarlo antes de probar simulaciones que "tantean" una estructura que no sabemos que tan buena es.
 
Y para saberlo deberías simular el circuito agregando las inductancias parásitas de las pistas y las capacidades parásitas entre los tracks --> es un bodrio importante para un diseño discreto.

Si con 1nF se te escapa la distorsión a 20kHz (lo que es algo que ahora no importa) ponele uno mas chico, y reducilo hasta que la distorsion sea razonable y el amplificador se mantenga estable.
Gracias por la ayuda...
si eso que comentas he probado: con 331p tira hasta 8 ohms pero con carga mas exigente se vuelve inestable...con el de 1nf es estable hasta los 2 ohms que probé....
a veces al encenderlo sin señal queda oscilando en 600khz, según la carga y el cap...
eso si suena excelente, así que lo voy a seguir trabajando para aprender
 
Gracias por la ayuda...
si eso que comentas he probado: con 331p tira hasta 8 ohms pero con carga mas exigente se vuelve inestable...con el de 1nf es estable hasta los 2 ohms que probé....
a veces al encenderlo sin señal queda oscilando en 600khz, según la carga y el cap...
eso si suena excelente, así que lo voy a seguir trabajando para aprender
Hola. Tener en cuenta incorporar una red de zobel en la salida de parlante , la misma esta compuesta por R25 y C15, faltaria un pequeño inductor para completarla. También realizar las pruebas con la placa metida dentro de una caja de aluminio o bien apoyada en una base metalica (chapón) puesta a tierra (aislada de las pistas de la placa porsupuesto para evitar cortos) ; además los cables desde la fuente de alimentacion al modulo lo mas cortos posibles, la frecuencia indicada en la que mencionas te estaría oscilando podría ser vestigios de una Radio AM que se esta filtrando (digo por la frecuencia de 600Khz), otra cosa a revisar por ultimo es quitar el capacitor electrolítico C17 , aveces dependiendo del diseño de la placa suele meter ruidos en vez de filtrarlos , me ha pasado! para probar puedes quitarlo o bien poner menor valor o mayor(no superior a 470uf) e ir probando.Cordial saludo!
 
Hola. Tener en cuenta incorporar una red de zobel en la salida de parlante , la misma esta compuesta por R25 y C15, faltaria un pequeño inductor para completarla. También realizar las pruebas con la placa metida dentro de una caja de aluminio o bien apoyada en una base metalica (chapón) puesta a tierra (aislada de las pistas de la placa porsupuesto para evitar cortos) ; además los cables desde la fuente de alimentacion al modulo lo mas cortos posibles, la frecuencia indicada en la que mencionas te estaría oscilando podría ser vestigios de una Radio AM que se esta filtrando (digo por la frecuencia de 600Khz), otra cosa a revisar por ultimo es quitar el capacitor electrolítico C17 , aveces dependiendo del diseño de la placa suele meter ruidos en vez de filtrarlos , me ha pasado! para probar puedes quitarlo o bien poner menor valor o mayor(no superior a 470uf) e ir probando.Cordial saludo!
Hola indemornin
mil gracias por la ayuda!
probé un inductor y un cap de 100p en T8 y T4 (THD20= 0.21 a 236W sobre 4ohms) puestos directos sobre ellos (el manual de la RCA dice que el capacitor tiene que estar lo mas cerca osible del transistor)
y logre lo que se ve en las imágenes, un poco de oscilaciones justo en el momento del recorte (100hz en 8ohms y 50hz en 2 ohms respectivamente)
Pude probar de sacar C17 pero se puso loco, fue a peor ;) así que lo deje (no tenia otro a mano para probar)
 

Adjuntos

  • 100hz-8ohms.jpg
    100hz-8ohms.jpg
    79.2 KB · Visitas: 9
  • 50hz-2ohms.jpg
    50hz-2ohms.jpg
    70.9 KB · Visitas: 9
Hola! siguiendo con el tema de la oscilaciones tengo este análisis de respuesta de frecuencia y fase de "lazo abierto" por el tema de la estabilidad...
Lo hice siguiendo los algunos ejemplos del ltspice (básicamente es insertar una fuente de voltaje en el feedback, dejo el esquema con estos detalles) y usar en análisis de AC.
En la imagen de las curvas la linea punteada es la fase y la solida la ganancia.
En la grafica superior esta la ganancia de lazo abierto y están marcado cuatros puntos:
la frecuancia donde la ganancia es 20db, la fase de este punto, el punto donde la ganancia es 1db (741 khz) y el punto donde la fase se hace 180º (4.81Mhz)
Con una ganancia de 20db me da un margen de fase 93º (180º - 87º)
La "unity gain frequency" seria de aprox. 741 khz
(todo esto siguiendo el ejemplo que me paso amablemente Dr. Zoidberdg (Taming the LM3886 Chip Amplifier: Stability))
La otra mitad del amp. es la salida común.
Según lo que entiendo el amp es estable...
lo que si veo que mi trazo de feedback es medio largo: 90 mm. masomenos....
bueno si alguien tiene cualquier critica soy todo oidos..
muchas gracias!
 

Adjuntos

  • sch-Ol.png
    sch-Ol.png
    154.8 KB · Visitas: 23
  • Oloop.png
    Oloop.png
    148.9 KB · Visitas: 23
Según diagrama sería bueno también experimentar con el valor de R17 (1K) parecería un tanto alto quizá reducir a 560 ohms , va a caer la ganancia de la etapa , colocar un capacitor de pequeño valor del orden de los pico faradios en paralelo con R17 limitaría el ancho de banda del sistema en límite superior, ahí también tendríamos una mejora para evitar oscilaciones de alta frec. Independientemente del comentario al circuito se lo ve completo bien diseñado y sin mas observaciones , el resultado final creo dependerá de la buena calidad de los componentes electrónicos utilizados.
 
Hola!
gracias indermornin!
Estuve estudiando el tema:
así como tengo el esquema + el inductor en la salida y un cap de 100p en T8 (B-C), el amp. no oscila al encender con mi carga "fantasma" en 2, 4 y 8 ohms pero tiene unas oscilaciones en el lado negativo de la onda cuando esta al mango...ahora cuando le enchufo un bafle que tengo para pruebas (de 6 ohms), directamente entra oscilando en los 410khz .(aprox)
Les dejo unas imágenes del osciloscopio (la primera de la oscilación al prender con el bafle, y la segunda de la oscilación sobre la carga fantasma).
Por todo esto, volví a hacer el análisis de estabilidad, un poco mejor:
PM (margen de fase)= 57º
GM (margen de ganancia)=11 db
Frecuencia de "crossover" = 926 khz
Beta=0,0434
La tercera imagen tiene la grafica de "lazo abierto" con esto (lo hice con otra técnica que me parece es mejor -tmb ejem. del ltspice-)
57º parece poco margen, no se que piensan?
Ahora con la sugerencia de indemornin de R17 en 560 me da esto:
PM= 72º
GM=16 db
Frecuencia de "crossover= 501 khz
beta = 0.0248

indemornin:​

Ya voy a probar lo que comentaste! muuuuchas gracias (no pude aun)
¿Que te parece mi layout ??
 

Adjuntos

  • osci1.jpg
    osci1.jpg
    88.6 KB · Visitas: 7
  • 100hz-8ohms.jpg
    100hz-8ohms.jpg
    79.2 KB · Visitas: 6
  • ana1.png
    ana1.png
    394.6 KB · Visitas: 5
Osea al bajar valor R17 aumenta la ganancia de la etapa, dejala en 1K o proba subir algo el valor (baja la ganancia) , independientemente de ello esa deformación en la onda decis que es cuando esta al máximo de potencia (100%), estaría interesante saber cual es el valor máximo y el punto justo en el cual aparece esa oscilacion . Podria llegar a pensar que algo ocurre durante el clip que mas alla de empezar a recortar el pico o cresta de la senoidal mete un ruido que se ve en la parte negativa de la onda, para descartar que te parece reemplazar el BD140 por un TIP42 ? no digo que sea el problema pero me paso con un amplificador que tenia un BD140 en la etapa clase A y me recortaba antes de lo previsto y lo cambie por un TIP y quedo solucionado.
Mensaje automáticamente combinado:

Otro tema que no contemplé en la respuestaanterior : durante las pruebas donde aparece esa deformación u oscilación en la parte negativa de la senoidal , estan hechas con el circuito de protección desconectado no??? descartemos que el circuito de protección este actuando!!!
 
Última edición:
indemornin!
Parece que es el asunto de la fase no mas:
45º es "marginalmente" estable (según leí), yo estoy en 52º... (beta=0,0434= 22k X 1k)
Ahora con 22k X 560 me da beta=0.024 y 72º de margen de fase y 16 db de margen de ganancia (allí dejo la imagen de ese análisis)....
Probé con ese cambio y estable como un tronco!! hasta con el parlante de 6ohms arranca sin oscilar y se fuero los pelos de la onda negativa (bd 140 de VA), todo hermoso!
Eso si: cap de 100p en driver negativo y el inductor en la salida PUESTOS (mas el de 100p del VA); si saco algo de esto comienza a asomar un poco de pelos en lado negativo, pero no auto oscila, ni se pone loco...
Por supuesto desconecte la proteccion (ni llegue a depurar eso todavía)
 

Adjuntos

  • ana2.png
    ana2.png
    416 KB · Visitas: 7
Estoy feliz suena de 10!
Termine con THD(20) en 0.35%, un poco arriba del 0.20% que quería pero bueno...( este thd es en 4 ohms al mangazo) con un cap (miller) de T8 de 56p...
Es super estable, y eso me alegra mucho...me falta ver la protección que tal va todavía...y de allí a re diseñar la placa final para "producción"...
Una cosa linda es que no hace ruido al prender (el simpático "Plop!")
Al fin pude probar el detector de pico que funciona MUY bien, no es la clásica "luz loca": se activa un toque antes del recorte, muy "elegantemente"...esta muy buena!
 
Bueno con todo corregido el esquema final va a ser este:


Al final el cap de T8 no es necesario, así que vuela de la versión final...
Incluye las redes en la salida y ademas toque un par de cositas mas por "aquí y por allá"...
el THD(20) termino en %0.32 al mangazo en 4 ohms.
El prototipo lo probé con una fuente (no muy buena) de maso 35+35 (todavía tengo que probar con la fuente de 50+50)
según el osciloscopio tiro unos 50wats limpios y de excelente sonido en 8ohms (la fuente de prueba no es buena realmente)
Al fin pude probar la protección!
como verán en las fotos y el video, la ajusté en 2,3 ohms para que salte.
El calibrado lo realice así: puse los preset a máxima resistencia, de esta forma el protector queda "sensible" y se activa prácticamente muy cerca de los 8 ohms (al mango)...De antemano en mi "resistencia de carga" (de cuerdas de guitarra!) tengo unas marcas en 4ohms y 2,3ohms (en la fotos y video se ve)Luego inyecto una señal de 1k al mango y en mi resistencia de carga la "corto circuito" para tener una idea por donde anda la sensibilidad, en mi caso al principio es prácticamente los 8 ohms, luego de a poco bajo la resistencia de los 2 preset POR IGUAL (por ejemplo 2 vueltas en cada uno) y vuelvo a ver en la resistencia de carga por donde salta el protector...de esta forma (y con paciencia) me voy acercando al valor objetivo: 2,3 ohms...y con este simpático procedimiento queda perfecta la protección. Cuando se activa suena asqueroso, pero bueno antes eso que quemar algo...
la onda con el protector en activo queda así:

El amp. reventado se ve así (sin ninguna cosa rara! :D :D: )


A 18khz al mango:

🥰🥰
Y les dejo un video del indicador de recorte y el protector en acción (y mi brazo peludo)
https://tridente.com.ar/diy/ACR-2020/final.webm
Ahora me falta diseñar la placa final ....ah!! las sospechas de que el layout estaba malo no tiene nada que ver....así que quedara masomenos por allí.
 

Adjuntos

  • sch-37.png
    sch-37.png
    31.4 KB · Visitas: 5
  • protec-2ohms.jpg
    protec-2ohms.jpg
    71.4 KB · Visitas: 3
  • recorte.jpg
    recorte.jpg
    76.6 KB · Visitas: 0
  • 18khz-mango.jpg
    18khz-mango.jpg
    75.2 KB · Visitas: 3
Arriba