Amplificador ACR 2020 :P

Hola gente…
Bueno aquí otro proyecto mas y se trata de mi version-evolución del amplificador RCA 130 de siempre.
La idea era hacer unas mejoras, pero quería mantenerlo simple...así que saque algunas ideas de "aquí y allá" y quedo esto.
Los cambios que hice: usar 2sc5200 en vez de los 2n3055 (cuasi complementario como el original), como drivers use tip41c y tip42c para el VA use BD140, y tiene un bc546b para ajustar el bias.
Agregue unos filtros en -vcc y +vcc y en la entrada para minimizar la posibilidad de oscilaciones.
Tiene una entrada “balanceada” para poder usar con equipos profesionales (mi motivación principal), un protector contra corto del tipo PERMANENTE (el original era momentáneo como lamentablemente pude comprobar
:P
) y un indicador de recorte (del lado positivo y negativo de la onda).
La ganancia es de 22 aprox. Y con 1.13 Vp esta al mango, tiene un pote para ajustar el volumen.
La protección se activa con una carga de 2 ohms con una Radj1 y Radj2 de alrededor de 160 ohms …
En el emulador da la siguiente perfomance:
con +-50V de fuente
en 4 ohms y con 20khz tenemos
VpPot WTHD(20)
0.5046.47340.053921%
0.7092.88850.068071%
1185.4890.123292%
1.13236.5870.200778%

en 4 ohms y con 1khz tenemos
VpPot WTHD(1)
0.547.38430.015054%
0.7094.5710.016781%
1188.9490.035407%
1.13241.1180.049819%


en 8 ohms es un poquito mejor todavía.

Dejo la imagen del simulador en 20khz..
El amp. esta andando pero no como esperaba...
Por ahora lo que mas me preocupa es una oscilación en 600khz, del lado negativo de la onda...
Es por eso que recurro a la sapiencia del foro: en T4 tengo el capacitor C9 (creo compensación miller) de 100Picos que es un valor aceptable para mis expectativas de distorsión en alta frecuencia, el tema es que con ese valor el amp oscila....con 150picos la zafa pero arruina un poco el thd en alta frecuencia...
Estoy convencido que mi layout de mi PCB no es tan bueno y por allí viene la mano.
También vi que algunas veces cuando corto la señal queda oscilando (linda calentada que le pega a los tr de salida)
Una cosa que noté en una placa comercial de otro amp. es que sus "T1 y T2" están pegado a su "T4 y su capacitor"... puede ayudar a hacer mas estable el amp.?
Dejo aquí el esquema y el layout por si alguien me tira un dato o un consejo de como hacerlo mejor, estaré eternamente agradecido!!
gracias y saludos
 

Adjuntos

  • ACR-simul.png
    ACR-simul.png
    52 KB · Visitas: 112
  • sch141.png
    sch141.png
    177.9 KB · Visitas: 133
  • layout141.png
    layout141.png
    332.1 KB · Visitas: 123
  • placa2.jpg
    placa2.jpg
    119.1 KB · Visitas: 82
  • placa1.jpg
    placa1.jpg
    92.6 KB · Visitas: 61
Buenas tardes! Probar insertando un capacitor de 1nF entre base y colector del TIP42 (T8) .Cordial saludo!
Muchas gracias por la ayuda!
Con el capacitor de 1nf se va las oscilaciones, pero lamentablemente se arruina un poco el thd 20khz= 4.48%
No se si mi una mejor PCB ayudaría a mermar los problemas
muchas gracias!
 

Dr. Zoidberg

Well-known-Papá Pitufo
No se si mi una mejor PCB ayudaría a mermar los problemas
Y para saberlo deberías simular el circuito agregando las inductancias parásitas de las pistas y las capacidades parásitas entre los tracks --> es un bodrio importante para un diseño discreto.

Si con 1nF se te escapa la distorsión a 20kHz (lo que es algo que ahora no importa) ponele uno mas chico, y reducilo hasta que la distorsion sea razonable y el amplificador se mantenga estable.

Te aviso que con un circuito nacido tipo Frankestein no podes esperar maravillas. Tenes que analizarlo y depurarlo antes de probar simulaciones que "tantean" una estructura que no sabemos que tan buena es.
 
Y para saberlo deberías simular el circuito agregando las inductancias parásitas de las pistas y las capacidades parásitas entre los tracks --> es un bodrio importante para un diseño discreto.

Si con 1nF se te escapa la distorsión a 20kHz (lo que es algo que ahora no importa) ponele uno mas chico, y reducilo hasta que la distorsion sea razonable y el amplificador se mantenga estable.
Gracias por la ayuda...
si eso que comentas he probado: con 331p tira hasta 8 ohms pero con carga mas exigente se vuelve inestable...con el de 1nf es estable hasta los 2 ohms que probé....
a veces al encenderlo sin señal queda oscilando en 600khz, según la carga y el cap...
eso si suena excelente, así que lo voy a seguir trabajando para aprender
 
Gracias por la ayuda...
si eso que comentas he probado: con 331p tira hasta 8 ohms pero con carga mas exigente se vuelve inestable...con el de 1nf es estable hasta los 2 ohms que probé....
a veces al encenderlo sin señal queda oscilando en 600khz, según la carga y el cap...
eso si suena excelente, así que lo voy a seguir trabajando para aprender
Hola. Tener en cuenta incorporar una red de zobel en la salida de parlante , la misma esta compuesta por R25 y C15, faltaria un pequeño inductor para completarla. También realizar las pruebas con la placa metida dentro de una caja de aluminio o bien apoyada en una base metalica (chapón) puesta a tierra (aislada de las pistas de la placa porsupuesto para evitar cortos) ; además los cables desde la fuente de alimentacion al modulo lo mas cortos posibles, la frecuencia indicada en la que mencionas te estaría oscilando podría ser vestigios de una Radio AM que se esta filtrando (digo por la frecuencia de 600Khz), otra cosa a revisar por ultimo es quitar el capacitor electrolítico C17 , aveces dependiendo del diseño de la placa suele meter ruidos en vez de filtrarlos , me ha pasado! para probar puedes quitarlo o bien poner menor valor o mayor(no superior a 470uf) e ir probando.Cordial saludo!
 
Hola. Tener en cuenta incorporar una red de zobel en la salida de parlante , la misma esta compuesta por R25 y C15, faltaria un pequeño inductor para completarla. También realizar las pruebas con la placa metida dentro de una caja de aluminio o bien apoyada en una base metalica (chapón) puesta a tierra (aislada de las pistas de la placa porsupuesto para evitar cortos) ; además los cables desde la fuente de alimentacion al modulo lo mas cortos posibles, la frecuencia indicada en la que mencionas te estaría oscilando podría ser vestigios de una Radio AM que se esta filtrando (digo por la frecuencia de 600Khz), otra cosa a revisar por ultimo es quitar el capacitor electrolítico C17 , aveces dependiendo del diseño de la placa suele meter ruidos en vez de filtrarlos , me ha pasado! para probar puedes quitarlo o bien poner menor valor o mayor(no superior a 470uf) e ir probando.Cordial saludo!
Hola indemornin
mil gracias por la ayuda!
probé un inductor y un cap de 100p en T8 y T4 (THD20= 0.21 a 236W sobre 4ohms) puestos directos sobre ellos (el manual de la RCA dice que el capacitor tiene que estar lo mas cerca osible del transistor)
y logre lo que se ve en las imágenes, un poco de oscilaciones justo en el momento del recorte (100hz en 8ohms y 50hz en 2 ohms respectivamente)
Pude probar de sacar C17 pero se puso loco, fue a peor ;) así que lo deje (no tenia otro a mano para probar)
 

Adjuntos

  • 100hz-8ohms.jpg
    100hz-8ohms.jpg
    79.2 KB · Visitas: 11
  • 50hz-2ohms.jpg
    50hz-2ohms.jpg
    70.9 KB · Visitas: 11
Hola! siguiendo con el tema de la oscilaciones tengo este análisis de respuesta de frecuencia y fase de "lazo abierto" por el tema de la estabilidad...
Lo hice siguiendo los algunos ejemplos del ltspice (básicamente es insertar una fuente de voltaje en el feedback, dejo el esquema con estos detalles) y usar en análisis de AC.
En la imagen de las curvas la linea punteada es la fase y la solida la ganancia.
En la grafica superior esta la ganancia de lazo abierto y están marcado cuatros puntos:
la frecuancia donde la ganancia es 20db, la fase de este punto, el punto donde la ganancia es 1db (741 khz) y el punto donde la fase se hace 180º (4.81Mhz)
Con una ganancia de 20db me da un margen de fase 93º (180º - 87º)
La "unity gain frequency" seria de aprox. 741 khz
(todo esto siguiendo el ejemplo que me paso amablemente Dr. Zoidberdg (Taming the LM3886 Chip Amplifier: Stability))
La otra mitad del amp. es la salida común.
Según lo que entiendo el amp es estable...
lo que si veo que mi trazo de feedback es medio largo: 90 mm. masomenos....
bueno si alguien tiene cualquier critica soy todo oidos..
muchas gracias!
 

Adjuntos

  • sch-Ol.png
    sch-Ol.png
    154.8 KB · Visitas: 37
  • Oloop.png
    Oloop.png
    148.9 KB · Visitas: 36
Según diagrama sería bueno también experimentar con el valor de R17 (1K) parecería un tanto alto quizá reducir a 560 ohms , va a caer la ganancia de la etapa , colocar un capacitor de pequeño valor del orden de los pico faradios en paralelo con R17 limitaría el ancho de banda del sistema en límite superior, ahí también tendríamos una mejora para evitar oscilaciones de alta frec. Independientemente del comentario al circuito se lo ve completo bien diseñado y sin mas observaciones , el resultado final creo dependerá de la buena calidad de los componentes electrónicos utilizados.
 
Hola!
gracias indermornin!
Estuve estudiando el tema:
así como tengo el esquema + el inductor en la salida y un cap de 100p en T8 (B-C), el amp. no oscila al encender con mi carga "fantasma" en 2, 4 y 8 ohms pero tiene unas oscilaciones en el lado negativo de la onda cuando esta al mango...ahora cuando le enchufo un bafle que tengo para pruebas (de 6 ohms), directamente entra oscilando en los 410khz .(aprox)
Les dejo unas imágenes del osciloscopio (la primera de la oscilación al prender con el bafle, y la segunda de la oscilación sobre la carga fantasma).
Por todo esto, volví a hacer el análisis de estabilidad, un poco mejor:
PM (margen de fase)= 57º
GM (margen de ganancia)=11 db
Frecuencia de "crossover" = 926 khz
Beta=0,0434
La tercera imagen tiene la grafica de "lazo abierto" con esto (lo hice con otra técnica que me parece es mejor -tmb ejem. del ltspice-)
57º parece poco margen, no se que piensan?
Ahora con la sugerencia de indemornin de R17 en 560 me da esto:
PM= 72º
GM=16 db
Frecuencia de "crossover= 501 khz
beta = 0.0248

indemornin:​

Ya voy a probar lo que comentaste! muuuuchas gracias (no pude aun)
¿Que te parece mi layout ??
 

Adjuntos

  • osci1.jpg
    osci1.jpg
    88.6 KB · Visitas: 8
  • 100hz-8ohms.jpg
    100hz-8ohms.jpg
    79.2 KB · Visitas: 7
  • ana1.png
    ana1.png
    394.6 KB · Visitas: 6
Osea al bajar valor R17 aumenta la ganancia de la etapa, dejala en 1K o proba subir algo el valor (baja la ganancia) , independientemente de ello esa deformación en la onda decis que es cuando esta al máximo de potencia (100%), estaría interesante saber cual es el valor máximo y el punto justo en el cual aparece esa oscilacion . Podria llegar a pensar que algo ocurre durante el clip que mas alla de empezar a recortar el pico o cresta de la senoidal mete un ruido que se ve en la parte negativa de la onda, para descartar que te parece reemplazar el BD140 por un TIP42 ? no digo que sea el problema pero me paso con un amplificador que tenia un BD140 en la etapa clase A y me recortaba antes de lo previsto y lo cambie por un TIP y quedo solucionado.
Mensaje automáticamente combinado:

Otro tema que no contemplé en la respuestaanterior : durante las pruebas donde aparece esa deformación u oscilación en la parte negativa de la senoidal , estan hechas con el circuito de protección desconectado no??? descartemos que el circuito de protección este actuando!!!
 
Última edición:
indemornin!
Parece que es el asunto de la fase no mas:
45º es "marginalmente" estable (según leí), yo estoy en 52º... (beta=0,0434= 22k X 1k)
Ahora con 22k X 560 me da beta=0.024 y 72º de margen de fase y 16 db de margen de ganancia (allí dejo la imagen de ese análisis)....
Probé con ese cambio y estable como un tronco!! hasta con el parlante de 6ohms arranca sin oscilar y se fuero los pelos de la onda negativa (bd 140 de VA), todo hermoso!
Eso si: cap de 100p en driver negativo y el inductor en la salida PUESTOS (mas el de 100p del VA); si saco algo de esto comienza a asomar un poco de pelos en lado negativo, pero no auto oscila, ni se pone loco...
Por supuesto desconecte la proteccion (ni llegue a depurar eso todavía)
 

Adjuntos

  • ana2.png
    ana2.png
    416 KB · Visitas: 9
Estoy feliz suena de 10!
Termine con THD(20) en 0.35%, un poco arriba del 0.20% que quería pero bueno...( este thd es en 4 ohms al mangazo) con un cap (miller) de T8 de 56p...
Es super estable, y eso me alegra mucho...me falta ver la protección que tal va todavía...y de allí a re diseñar la placa final para "producción"...
Una cosa linda es que no hace ruido al prender (el simpático "Plop!")
Al fin pude probar el detector de pico que funciona MUY bien, no es la clásica "luz loca": se activa un toque antes del recorte, muy "elegantemente"...esta muy buena!
 
Bueno con todo corregido el esquema final va a ser este:

sch-37.png

Al final el cap de T8 no es necesario, así que vuela de la versión final...
Incluye las redes en la salida y ademas toque un par de cositas mas por "aquí y por allá"...
el THD(20) termino en %0.32 al mangazo en 4 ohms.
El prototipo lo probé con una fuente (no muy buena) de maso 35+35 (todavía tengo que probar con la fuente de 50+50)
según el osciloscopio tiro unos 50wats limpios y de excelente sonido en 8ohms (la fuente de prueba no es buena realmente)
Al fin pude probar la protección!
como verán en las fotos y el video, la ajusté en 2,3 ohms para que salte.
El calibrado lo realice así: puse los preset a máxima resistencia, de esta forma el protector queda "sensible" y se activa prácticamente muy cerca de los 8 ohms (al mango)...De antemano en mi "resistencia de carga" (de cuerdas de guitarra!) tengo unas marcas en 4ohms y 2,3ohms (en la fotos y video se ve)Luego inyecto una señal de 1k al mango y en mi resistencia de carga la "corto circuito" para tener una idea por donde anda la sensibilidad, en mi caso al principio es prácticamente los 8 ohms, luego de a poco bajo la resistencia de los 2 preset POR IGUAL (por ejemplo 2 vueltas en cada uno) y vuelvo a ver en la resistencia de carga por donde salta el protector...de esta forma (y con paciencia) me voy acercando al valor objetivo: 2,3 ohms...y con este simpático procedimiento queda perfecta la protección. Cuando se activa suena asqueroso, pero bueno antes eso que quemar algo...
la onda con el protector en activo queda así:
protec-2ohms.jpg

El amp. reventado se ve así (sin ninguna cosa rara! :D :D: )
recorte.jpg


A 18khz al mango:
18khz-mango.jpg

🥰🥰
Y les dejo un video del indicador de recorte y el protector en acción (y mi brazo peludo)
https://tridente.com.ar/diy/ACR-2020/final.webm
Ahora me falta diseñar la placa final ....ah!! las sospechas de que el layout estaba malo no tiene nada que ver....así que quedara masomenos por allí.
 

Adjuntos

  • sch-37.png
    sch-37.png
    31.4 KB · Visitas: 12
  • protec-2ohms.jpg
    protec-2ohms.jpg
    71.4 KB · Visitas: 9
  • recorte.jpg
    recorte.jpg
    76.6 KB · Visitas: 4
  • 18khz-mango.jpg
    18khz-mango.jpg
    75.2 KB · Visitas: 12
Hola gente, como va?
Ya terminado este proyecto... les dejo el esquema final con unos cambios.
ACRNT2020(V1.8)-R396-sch.png

El principal es que T4 (VA) pasa a J350 o mejor a 2SA1837 en cuenta del BD140, porque me parece esta muy justo para fuentes de mas de +-36vcc. En el primer prototipo lo use (+-36vcc) sin problemas (y le di para que tenga!) pero es mejor mas margen (según el simulador, de los tres, el BD140 es el que produce menos distorsión).
En el segundo amplificador que hice use MJE350 directamente.

Dejo las placas finales en 3 versiones: 2 para el BD140 (una de ellas con el inductor y su resistencia asociada en la placa, la otra es para montar afuera); y la tercera es para el 2SA1837 o J350 (tiene el inductor-resistencia en la placa).
Versión 2SA1837-J350
ACR%20NT2020-FULL(V1.81-R3.96).png

Versiones para BD140
ACR%20NT2020-FULL(V1.81-R3.96-Alt).png

ACR%20NT2020-FULL(V1.4-R3.96-Alt%20).png




También dejo los archivos “fuente” de ExpressPCB por si alguien quiere modificarlo a su necesidad; solo le ruego que lo comparta!
PCBs
Pcb J350 - 2SA1837
Pcb BD140 (L-R exterior)
Pcb BD140 (L-R en placa)
Esquema
Esquema para editar



Ya armaré una pcb para mas transistores de salida y con modo “puente” (la distorsión mejora)

El rendimiento medido da un THD(1) 0.45% aprox. antes de que la luz de recorte se encienda y de 0.64% cuando comienza a iluminar, tomado en el prototipo con una fuente bastante floja y con el J350 mas unos 2n3055 (falsos creo) en la salida (no es optimo)

La técnica para medir que use fue la siguiente: le enchufe mi carga fantasma “hechiza” de cuerdas de guitarra en “modo 8 ohms”, de aquí tome la señal de salida con un divisor resistivo: (salida→22k→^muestra^1k→tierra)

^muestra^ la inyecte a una placa de sonido configurada en 96K y con el programa de audio REAPER (que es completamente funcional en su demo) use sus herramientas de analizador de espectro y el generador de señales; Con eso tome capturas de pantalla de los espectros resultantes.

Antes de medir el amplificador, tome una muestra en “bucle” de la placa de sonido (out→in) para medir el THD(1) propio, que dio aproximadamente 0. 031% (o sea que no podemos medir nada menos que eso)
Espectro del loop
Cal-1khz.png

Con estas capturas tome los datos a “ojo” y los introduje en una hoja de calculo, que arme para que calcule THD y la potencia...
Espectro de la 3° medición
spc-1k(3).png


Lamentablemente perdí los datos de salida, así que los resultados no quedaron tan completos:

THD(1) para aprox. %80 de potencia= 0,24%

THD(1) para aprox. %90 de potencia= 0,45%

THD(1) para aprox. %95 de potencia= 0,64%

med.png


Dejo la hoja de calculo por si alguien quiere medir algo con esta humilde técnica.

Para usarla solo tienen que rellenar los datos disponibles en los casilleros blancos (si un armónico no les “aparece” rellenen con -130, sino da error.

Apenas pueda voy a repetir las mediciones para saber la potencia mejor (y también en 4 ohms y THD(10)) pero ya sobre un amplificador con mejores transistores de salida y sobre todo con una fuente como la gente.

Me quedo como deuda: probar entre el bd140 y elJ350 si hay cambios mensurables de THD y la respuesta en frecuencia del amplificador (se me empaco el Soft!!)

También el prototipo funciono perfecto con +-20Vcc
Lo mejor es que Suena excelente (y es muy silencioso! tampoco hace “plop” al encender o apagar!)

PD: en los adjuntos pdf de la lista de partes, los pdf de las PCB (3 versiones) , un pdf con un par de comentarios y un zip con la hoja de calculo.
 

Adjuntos

  • ACRNT2020(V1.8)-R396-Lista-BOM.pdf
    29.3 KB · Visitas: 19
  • ACRNT2020(V1.8)-R396-Leer.pdf
    29.1 KB · Visitas: 18
  • ACR NT2020-TOP(V1.81-R3.96-Alt).pdf
    27 KB · Visitas: 17
  • ACR NT2020-TOP(V1.4-R3.96-Alt ).pdf
    27.3 KB · Visitas: 17
  • ACR NT2020-PCB(V1.81-R3.96-Alt).pdf
    32.6 KB · Visitas: 15
  • ACRNT2020(V1.8)-R396.pdf
    47.2 KB · Visitas: 19
  • ACR NT2020-FULL(V1.4-R3.96-Alt ).pdf
    47.5 KB · Visitas: 16
  • ACR NT2020-FULL(V1.81-R3.96).pdf
    49.1 KB · Visitas: 16
  • ACR NT2020-PCB(V1.81-R3.96).pdf
    32.5 KB · Visitas: 15
  • ACRNT2020(V1.8)-R396-sch.png
    ACRNT2020(V1.8)-R396-sch.png
    33 KB · Visitas: 20
  • ACR NT2020-FULL(V1.81-R3.96-Alt).pdf
    49.6 KB · Visitas: 15
  • ACR NT2020-TOP(V1.81-R3.96).pdf
    26.6 KB · Visitas: 16
  • ACR NT2020-PCB(V1.4-R3.96-Alt).pdf
    30.5 KB · Visitas: 15
  • med.ods.zip
    15.7 KB · Visitas: 15
Última edición:
Al final realice las mediciones de nuevo y las que me faltaban sobre el mismo prototipo, como para ver mejor el resultado.
También hice pruebas con un amplificador comercial Alesis RA150 para comparar.
El calculo de THD los simplifique a los 3 armónicos de mayor magnitud porque entre prueba y prueba me di cuenta que el THD varia muy poco mas allá de esos 3, era trabajo extra solo para cambiar muy poco.
Aquí la respuesta en frecuencia:
Primero la respuesta de mi "sistema de medida"
Ref.png

La escala de la magnitud es de -3 a 3...
El amplificador dio esto:
ACRNT2020-Rf.png

de 30hz a 20khz de 0db a -1.5db (medido al palo)
Lo de la fase es algo que no entiendo bien porque da así....
Y Ahora las de distorsión THD(1) con el método simplificado de 3 armónicos en 8 ohms:
ThdxPot.png

un THD de 0,21% para 3,4W y 0,59% para 49W
El amplificador comercial dio 0,22% para 19,5W y 0,29% para 55,5W.
Noto que la distorsión no sube tan "empinada" en ese amplificador...de todas formas el amp. casero comparativamente esta bastante bien...Seria lindo poder medir mas amplificadores como para poder comparar mejor.
Los graves son espectaculares y viendo el grafico quizás sea por la respuesta (lo agudos son muy buenos también, pero como oyente me impacto los graves sobre todo)
Si el tiempo me da (y el cerebro!) voy a intentar una version 2021...
 
Arriba