Avería extraña en piano Yamaha Piaggero NP12

Hola a todos. Ante todo gracias por todos los conocimientos que compartís.

Tengo un problema con un teclado eléctrico, en concreto un Yamaha Piaggero NP12 que usa mi hija. Adelanto que mis conocimientos de electrónica son muy limitados, lo poco que he hecho, con Arduinos y de forma totalmente autodidacta: ya con los transistores me hago un lío.

Antes del confinamiento comenzó a no encender. Pulsábamos la tecla on y se encendía un led durante unas décimas de segundo y se volvía a apagar. Era como que la fuente de alimentación no "arrancaba" el teclado. De vez en cuando, aleatoriamente, se encendía. Dispuesto estaba a llevarlo al servicio técnico, cuando llegó el virus y el estado de alarma, así que lo dejé guardado.

Ahora que ya hay movilidad, lo pruebo antes de llevarlo y funcionaba siempre. Raro. Al día siguiente, día tormentoso, bajan temperaturas y deja de funcionar. Le acerco un secador de pelo y de nuevo enciende. Al rato, ya frío, ya no arranca.

Hoy me animo a desarmarlo, sospecho que puede ser un condensador. Localizo la fuente de alimentación y calentando y enfriando alternativamente el condensador más gordo, se enciende o no. No hace falta mucho, el límite de sensibilidad debe estar alrededor de los 22 grados. Se trata de un condensador de 25V y 1000uF, y el tester que tengo solo llega a 200uF (o no sé medirlo), y en cualquier caso marca 150uF.

A la pregunta. Está claro que este método científico 😁 que he utilizado apunta a que el fallo esté ahí, pero, ¿tiene sentido, o es posible? He buscado y no he encontrado por ninguna parte que un condensador a punto de cascar tenga esa "sensibilidad" a la temperatura. Más bien al contrario, o sea, que falle por alta temperatura, no por debajo de un valor nada extremo.

Estas son fotos de la fuente y del condensador en concreto.





Tenía otra duda, si me permitís. Si efectivamente fuera eso, he pensado en sustituirlo. Tengo alguno por casa, pero no de esos valores. En concreto los que tengo son de 35V y 2200uF, que compré hace tiempo para arreglar un flash. ¿Sucedería algo en este caso? En muchos sitios he leído que no pasaría nada, pero no sé si en este dispositivo concreto podría causar algún daño.

Gracias por vuestra ayuda inestimable.
 

DOSMETROS

High 2m Modereitor
Si , probá tranquilo con el de 2200 por 35V.

Hay dos temas distintos con la temperatura , con un poco de ella los capacitores trabajan mejor , por otro lado se arruinan los capacitores recalentados . . .
 
Mira con una lupa o repasa las soldaduras de ese condensador. Hay veces que ese tipo de fallos es producido por una soldadura defectuosa. Suele ocurrir en piezas grandes. Por eso suelen ir además de soldadas pegadas con una especie de silicona.
Si es esa la causa, se ve dando unos golpecitos a la pieza sospechosa con algo aislante y viendo si así enciende.
 
Los condensadores electrolíticos cambian un poco su capacidad (en faradios) con el calor. Tras leerlo en varias web lo comprobé cogiendo un condensador y conectándolo a mi capacímetro y calentándolo con un mechero. No recuerdo ahora cuanto le subió la capacidad pero un 10% de incremento pudo ser perfectamente. Si tienes un condensador con una capacidad ligeramente más baja de lo que le permite trabajar con normalidad, ese calor extra que le estás dando, hace que suba su capacidad lo justo para que haga su función.
 
Mira con una lupa o repasa las soldaduras de ese condensador. Hay veces que ese tipo de fallos es producido por una soldadura defectuosa. Suele ocurrir en piezas grandes. Por eso suelen ir además de soldadas pegadas con una especie de silicona.
Si es esa la causa, se ve dando unos golpecitos a la pieza sospechosa con algo aislante y viendo si así enciende.

Gracias. He probado lo que comentas, no he visto nada raro y los golpecitos no lo activan si está frío. He repasado las soldaduras y nada...
Así que finalmente lo he cambiado.
Parece que el problema persiste, aunque me da la impresión de que hay que enfriarlo más. Lo enfrío con una bolsa de gel del congelador, de forma lo más concentrada en el condensador que puedo. Podría ser que el frío se transmitiera a otro elemento que esté cerca que sea el que está dañado.
En fin, mi gozo en un pozo. De momento funciona, esperaré al inverno con temperatura menos benigna, para ver qué pasa.

Gracias a todos por la ayuda.
 

Pinchavalvulas

Well-Unknown member
Si tienes un condensador con una capacidad ligeramente más baja de lo que le permite trabajar con normalidad, ese calor extra que le estás dando, hace que suba su capacidad lo justo para que haga su función.
Parece que el problema persiste, aunque me da la impresión de que hay que enfriarlo más. Lo enfrío con una bolsa de gel del congelador, de forma lo más concentrada en el condensador que puedo. Podría ser que el frío se transmitiera a otro elemento que esté cerca que sea el que está dañado.
También puede ser que al variar la capacidad del condensador, aumentando la temperatura, el circuito en sí vuelva a funcionar por estar calentando la zona en general o porque las propiedades de otro o varios componentes han cambiado.. :unsure:
Me ha pasado que al calentar un condensador el televisor recuperara la imagen y sin embargo la avería en sí estaba en la otra punta de la placa.
Así que finalmente lo he cambiado.
A veces da mas capacidad el condensador viejo que el nuevo..
 
Me ha pasado que al calentar un condensador el televisor recuperara la imagen y sin embargo la avería en sí estaba en la otra punta de la placa.

¿Quizá ese calor localizado en un lugar provoca alguna ligera torsión de la placa que se manifiesta en la otra punta? Quizá si en la otra punta tienes soldaduras frías... la torsión hace que funcione bien el dispositivo. ¿?
 

Pinchavalvulas

Well-Unknown member
Para lograr conseguir esa torsión, de una punta a otra de la placa, debería de haber recalentado bastante y no.. tampoco sé si con un secador de mano se llegaría a ese extremo.
Para buscar averías no es necesario calentar en exceso, con aplicar calor lo mas centrado posible durante unos segundos o un par de minutos máximo (dependiendo de la época y temperatura ambiente) ya se nota la reacción que buscamos. Si hay que calentar en exceso posiblemente no esté la avería en esa zona y sea normal la reacción de los componentes en ese caso extremo.
 
En mi caso, como decía, el límite está alrededor de los 22ºC, es decir, por debajo de esa temperatura no enciende, por encima sí.
Hoy probaré, ya que la temperatura estará por debajo de ésa.
 

Pinchavalvulas

Well-Unknown member
Fotos de la placa por el lado de las soldaduras.. :rolleyes:
Para que al enfriar el condensador llegue a los que están pegados (no tan pegados según imagen) debe ser mucho frío el que se aplique.
Podría ser que debajo haya algún componente al que sí le llegue el fresquito.
 
Cuando tenga un hueco vuelvo a destapar y subo fotos. Tampoco aplico tanto frío, uso una bolsa de gel del congelador 10 o 20 segundos alrededor del condensador, no tocando nada más. Luego lo caliento con los dedos otros 15-20 segundos para que recupere la temperatura, y es cuando vuelve a encender. No hay nada alrededor salvo lo que se ve, los más cercanos son los condensadores cerámicos y los que marcan 154G. No sé...
Ayer finalmente no había bajado tanto la temperatura como para que no encendiera, seguiré probando.
Gracias por la respuesta.
 
Arriba