Circuito de iniciacion a la programacion en basic

#1
Hola, soy Sergi (por si se quieren dirigir a mi), y me estoy iniciando a la programacion, la cuestion esque encontre un circuito de 8 leds, para la practica de diferentes programas. El problema esque no me funciona nunca, lo alimento a 5V a 200mA. En este tema os dejo una imagen del circuito + la programacion, y desearia que me dijeran si el error es del diagrama, de la programacion, o d ambos, y cual es ese error, para que no me vuelva a ocurrir mas :evil:.

PROGRAMACIÓN:
"
AllDigital
TRISA = %11111111
TRISB = %00000000
Dim step1 As Bit
Dim step2 As Bit
Dim rutina As Bit
Symbol led1 = PORTB.0
Symbol led2 = PORTB.1
Symbol led3 = PORTB.2
Symbol led4 = PORTB.3
Symbol led5 = PORTB.4
Symbol led6 = PORTB.5
Symbol led7 = PORTB.6
Symbol led8 = PORTB.7
step1: 'rutina 1
led1 = 1
led1 = 0
led2 = 1
led2 = 0
led3 = 1
led3 = 0
led4 = 1
led4 = 0
led5 = 1
led5 = 0
led6 = 1
led6 = 0
led7 = 1
led7 = 0
led8 = 1
led8 = 0
Goto step1
"

Me harian un gran favor ayudandome, gracias de antemano, y que tengan un buen dia.


Soopy46
 

Adjuntos

Última edición por un moderador:
#2
Hola Sergi:

El primer detalle que me salta a la vista es que no estás utilizando ningún tipo de retardo para poder visualizar como encienden y apagan los leds. Lo está haciendo tan rápido que es imposible que el ojo pueda distinguir cada paso.

A veces cambian un poco las sentencias de comandos internos dependiendo de cada programa.
Yo uso proton para los programas en basic, para hacer los retardos escribes:

DelayMS 500 (retardo de medio segundo)
El número que sigue al comando debe ser expresado en milisegundos.Por lo que quedaría:
step1: 'rutina 1led1 = 1DelayMS 500led1 = 0DelayMS 500led2 = 1[/SIZE]DelayMS 500 led2 = 0DelayMS 500etc....

Y la parte que también llamó mi atención es la de los "dim"

En la primera declaras "step1" como un bit, pero después la utilizas como etiqueta (step1: 'rutina 1), que yo sepa eso no es muy recomendable.

La segunda y tercera, no son usadas dentro del programa, por lo que están de más, ya que te están gastando memoria del micro-controlador.

a ver como te responde cuando le pongas los retardos.

Saludos al foro :D
 
Última edición:
Arriba