Comparar voltajes variables, es decir, sin Vref. fijo

#41
Amigo, existe otro problema en tu circuito que estamos menospreciando. Si dices que el rele "zumba", pues existen estas posibilidades: el transistor no excita correctamente al mismo o la alimentacion del mismo no es la suficiente o esta filtrada no convenientemente.
Por otra parte las tensiones Vin y/o Vref. no son estables. Pues con porcentaje de histeresis no deberia suceder eso.
Para ir eliminando items, coloca en la entrada de cada pin, inversor y no inversor del op-amp un condensador de aprox. 100uF a GND.
 
#42
Saludos.

Gracias Gudino Roberto duberlin por esta opcion (cap 100uF) que intentare enseguida, en cuato a si la alimentacion no es suficiente, te comento que la alimentacion es de 8V para el relay de 5V, sera necesario aumentar esta alimentacion.:unsure:

Entonces no son estables las entradas, intentare con los capacitores y te comento

No entendi eso sobre que esta filtrada no convenientemente, alimento por separado al relay con un eliminador fijo de 7.2V pero que da aprox los 8V que comento.

Igualmente gracias powerful por la recomendacion del potenciometro, parece arreglarse un poco el problema de mantener esa diferencia de 0.4V para varios voltajes.

Gracias por su ayuda:apreton:
 
#44
Saludos

Les comento que el cto ya funciona correctamente, primero le puse los capacitores que me recomendaste Gudino Roberto duberlin pero no de 100uF ya que no tenia, le puse de 47uF como pueden ver en el cto que adjunto, ya con esto la diferencia de voltaje entre Vin y Vref bajo de esos 0.40V hasta unos 0.10 :), pero tambien le puse a la salida un capacitor mas de 10uF y con esto el cto funciona con practicamente los voltajes igualados (y)., pero como pueden ver en el cto dejo una separacion de unos 3V entre Vref y Vin.

Sera necesario que cambie los capacitores de 47uF por unos de 100uF:unsure:

Como siempre gracias por su ayuda powerful y Gudino Roberto duberlin :apreton: saludos
 

Adjuntos

Temas similares

Arriba