Comportamiento extraño de baterías Ni-MH

Circuito terminado y funcionando:

Ver el archivo adjunto 262862

Después de probarlo a fondo, veo la necesidad de cambiar los valores de las resistencias para que corten a mayor tensión (quizás un poco por encima de 7V y rearmen también más arriba (6,2 - 6,3 V?). Si alguien me puede echar una mano con esto se lo agradeceré porque estoy un poco atorado con este tema. Tengo una histéresis más o menos adecuada (1,2 V aprox) pero debería desplazar los valores de tensión hacia arriba.

Por otro lado, detecto un problema más o menos leve: Si retiro las baterías y pretendo que el circuito funcione a 12V, el sistema se pone a oscilar (el relé ratea). Al no haber tensión de baterías y estar el contacto del relé cerrado, la entrada no inversora recibe la salida directa del cargador.
Retiras bateria? osea extraer botar sacar extirpar sacar... por que harías eso?? estas metiendo otra condición de borde..
Calienta el 317¿
Cuantas placas quieres hacer??
Mensaje automáticamente combinado:

Nuevo golpe bajo... Una vez todo construido y comprobado, conecto la alimentación del circuito externo (que consume alrededor de 1 Amperio) y todo se viene abajo. Los valores se modifican y el cargador deja de cargar... Utilizo una fuente de 3 Amperios y las baterías tienen una capacidad de 2500 mAh

Como esto siga así, tendré que replantearlo absolutamente todo...:mad:
Eso se llama hacer ciencia... prueba y error..
3amper?... que tu bateria sea de 2.5amper no significa que tengas que ponerle un transformador de 2.5amper o mas.. ya antes te explique que solo consume 0.25amper.. tu transformador deberia ser 1.25amper.
Recuerda que la bateria en algun momento va a cargarse y su consumo va a ser 0amper... no se por que piensas que 3amper va a ser necesario.
 
Última edición:
Hola Emilio,

Creo que no me estás entendiendo... No uso ningún transformador de 3 A. Tengo una fuente de laboratorio (entre otras) de 3 A, regulable entre 0 y 30 Voltios y con posibilidad de limitación de corriente. Esta es la fuente que utilizo para hacer las pruebas y, si lo mencioné, fue para recalcar que iba más que sobrado de corriente y que el problema no era que se me "amorrase" la tensión al consumir bastante.

¿Por qué sacar las baterías? Verás, yo no sé lo que va a hacer un usuario con ese aparato que vamos a intentar construir (disculpad que por el momento no lo desvele, pero mi socio me lo tiene prohibido). Pero me pongo en el peor de los casos: Después de cierto tiempo de uso, las baterías han perdido capacidad y ya no sirven. El usuario no tiene otro pack de baterías en ese momento. Las retira del dispositivo y pretende trabajar solamente con el alimentador de 12V. No funciona y se oye dentro un ruido, como una especie de rateo... el relé rateando, claro, porque el operacional tiene una referencia en la entrada inversora pero la entrada no inversora tiene una "antena" al aire (el terminal de la resistencia de 15K). Llamada a servicio técnico y... este aparato que me han vendido no sirve para nada y bla, bla, bla... Mal asunto porque cualquiera le explica a ese señor cual es el motivo y que no tenía que haber retirado el pack de baterías. Claro que se puede poner en el manual de instrucciones "Atención, nunca trabajar con el dispositivo sin conectar el pack de baterías", pero me parece poco elegante.

Creo que cuando se hace un diseño que no es para uno mismo, hay que cubrir todas las posibilidades y ponerse en la piel del usuario final que, como no tiene ni idea de lo que maneja, puede complicar bastante las cosas.

El 317 se calienta, pero se puede tocar con el dedo. Pero claro, ahora lo estoy probando en contacto directo con el aire ambiente. Una vez encerrado en un compartimento de 7,5 x 5 x 2 cm con solo unos pocos orificios laterales, el calor se irá acumulando. Debo prever eso.

¿Cuántas placas quiero hacer? Eso dependerá de si el aparato (si algún dia consigo que funcione con la precisión que necesito) tiene el suficiente éxito. Yo de momento, cuando tenga el diseño listo, encargaré 10 placas a China y las montaré. Si se vende bien, iré por 50 más. Pero todo son conjeturas. Quizás no vendamos ninguno... quien sabe. En cualquier caso, la idea es hacer un circuito con valores fijos, sin ajustes, y que sea fácil y rápido de montar y fiable. Es decir, hacerlo de tal manera que las tolerancias de los componentes no hagan que se pierda precisión en ninguna unidad.
 
Hola Emilio,

Creo que no me estás entendiendo... No uso ningún transformador de 3 A. Tengo una fuente de laboratorio (entre otras) de 3 A, regulable entre 0 y 30 Voltios y con posibilidad de limitación de corriente. Esta es la fuente que utilizo para hacer las pruebas y, si lo mencioné, fue para recalcar que iba más que sobrado de corriente y que el problema no era que se me "amorrase" la tensión al consumir bastante.

¿Por qué sacar las baterías? Verás, yo no sé lo que va a hacer un usuario con ese aparato que vamos a intentar construir (disculpad que por el momento no lo desvele, pero mi socio me lo tiene prohibido). Pero me pongo en el peor de los casos: Después de cierto tiempo de uso, las baterías han perdido capacidad y ya no sirven. El usuario no tiene otro pack de baterías en ese momento. Las retira del dispositivo y pretende trabajar solamente con el alimentador de 12V. No funciona y se oye dentro un ruido, como una especie de rateo... el relé rateando, claro, porque el operacional tiene una referencia en la entrada inversora pero la entrada no inversora tiene una "antena" al aire (el terminal de la resistencia de 15K). Llamada a servicio técnico y... este aparato que me han vendido no sirve para nada y bla, bla, bla... Mal asunto porque cualquiera le explica a ese señor cual es el motivo y que no tenía que haber retirado el pack de baterías. Claro que se puede poner en el manual de instrucciones "Atención, nunca trabajar con el dispositivo sin conectar el pack de baterías", pero me parece poco elegante.

Creo que cuando se hace un diseño que no es para uno mismo, hay que cubrir todas las posibilidades y ponerse en la piel del usuario final que, como no tiene ni idea de lo que maneja, puede complicar bastante las cosas.

El 317 se calienta, pero se puede tocar con el dedo. Pero claro, ahora lo estoy probando en contacto directo con el aire ambiente. Una vez encerrado en un compartimento de 7,5 x 5 x 2 cm con solo unos pocos orificios laterales, el calor se irá acumulando. Debo prever eso.

¿Cuántas placas quiero hacer? Eso dependerá de si el aparato (si algún dia consigo que funcione con la precisión que necesito) tiene el suficiente éxito. Yo de momento, cuando tenga el diseño listo, encargaré 10 placas a China y las montaré. Si se vende bien, iré por 50 más. Pero todo son conjeturas. Quizás no vendamos ninguno... quien sabe. En cualquier caso, la idea es hacer un circuito con valores fijos, sin ajustes, y que sea fácil y rápido de montar y fiable. Es decir, hacerlo de tal manera que las tolerancias de los componentes no hagan que se pierda precisión en ninguna unidad.
Huy... yo aqui tomando desayuno.. un cafe y empana de pollo.. voy a acomodar mi humanidad.. leo tranquilo y en el almuerzo te respondo..
Esta cuarentena me tiene loco..
Siempre que hagas o pidas diseño... OBLIGATORIO entregar condiciones de borde.. si alguna vez tuviste un profesor. imagino sabes de eso..
 
Siempre que hagas o pidas diseño... OBLIGATORIO entregar condiciones de borde.. si alguna vez tuviste un profesor. imagino sabes de eso..

Tienes toda la razón. El problema es que normalmente no caes en esas cosas hasta que empiezas a probar un prototipo.

Yo, cuando monto algún sistema, tengo tendencia a probar todo lo malo que podría pasar ("putearlo" lo llamamos por aquí). Muchas cosas no tienen ninguna importancia, pero otras sí. Eso no lo descubres hasta que ya está montado y empiezas a trastearlo.
 
Tienes toda la razón. El problema es que normalmente no caes en esas cosas hasta que empiezas a probar un prototipo.

Yo, cuando monto algún sistema, tengo tendencia a probar todo lo malo que podría pasar ("putearlo" lo llamamos por aquí). Muchas cosas no tienen ninguna importancia, pero otras sí. Eso no lo descubres hasta que ya está montado y empiezas a trastearlo.
Ok.. para evitar ese zapateo en rele.. debes poner un potenciometro de 100k desde el max lo bajas hasta que deje de zapatear ... al final mides y pones una resistencia fija..luego mides el voltaje en el pin3 de el 741(porciacaso sin la bateria)
Luego que te funcione .. podemos optimizar salida rele

Scan0001 (1).jpg
 
Última edición:
Ok.. para evitar ese zapateo en rele.. debes poner un potenciometro de 100k desde el max lo bajas hasta que deje de zapatear ... al final mides y pones una resistencia fija..luego mides el voltaje en el pin3 de el 741(porciacaso sin la bateria)
Luego que te funcione .. podemos optimizar salida rele

Genial! He seguido tus indicaciones y después de ajustar el potenciómetro al punto correcto, con una resistencia de 22K a positivo, el relé ha dejado de ratear (o zapatear). La tensión en el pin 3 del 741 se queda en 2,19V ligeramente por encima de la referencia (2,140 V) y, en principio, no da problemas. No sé si será demasiado justo y habría que separar un poco esas dos tensiones.

También he optimizado el circuito externo. De hecho, el consumo máximo se da cuando se pone en marcha una resistencia calefactora que consume unos 800 mA. Lo que he hecho ha sido dividirla en dos resistencias (es hilo de NiCrom y simplemente lo he cortado). He pasado las resistencias por otro relé de forma que cuando la tensión es de 6V, ambas están en paralelo y cuando la tensión sube a 12 V conmuta el relé y las pone en serie. De esta manera consigo el mismo efecto de calentamiento con ambas tensiones y un consumo exactamente igual en los dos casos.

Empiezo a ver la luz al final del túnel (en buena parte gracias a ti) y ahora -aparte de comprobar todo el conjunto en todas las condiciones posibles, "putearlo" al máximo, etc.- tengo que ajustar correctamente los puntos de desconexión y conexión del cargador de baterías. Como comenté, funciona bien pero esos puntos están desplazados, de forma que solo me carga baterías cuando están por debajo de 5,7V y desconecta a 6,9V. De esta forma nunca llegaré a cargarlas por completo. Debo desplazarlo hacia arriba y no consigo hacerlo. Matemáticamente me queda muy bonito, pero en la práctica, con componentes normalizados, no encuentro la solución. Si no hay otra posibilidad habrá que poner un potenciómetro, pero si lo puedo evitar -aunque pierda más tiempo en el diseño- ganaré bastante tiempo a la hora del montaje, sobre todo si conseguimos fabricar bastantes unidades.

En fin... soy consciente de que estoy abusando de tu amabilidad y de tus conocimientos, pero si me puedes ayudar un poco con eso te quedaré eternamente agradecido. Yo... lo seguiré intentando.

Saludos!
 
No sé si será demasiado justo y habría que separar un poco esas dos tensiones.
Si.. separarlo un poco mas 2.3v luego varia el voltaje de la fuente desde 6v hasta 12v... y busca el zapateo.. con eso pones condiciones de borde
Mensaje automáticamente combinado:

También he optimizado el circuito externo. De hecho, el consumo máximo se da cuando se pone en marcha una resistencia calefactora que consume unos 800 mA. Lo que he hecho ha sido dividirla en dos resistencias (es hilo de NiCrom y simplemente lo he cortado). He pasado las resistencias por otro relé de forma que cuando la tensión es de 6V, ambas están en paralelo y cuando la tensión sube a 12 V conmuta el relé y las pone en serie. De esta manera consigo el mismo efecto de calentamiento con ambas tensiones y un consumo exactamente igual en los dos casos.
Aqui no te entiendo nada....
Por favor dile las personas que no hagan esto. referirse a algo que ellos tienen al frente.. hablan muy fácil.. pero a la persona qie esta al otro lado del mundo no pueden ver de lo que tu estas hablando... lo correcto es.. si te vas a referir alguna resistencia indica a que resistencia te refieress.. ejemplo...R1 lo que debes indicarlo en el plano...
Mensaje automáticamente combinado:

De esta forma nunca llegaré a cargarlas por completo.
Estas seguro??? si me dices que desconecta a 6.9v.. ese voltaje signidica qie esta cargada... plop...
Mensaje automáticamente combinado:

Si no hay otra posibilidad habrá que poner un potenciómetro,
No entiendo.. para que?

Lo otro que queria comentarte.. no es necesario poner ese enorme transistor bd138... aqui modificacion..
agrega un condensador en el zener 100uf 16v
Lo pruebas y me comentas
Ingresa 9v y 12v mides voltaje pin 2 y 3
Scan0001 (1).jpg
 
Última edición:
Buenas tardes. Lamentablemente, estos días no me quedan ni 10 minutos para dedicar al proyecto. Mi hijo está de mudanza y tengo que ayudarle a llevar cosas y a instalarlo todo. Entre eso y el trabajo que me da de comer...

Hoy he conseguido un par de horas y he montado el circuito tal como lo planteaste (omitiendo de momento el cargador). En estas condiciones funciona perfectamente. He añadido una resistencia de 2K2 en serie con la de 22K y he eliminado nuevamente el zapateo del relé.

Por otro lado, la referencia del zener se mantiene estable en 2,33 V a 12 V de alimentación, en 2,22 V a 9 V de alimentación y en 2,06 a 6 V de alimentación.

En cuanto disponga de otro momento, añadiré el 317 y veré como se comporta el conjunto.

Las pruebas las estoy haciendo con una fuente de 12 V para alimentar el circuito y con otra de tensión ajustable para simular la carga de baterías. Conecto positivo al punto donde conecta el positivo de las baterías y uno las masas de ambas fuentes. La desconexión se produce a 7,04 V de baterías y la reconexión a 6,04 V (genial).

Tengo algunas dudas, porque recuerdo que con el anterior montaje, la tensión de baterías (conectadas al cargador), podía subir a más de 7,4 V. Por ese motivo te comentaba que no estaba muy convencido de que las baterías estuviesen a plena carga a 6,9 V.

De nuevo muchas gracias y seguiré informando en cuanto tenga más datos.

Saludos!
 
Buenas tardes. Lamentablemente, estos días no me quedan ni 10 minutos para dedicar al proyecto. Mi hijo está de mudanza y tengo que ayudarle a llevar cosas y a instalarlo todo. Entre eso y el trabajo que me da de comer...

Hoy he conseguido un par de horas y he montado el circuito tal como lo planteaste (omitiendo de momento el cargador). En estas condiciones funciona perfectamente. He añadido una resistencia de 2K2 en serie con la de 22K y he eliminado nuevamente el zapateo del relé.

Por otro lado, la referencia del zener se mantiene estable en 2,33 V a 12 V de alimentación, en 2,22 V a 9 V de alimentación y en 2,06 a 6 V de alimentación.

En cuanto disponga de otro momento, añadiré el 317 y veré como se comporta el conjunto.

Las pruebas las estoy haciendo con una fuente de 12 V para alimentar el circuito y con otra de tensión ajustable para simular la carga de baterías. Conecto positivo al punto donde conecta el positivo de las baterías y uno las masas de ambas fuentes. La desconexión se produce a 7,04 V de baterías y la reconexión a 6,04 V (genial).

Tengo algunas dudas, porque recuerdo que con el anterior montaje, la tensión de baterías (conectadas al cargador), podía subir a más de 7,4 V. Por ese motivo te comentaba que no estaba muy convencido de que las baterías estuviesen a plena carga a 6,9 V.

De nuevo muchas gracias y seguiré informando en cuanto tenga más datos.

Saludos!
Yo hago diseño de todo tipo de circuitos...proyectos.. etc... hago el circuito.. hacer todo tipo de pruebas.. y me pongo feliz cuando falla... ya que me da la opción de aprender algo mas..debo recalcular e investigar mas..
Pero... reparar es lo mas fácil del mundo sacar un condensador inflado... comprar en la esquina uno nuevo y todos felices..
Mira el circuito ya realizado y compara con lo que te empezastes.....
 
Arriba