Compuertas logicas. ¿Como son en la practica?

#1
Buenas, me dirijo a estudes para consultar una gran duda para un proyecto en la universidad.

El problema es que, teoricamente, en la compuerta AND en el C I 7408 en la pata 14 se conecta el voltaje de entrada y 7 se conecta la tierra. al conectar un led en la pata 11 este se enciende (sin haber conectado ninguna otra pata) conecto la pata 13 y 12 a el voltaje de entrada y no sucede nada! haga las conexiones que haga el led sigue encendido.

Ayudenme por favor, no entiendo muy bien lo que sucede en la practica.
 

Fogonazo

Exorcista & Moderador eventual
#2
Buenas, me dirijo a estudes para consultar una gran duda para un proyecto en la universidad.

El problema es que, teoricamente, en la compuerta AND en el C I 7408 en la pata 14 se conecta el voltaje de entrada y 7 se conecta la tierra. al conectar un led en la pata 11 este se enciende (sin haber conectado ninguna otra pata) conecto la pata 13 y 12 a el voltaje de entrada y no sucede nada! haga las conexiones que haga el led sigue encendido.

Ayudenme por favor, no entiendo muy bien lo que sucede en la practica.
¿ Y que opinas si publicas un circuito de lo que estas haciendo ?
 
#3
Oks. este seria el esquema, solo que el la pata C3 conecto la pata positiva de un led que luego lo llevo a tierra. A3 y B3 son los que deberia de manipular con diversas convinaciones para que el led encendiera, pero dejandolas con cualquiera convinacion sea 0 0 ; 0 1 ; 1 0 ; 1 1 ; el led sigue encendido. no se lo que sucede.

 

Dano

Moderador
#4
Oks. este seria el esquema, solo que el la pata C3 conecto la pata positiva de un led que luego lo llevo a tierra. A3 y B3 son los que deberia de manipular con diversas convinaciones para que el led encendiera, pero dejandolas con cualquiera convinacion sea 0 0 ; 0 1 ; 1 0 ; 1 1 ; el led sigue encendido. no se lo que sucede.

http://packajus.files.wordpress.com/2010/05/330px-ttl_inside_7408-svg.png
Estas usando la resistencia correspondiente en serie con el led?
 

sp_27

KittyModerator
#6
El 7408 es un TTL, si no conectas nada en las entradas el circuito lo toma como si tuvieran un 1 lógico, si lo conectas al voltaje de entrada obviamente el led seguirá encendido.

Ahora lo de que hagas las combinaciones y el led siempre esté encendido pueden ser 2 razones: el componente está dañado o no estás haciendo las combinaciones de la forma correcta, si lo haces desconectando de la fuente no hay cambio.

Lo que debes hacer es conectar las entradas al voltaje de entrada cada una mediante un interruptor, y en el punto medio colocar una resistencia a tierra, de modo que al abrir el interruptor cada una de las entradas tenga un camino a tierra a través de la resistencia, te recomiendo usar valores bajos como (330 Ω). Si no quieres usar varios interruptores puedes usar un dip switch que trae varios interruptores juntos y ocupa poco espacio.

Nota: los TTL usan 5 voltios, según recuerdo funcionan bien desde 4,5 hasta 5,5 V, de resto pueden quemarse o dar errores, verifica en el datasheet

http://www.datasheetcatalog.net/es/datasheets_pdf/7/4/0/8/7408.shtml



Dip Switch
 
Última edición:
#8
Sp_27 muchas por tu respuesta, fue la que soluciono todo. También muchas gracias a los demás por ayudarme. Ese era mi error, no lo conectaba a tierra con la pequeña resistencia., porque no sabía esa parte de ese componente. Ya la compuertas lógicas funcional como es de esperarse. El problema esta solucionado. Muchas gracias.
 
Arriba