Conexion del Amplificador Operacional LM358N

#1
Hola, mi duda es muy simple y seguramente será alguna tonteria, pero no hay manera de resolver el problema. Os explico:

Estoy haciendo un circuito simple con un AO LM358, simplemente deseo alimentar una señal digital que sale de un PLC de valor 5 V hasta 10 V, es decir, una ganancia 2. Segun el datasheet del amplificador, ha de alimentarse a 32 V, y asi lo he hecho con una fuente de CC. Adjunto una foto del circuito dibujado a mano. Las resistencias han de ser iguales para obtenes G=2, asi que he puesto dos de 10kΩ.

Mi duda mas que nada recae sobre las diferentes conexiones a tirra ya que despues de llevar mucho rato probando creo que puede estar ahi el fallo. Como conexiones a tierra tengo la de la fueste y la referencia a cero del PLC.

A cual he de conectar la tierra de R1? y con que referencia obtendre Vo igual al doble de Ventrada?

Gracias de antemano por las respuestas.
 

Adjuntos

Última edición por un moderador:
#2
Tres cosas:

1- ¿Cuál es la alimentación?
2- ¿Cómo es la ganancia de esa configuración?
3- ¿No convendría usar transistores para un cambio de nivel?
 

DOSMETROS

Insipient Constructor
#3
Eso es un amplificador no inversor de ganancia 2 , OK (la pregunta es porqué dibujás al revés de la "norma" conocida)




Podés poner un diagrama completo de todo , incluyendo fuentes de alimentación ! ?
 

DOSMETROS

Insipient Constructor
#5
Si sabe la ganancia = 1+(R1/R2) es porque algo estuvo leyendo , y justamente como dibuja atravesado pensé que era un amplificador inversor y que ahí estaría el problema ! ;)
 
#6
Todas las masas deben estar unidas. No se que problema encuentras. ¿ La entrada positiva tiene alguna resistencia a masa proveniente del PLC? No lo indicas. Además. que voltaje sale del integrado cuando le entra 5 V? No lo dices.
 
#7
Bueno, veamos.

Lo primero, algo del tema se, soy ingeniero eléctrico y en la universidad ya he trabajado con estos amplificadores, aunque un experto no soy porque lo que he estudiado no es electrónica. Lo de dibujarlo al revés que la norma... Solo he de decir, a mi me lo enseñaron asi.

La conexión es la de un amplicador no inversor y la teoría me la se. El problema es que si mido con el multimetro la tensión entre el negativo de la fuente de alimentación (masa) y la tierra de referencia del PLC obtengo una diferencia de tensión de 10V.

El famoso cortocircuito vistual no aparece en nmi caso, ya que midiendo la tensión ente la entrada + y la - del AO abtengo los 5V de entrada y no cero como debería ocurrir.

Al poner todas las masas coincidentes obtengo a la salida del AO una tensión de 17V sea cual sea la entrada del amplificador, es decir, si pongo activa la salida del PLC y al AO llegan 5V tengo 17V a la salida, si dejo la salida del PLC inactiva y al AO llegan 0V a la salida tengo tmb 17V.

Si, se que son cosas muy raras y que casi no se pueden explicar, pero si alguno sabe algo le agradecería su ayuda, sino seguiré haciendo mil y una puebas hasta que salga, que tampoco tiene que ser tan dificil... jajaja
 
#8
Seguimos sin saber la fuente con la que alimentás el operacional (pero mayor a 17v parece ser).

El circuito que planteás es correcto, solo si:

- GND del PLC es el mismo GND que la fuente de alimentación que usará amplificador.

- La alimentación es la adecuada.

- Los valores de R1 y R2 tienen las magnitudes correctas, no basta solo con que sean iguales.

- R1 debe ir por un lado a la masa de la alimentación y por el otro al terminal (-) del amplificador.

- La carga a la salida del amplificador es la adecuada según la corriente máxima que pueda suministrar el amplificador.

De nuevo, tal vez resulte más sencillo hacer un cambio de nivel usando transistores.
 
#9
Muchas gracias por todo, el problema se ha resuelto.

Lo único que debia hacer es unir electricamente todas las masas, ahora ya funciona correctamente.
 

Temas similares


Arriba