Contador fotoelectrico 0-9

#1
Hola!

Necesito hacer un contador 0-9 de personas.

Monte el circuito del contador que se encuentra en proyectos practicos (https://www.forosdeelectronica.com/proyectos/contador-fotoelectrico.htm) lo hice con un solo display y reemplaze la fotocelda por un fototransistor, el problema es que al conectar todo el display no me da numeros, solo se prenden partes y cuando le mando el pulso no obtengo ninguna respuesta.

Espero me puedan ayudar.
Muchas gracias de antemano.
 
#2
pone alguna foto de como lo tenes montado en este momento,

si lo armas en protoboard, etc...

y adjunta los circuitos (esquemas) de lo que estas usando!
 
#3
Lo primero que debes verificar es si realmente el fotoresistor está "viendo" algo. Para ello mides tensión en la salida del inversor schmitt-triger o lo que hayas puesto como conformador de onda. Debería cambiar de 0 Volt a 5 Volt cuando "se atraviesa la persona". Si no cambia....... uno de los problemas está ahí. Si cambia, debes chequear el contador, que esté habilitado, que no esté reset......
Que el display te muestra cualquier cosa puede probablemente sea que lo has conectado como el orto. También es fácil de diagnosticar, mides con el tester qué valor binario hay en la entradas A, B, C, D ó I0, I1, I2, I3 ó como se llamen y te fijas si están activadas las salidas correspondientes. Otro posible problema es que tengas display de 7 segmentos ánodo común cuando en su lugar debería ser cátado común.
Cómo te menciona ALEXUS, sin los esquemáticos no es fácil darte una mano.

Saludos,
Hernán
 
#11
Lo primero que puedo observarte es que tienes conectado el display al Dígito más significativo (las centenas; pin 15). Conectado así el dígito se incrementa en 1 cada 100 clock. Deberías conectar el transistor al pin 2 del MC14553.
http://www.datasheetcatalog.org/datasheet/motorola/MC14553B.pdf

Imagino que C1 lo has puesto como dice la hoja de datos, 0.001 microF

El pin 10 del MC14553 debería estar a masa. Un resistencia a masa vendría bien, una vez que funcione se la quitas para ver si hace falta o no. Creo que no hace falta pero...... por si las moscas

IMPORTANTISIMO !!! El tranistor está alrevés. El emisor se conecta a VDD (+9V) y el colector al display. El display debe ser ánodo común.

Podés probar el CD4543 de la siguiente manera:
Desconectas R14 del MC14553 y la conectas directo a +9V. Con ello consigues que el display esté siempre energizado a travez del transistor.
Luego desconectas los cuatro cables del dígito binario (MC14553 pines 9;7;6;5 --- CD4543 pines 5;3;2;4)
Luego, con cuatro cables conectados al CD4543 a los pines 5;3;2;4 le metes combinacioes binarias y chqueas que el display junto con el decodificador BCD-7 Segmentos funcione correctamente.
Si no funciona.... estás en el horno. Está fregado el CD4543.... o el transistor. Para chequear si es el transistor, le haces un puente en colector y emisor, si empieza a funcionar el display es porque el transistor está pa atrás o la R14 es muy grande. Reemplaza.

Si estás seguro que el conformador de onda está funcionando, el resto debería funcionar, luego de corregir lo de transistor y conectar R14 al pin 2.

Si con todo ésto no funciona, avisa y vemos cómo probar el contador. Hay que saarle el capacitor, poner un pulsador y..... si hace falta lo vemos.

Suerte,
Hernán
 

Adjuntos

#13
busca la hoja de datos del 4510 y del 4511, es mucho mas sencillo, el clock del contador lo manejas saturando y cortando un transistor con el LDR...

vos ves, me aprece que es mas sencillo con esos integrados!
 
#17
Ya lo tengo todo conectado, la fotocelda con el transistor al clock del 4510, el display me muestra el numero cero pero al interumpir la fotocelda no pasa nada, el numero no cambia.
 
#18
trata de exitar dos transistores, con el ldr comandas uno, y de el emisor de ese uno comandas otro, no falla, porque no he probado, de ultima proba con los fototransistores de esos genericos...
 
#19
Podés verificar que el circuito del contador esté funcionando desconectando el clock del circuito barrera y generando pulso con un pulsador, así te sacás la duda si el conador está funcionando.
Del mismo modo probás el circuito de la barrera, desconectándolo del contador y midiendo con el multímetro tensión a la salida del Schmit-trigger y viendo que cambie cuando le hacés sombra al fototransistor. A partir de ahí vemos dónde está el problema.
 
#20
El 4510 no responde a los pulsos, lo raro es que lo cambio por otro 4510 y tampoco responde.

Otra cosa es que, no se si sea normal, desconecte del 4510 los cables que van al 4511(pines 6, 11, 14, 2), al mover esos cables que seguian conectados al 4511 el display hiba cambiando de numero aleatoriamente.
 

Temas similares

Arriba