Control Motor Unipolar con L297

#1
Un saludo:

Estoy desarrollando un control para motor unipolar y estoy usando el integrado l297.

El problema es que no he podido hacer que se mueva correctamenta los motores, es decir hacen un movimento erratico como hacia dalente y hacia atras y sin nada de torque.

Tengo un motor de 2,4 A por fase alimentado a 12v unipolar, la parte de control esta implementada por 4 mosfet IRFz44n.

Segun el data sheet la secuencia del motor esta dada por (CORRESPONDINTE A MEDIO PASO):

ABCD
0101
0001
1001
1000
1010
0010
0110
0100

Para poder trabajar entonces uso la siguiente secuencia:

BDAC
1100
0100
0110
0010
0011
0001
1001
1000

El pin de control (pin 11) lo tengo en estado alto por que no estoy usando INH1 y INH2, ya que el chopeo se hace por ABCD. ¿estoy en lo correcto?

Pero sigo sin entender por que no se mueve correcto.

La señal de reloj la genero por medio de labview y todo el control, no se si esto tega que ver algo.

Gracias pòr la ayuda.
 
#2
Hola Gustavo84, en mi web tengo publicado un driver unipolar justamente con el L297 y mofet, yo use los IRL por ser adecuados para conmutar con lógica (5v):

http://www.esteca55.com.ar/proye-dvu4a.html

Ahí encontraras el esquemático además del proyecto completo lo cual te puede ser útil para sacarte las dudas que tengas.

Saludos
 
#3
Saludo:

INH1 y INH2 son las que me habilitan las salidas de la compuerta para ABCD, es decir que:

INH1 habilita a A y B
INH2 habilita a C y D

esto siempre tiene que ser asi o depende de la secuencia que use el motor por decir en mi caso tengo que habilitar con INH1 a B y D y con INH2 a C y A.

Otra cosa el pin 11 que es el de control de corriente se tiene en bajo ¿por que el control de corriente lo hace INH1 y INH2? . ¿lo podria poner en alto y ahorrarme la compuerta? para que el control se haga por ABCD.
 
#4
Hola,

No necesariamente INH1 habilita a A y B y INH2 habilita a C y D, sino que INH1 debe habilitar al grupo que esta conectado a la resistencia Shunt que censa la corriente y manda un valor analógico a pin SENS1 del L297 y INH2 debe habilitar al grupo que esta esta energizada a travez de la otra resistencia shunt y proporciona el valor analógico para el control de corriente al pin SENS2.

Te recomiendo que leas la hoja de datos del L297, ahi eta todo explicado.

Saludos
 
#5
Buenas tambien estoy armado un circuito para motor unipolar pero no encuentro el integrado L297 sera que alguien sabe el numero de otro integrado que sea el mismo o sera que me pueden decir el numero ECG ya que no lo consigo en el ECG ni en el NTE de internet
 
#6
Ahora yo hago una pregunta: por que estoy confundido con el tema de los INH1 y INH2si yo dejo el pin de CONTROL a 1 y se supone que se aplica el PWM sobre las fases..al no usar INH1 y 2 estoy mejorando la evolución ascendente de la corriente pero cuando se desenergizan la descarga de la bobina sigue = (por disipacion en la misma r de fase) que antes por lo cual estaria en la misma : mejoro la subida pero no la bajada de la cte,¿esto es asi no?, y gustavo yo me lie con el mismo problema que vos y cambie la secuencia como lo hicestes vos ya que como el driver es bipolar arranca con 0101 asi que hube de acomodarlo y con el mismo resultado pense que andaba conectando mal los cables pero estoy seguro que no es eso q vos se mueve erratico ademas de que no es lo mas eficiente por que deberiamos poder usar paso completo para sacar el maximo torque y en este modo no funcionan los INH
 
#8
buenas tardes, soy de venezuela, he estado buscando en internet y los diseños para control cnc y todos implican integrados como l297, l298, 74hc244n, los cuales no he podido conseguir, hay algun equivalente, no soy tan diestro en electronica...
espero puedan ayudarme...
 
#11
Hola Gustavo84, en mi web tengo publicado un driver unipolar justamente con el L297 y mofet, yo use los IRL por ser adecuados para conmutar con lógica (5v):

http://www.esteca55.com.ar/proye-dvu4a.html

Ahí encontraras el esquemático además del proyecto completo lo cual te puede ser útil para sacarte las dudas que tengas.

Saludos
hola tengo un problema con respecto al driver de 2 amperios bipolar .
resulta q tengo la interfaz y los driver pero el problema es que tengo motores unipolares de 6 cables y segun he leido tambien puede usarse estos motores como bipolares.
cuando conecte el motor al driver estaba q mandaba pulsos pero el motor no giraba( solo vibrada con cada pulso ) pero solo funciono por un rato nada mas y ahora ya no funciona el motor. Mi duda es si los terminales del motor que yo tengo osea el A B C D son iguales a A+ A- B+ B- respectivamente.
 
#13
Hola a todos esta muy bueno este foro.. Acabo de construir mi driver unipolar de 35V 4A de Esteca y el problema que tengo es que no logro que gire rapido, lo estoy alimentando a 38 V y 400mA porque es la unica fuente que tengo cercano a 35 V, uso un motor de 6 cables de 5 V 350mA, lo estoy controlando con arduino, es decir las entradas de clock, enable, y demas.. este motor solo es para hacer las pruebas luego pienso conectar un motor mas grande y con mayor torque.. Los mosfet que utilizo son los NEC 2723 de 60V 13A son los que pude conseguir, el motor hace una vuelta en 2.4 seg aproximadamente y es lo mas rapido que puede girar, auque aumento la frecuecia en la entrada del clock sigue girando a la misma velocidad, si a alguien le a pasado algo similar les agradeceria que me den una mano...
 
#14
hola que tal a todos. Esteban quisiera saber como configurar las secuencias de los pasos en momento de inicio para que sea par (2,4,6,8) yo estoy colocando en un bajo el pin half/full pero cuando se enciende la primera secuencia es 0101 y sucesivamente (1,3,5,7). que debo hacer? le estoy mandando los pulsos con un microcontrolador 16f877
 
#15
Hola he armado tu pcb de driver de 4amp para cnc pero no me funciona el motor se queda parado y no se llega a mover para ningun lado el voltaje a los motores es de 24 vol el zener es del 24
Ya he caMbiado 3 unidades del l297 pensando qUE estaban mal pero igual tengo el mismo problema

Espero que me pUEdas guiar para su funcionamiento
Gracias
 
Última edición por un moderador:
#16
Hola.

Tengo un-problema con un diseño con el l297
Tengo salida de datos en ABCD Y INH1 Y INH2 no hay salida y el pin 11(control esta en 0 )
¿ Alguna idea de porque sucede ?
He colocado el motor pap y no funciona he colocado leds para ver la salida y no hay respuesta hice prueBas con osciloscopio y note donde hay salidas y donde no.
 
Última edición por un moderador:

Fogonazo

Exorcista & Moderador eventual
#17
Hola.

Tengo un-problema con un diseño con el l297
Tengo salida de datos en ABCD Y INH1 Y INH2 no hay salida y el pin 11(control esta en 0 )
¿ Alguna idea de porque sucede ?
He colocado el motor pap y no funciona he colocado leds para ver la salida y no hay respuesta hice prueBas con osciloscopio y note donde hay salidas y donde no.
¿ Circuito ?

Reglas generales de uso del foro

03) Cuando preguntes, danos la máxima información posible. ¡ No somos adivinos !

05) Escribe de manera correcta y legible para todos. Estás en un Foro no en un Chat. Esto incluye emplear signos de puntuación e interrogación, (Por ejemplo "Punto y Aparte, signos de interrogación, Etc"), comenzar un renglón nuevo con mayúscula, Etc. No nos gusta la escritura "En Bloque"
 

Temas similares

Arriba