Diseño de conmutador a base de mosfet y optoacoplador - Ruido en la carga

Igual, no tomes en cuenta el IR, ya que me parece que lo que pretendes, no tiene relacion alguna.
Ademas que necesita de un voltaje superior a los escasos 1.6V que pretendes.
 
Igual, no tomes en cuenta el IR, ya que me parece que lo que pretendes, no tiene relacion alguna.
Ademas que necesita de un voltaje superior a los escasos 1.6V que pretendes.
Creare un nuevo tema de foro, con todo lo que me han planteado y los arreglos que hice, muchas gracias a todos por sus respuestas. Dios los Bendiga mucho!
 
No, no crees un tema, si ya hay uno hablando de lo mismo (estan en las reglas).
Mejor coloca todo en el mismo lugar, y lo mas detallado
 
No, no crees un tema, si ya hay uno hablando de lo mismo (estan en las reglas).
Mejor coloca todo en el mismo lugar, y lo mas detallado
Vale entonces ahora lo colocó acá.
Así me quedo con todo lo que me han propuesto, aparentemente lo está realizando perfecto en lo simulado, le puse un ciclo de trabajo de 50% y a 1 hertz pero para poder apreciar lo que se ve cuando esta encendido, pero realmente es con un ciclo de trabajo de 10% y 10Hz. Creen que sea necesario utilizar un driver? Si en dicho ca so el ruido que me esta dando es por las capacitancias parasitas de los mosfet, como podría afrontar este problema? Había leído sobre el driver push pull pero aun no lo tengo claro como debería aplicarlo.

Lo acabo de montar en protoboard, y miren ahora esta muchísimo mejor gracias a sus comentarios.
Esta es la salida del optoacoplador 4n25:
nuevo11.png
Y esta es la salida en la carga del mosfet, ya no tiene ruido, sin embargo noe sta en el tiempo de trabajo ni la frecuencia, paso de ser 10 Hz a 60 Hz, y de un ciclo de trabajo de 10% a 60% que luego bajoa un 30%.
nuevo 22.png
Acá se ve con mas detalle:
nuevo 33.png
, yo creo que se debe a los tiempos de carga y descarga de los capacitores internos del mosfet, en dicho caso, como puedo mejorar ese problema?
 

Adjuntos

  • sdffsfd.PNG
    sdffsfd.PNG
    144.3 KB · Visitas: 7
Última edición:

shevchenko

Well-known-Ruso
Bajando la Resistencia de base, siempre que lo que maneje el Mosfet pueda manejar "mas corriente", ahora la frecuencia y ciclo se maneja desde otra parte, con la R de Gate solo vas a tener menos/mas Rampa.
 
Lo acabo de montar en protoboard, y miren ahora esta muchísimo mejor gracias a sus comentarios.
Esta es la salida del optoacoplador 4n25:
Ver el archivo adjunto 272144
Y esta es la salida en la carga del mosfet, ya no tiene ruido, sin embargo noe sta en el tiempo de trabajo ni la frecuencia, paso de ser 10 Hz a 60 Hz, y de un ciclo de trabajo de 10% a 60% que luego bajoa un 30%.
Ver el archivo adjunto 272145
Acá se ve con mas detalle:
Ver el archivo adjunto 272146
, yo creo que se debe a los tiempos de carga y descarga de los capacitores internos del mosfet, en dicho caso, como puedo mejorar ese problema?
Las cosas funcionan mejor, cuando se atiende a la teoría, harto practicada en todo el mundo académico.
Algunos foristas por ahí, le responden con alguna ironía porque, a mi entender, sienten que usted, por momentos, hace caso omiso, o pasa por alto, algunos aspecto importantes de la necesaria e indispensable teoría y experiencia. Eso es todo.
Me alegro que ahora se haya usted encaminado hacia su objetivo :rolleyes: :unsure: ;)
 
Vale entiendo, lo que pasa es que para lo que se tiene planeado como carga son 2 plaquetas de metal o aluminio que a su vez energizan una botella de agua con sal

ese circuito, es este mismo?
Ver el archivo adjunto 272140
Si ese circuito es el mismo. La idea es que cuando enciendas el dispositivo este quede clavado a Vdrv y cuando abras el dispositivo este quede clavado a Vss (o la tension de source).

Esto explica porque la carga debe colocarse en el drenador. El MOSFET mira su tensión en la gate o puerta respecto a la source o fuente. Por tanto la masa del Driver en el caso que tienes hay (GND) esta directamente referida a la source. En tu esquema anterior la carga al estar entre source y la masa del driver hace que cuando cierres el mosfet la caida de tension entre el gate y el source no sea exactamente la que quieres, (aunque la carga al ser tan pequeña apenas cogera tension y permitira cerrar el mosfet pero sigue sin ser recomendable). Por otro lado al no tener el PNP no estas forzando la tension de puerta a 0V, por tanto queda en abierto, no recuerdo ahora el valor de resistencia GS que tenias en paralelo pero debe ser alto lo cual se puede asemejar a un circuito abierto ya que no circula apenas corriente por la misma y por tanto la carga de la puerta no se disipa del todo correctamente. Por eso tienes como una senoidal cuando abres.

Tambien un poco por lo que he leido arriba tienes que entender que el MOSFET trabaja con potencia y el driver (eso que llama Bipolar Totem-Pole) es un circuito de adaptacion de la señal PWM que envia el micro para que el MOSFET se cierre o abra correctamente.

Y recuerda, el driver siempre referido a la SOURCE del MOSFET. (Hay otros dispositivos que no siempre usan este esquema pero te es indiferente para tu aplicación).

Una ultima recomendacion, si a pesar de cambiar bien el driver te sigue dando problemas de picos o ruidos por tensión (sobretodo cuando abres con carga y/o cierras con carga) mira circuitos de snubber. A mi alguno me ha salvado alguna vez.


EDIT:
Me habia saltado la pagina 3 no la vi igual mis comentarios quedaron un poco desfasdos. Por lo que vi en tus imagenes, esa rampa depende de la resistencia de puerta (Rgate), si reduces dicho valor (rollo 1 ohm) o del estilo la salida será mas rapida. Tambien te digo tienes un MOSFET (IRF1404) de 40V a 163A, vas sobradisimo para 10A pero mejor menor Rdon menos perdidas por conduccion. Con ese MOSFET la dv/dt (que es la pendiente de esa rampa que tienes ahi) puede llegar a 5 V/ns, en otras palabras cortar 5 V en 1 ns.

EDIT2:
Igual me vengo arriba pero bueno, te dejo esta pagina de MOUSER MOSFETs en la cual puedes encontrar MOSFETs discretos (y comprarlos pero bueno es ya up to you), con una serie de filtros que te puede servir para buscar dispositivos que encagen mejor con tu sistema. Tambien de Digi-key, RS y Farnell encuentras cosas del estilo.
 
Última edición:
Ahora si esta como se debe, si lo que buscas con el tema de las capacidades parasitas es que en vez de una cuadrada ves un trapecio, primero fijate si tu osciloscopio es capas de mostrar una cuadrada perfecta a esa frecuencia, si fuese un osciloscopio de tubo analogico te diría el que problema es tu circuito, pero con eso que estas usando, primero asegurate que tenga la velocidad suficiente como para mostrar una cuadrada a esa frecuencia, todo depende del dv/dt.
 
Amigos quiero cambiar este retraso que les puse arriba:
Si ven que está tardando en encender y apagar, donde debería ser una frecuencia de 10 Hz y un duty de 10%

nuevo 33.png

Así que decidí hacer este totem pole para mejorar esto según sus recomendaciones, pero como sabrán tengo problemas XD:
Captura.PNG
 
La frecuencia define la rapidez.
El % de ciclo activo , define la duración del ciclo activo, de ESE período en particular, mas no del ciclo pasivo, que en su caso lo termina definienfo la frecuencia. Vea el adjunto y trate de entender.
Si tarda en repetir el ciclo debe aumentar la frecuencia, es decir que ocurra a intervalos mas cortos, despues es cuestión de definir cuanto tiempo de ese periodo va a permanecer encendido solamente, el tiempo de apagado lo va a definir el circuito o la rutina de programación que controla la frecuencia. Eso va a hacer que vuelva a encender , pero el control de periodo activo, va a determinar cuanto permanecer activo y lo apagará.
 

Adjuntos

  • PWM3.jpg
    PWM3.jpg
    29.9 KB · Visitas: 5

shevchenko

Well-known-Ruso
algo más así
así
R load seria el Gate de tu mosfet
 

Adjuntos

  • Screenshot_20210928-234131.png
    Screenshot_20210928-234131.png
    376.9 KB · Visitas: 12
  • NE9Oe.gif
    NE9Oe.gif
    2 KB · Visitas: 36

Dr. Zoidberg

Well-known-Papá Pitufo
El problema de la velocidad de conmutación es por la presencia del optoacoplador. En mis épocas solía usar una resistencia de base del optotransistor a masa (algo de 33K si mal no recuerdo) para acelerar la evacuación de portadores y acelerar la conmutación. Hay que probar...
 
Tienes una resistencia de 22 (R3) Ohm en la gate, eso es una burrada para ese interruptor. Pon una de 2 Ohms a lo sumo. Ademas el Q4 parece que lo has puesto al revés ¿? El emisor parece que está abajo en vez de estar arriba, lo que te dicen en el comentario anterior. Haces un circuito de driver muy raro, porque además le metes otro transistor (Q2) con una resistencia de 22k que ademas reduce la velocidad, ¿Por que no usas directamente el optocoplador a la entrada de Q3 y Q4?
 
Gracias por responderme, en base a sus comentarios lo diseñe de la siguiente forma:
En este punto esta encendido, pero tiene un tiempo de descarga algo pronunciado, y la corriente no supera los 11 mA en la compuerta
29-09.PNG
 

Dr. Zoidberg

Well-known-Papá Pitufo
Mirá esta IMAGEN que te dieron hace rato !!!!!
ne9oe-gif.272220

No ves que tenés mal conectado el transistor de abajo???
Son seguidores de emisor complementarios y NO lo que vos has conectado.
 
De onda te lo digo, si estas cuestionando una respuesta del Dr. la cual es correcta ya que estaba mal lo que tenías, te vas a quedar sin ayuda de nadie y vas a seguir navegando solo en este mundo, o en este foro.
 
amigo, se supone el de abajo es un pnp, en proteus el pnp se simboliza así como lo puse :LOL:, bueno ya lo invertí el pnp y puse como en la foto, así?
Ver el archivo adjunto 272237
Se simboliza de esa manera, pero en Proteus también tiene la opción de ponerlo en espejo para conectarlo como corresponde.

Sino los conectas como deben, vas a seguir teniendo problemas en tus circuitos.
 
Arriba