Filtrado pico corriente al encender motor alterna

Muy buenas a todos.

Hace un par de años me compre una maquina de corte y grabado laser por aliexpress, la K40. Es una máquina que la gente se compra para iniciarse en el mundillo del laser y trastearla.

El tema es que rehice todo el cuadro de control. Lo saque fuera de la máquina y lo puse en un cuadro metálico aparte. Cambié la placa de control por una makerbase para darle mas funcionalidades a la maquina y hasta ahi todo correcto. Me conecto con el portatil a la placa por usb para enviarle los comandos g-code y asi mover el cabezal laser para que corte o grabe.

El problema vino cuando añadi un "compresor" (uno de pecera que lleva un electroiman que sopla mas bien que comprimir el aire) para soplar la llama y extinguirla.

Cuando arranco el compresor o lo paro de vez en cuando me corta la comunicación serie entre el portatil y la placa.

Empecé conectando el motor a tierra. La caja donde esta la electronica tmb esta a tierra, junto con la caja donde va la maquina. Tambien he puesto un filtro en la entrada de la fuente que alimenta la placa (uno de esos que viene con terminales faston y encapsulados en una cajita metalica). Y todo eso no lo hace desaparecer el problema pero si que lo va mitigando un poco.

Lo que queria preguntar es como puedo hacer para amortiguar el pico de corriente que se produce al encender y apagar el motor. Sino habria la otra opción de filtrar la señal que le lleva a la fuente de alimentación de la placa controladora, pero creo que es mas dificil de poder calcular los valores del filtro.

He conectado el osciloscopio a gnd de la placa controladora y a uno de los pines de datos del usb y se ve claramente como cuando enciendo y apago el motor aparece bastante ruido en la linea usb.

Pues eso es lo que me esta pasando y llevo muchos meses con esto atascado. La maquina la voy usando porque antes de conectar el usb enciendo el motor y asi no hay problema, pero me gustaria poder tenerlo bien hecho, sobretodo para poder aprender a como se hacen bien las cosas.

Muchas gracias

PD: Lo mas curioso de todo es que si uso un portatil mac no hay ningun problema, nunca salta la comunicacion. El cargador del portatil no es el original y este no lleva conexion a tierra. No se si es porque el conector USB filtra mejor la señal que le lleva, o porque la carcasa del portatil es de aluminio y hace una especie de jaula de farady (aunque no creo porque el el portatil no esta conectado a tierra)
 
El ruido electrico es un tema mas que complejo, hay infinidad de posibilidades y cosas por hacer, lo que se suele hacer es optar por todas, no es que una sea la solución, sino que la suma de todo lo que hagas es lo que da resultado, los arminicos que se generan en el ruido electrico tiene toda la gama de frecuencias posibles, por eso una sola opción no basta, en la industria he usado todo tipo de cosas, desde anillos de ferrite, hasta enmascarar con cinta de alumino autoadhesiva las cachas de los conectores que eran de plastico.
La puesta a tierra es fundamental, que todo, aun lo que no piene la espiga, esté a tierra.
El cortadora que tenemos en la empresa, usamos aire comprimido, o tubo de nitrogeno.
 
Yo empezaría por lo fácil y luego por lo difícil

Usa el PC con baterías
Cambia el cable USB por uno apantallado
Pon el compresor lo mas lejos posible.
Pon un calderín mas grand para evitar que el compresor se active a mitad de corte; lo cargas antes y ya no lo cargas durante el corte.
Compra otro compresor
 
Esos sopladores de pecera suelen ser un transformador de núcleo abierto que hace vibrar una lengueta --> Tenés campo magnético disperso que te induce corrientes en lo que pase cerca.
No podés ubicarlo donde se te antoje. Alimentalo con una prolongación desde una tomacorriente alejado y fijate a que distancia de los cables y placas no molesta, después lo montás bien y agregás algún blindaje (una chapa). A veces basta correrlo unos centímetros o cambiar el recorrido de algunos cables.
 
Muchas gracias a todos por contestar.

He puesto un varistor entre los contactos del interruptor que enciende el motor y parece que se ha solucionado. Digo parece, porque puede que en unos dias vuelva a pasar (ya me ha pasado que creia que lo habia solucionado pero a la siguiente vez que lo ponia, saltaba)

Tengo que reordenar los cables dentro de la caja porque mezclo cables de alterna con los de continua y siguiendo los consejos que me habeis dado, alejare todo lo que pueda los cables de alterna y continua.

Y ya me queda claro que las interferencias son cosas de hacer pequeños cambios y que todos sumados son los que las filtran.

Lo que veo mas logico de como atajar el problema (solo que no tengo los conocimientos ni la experiencia) seria colocar una serie de filtros que filtraran la señal del usb. Entiendo que es como debe estar hecho en el portatil mac y eso ayuda a que no tengas que estar aislando todo el entorno para que no te salte la señal.
En una ocasion encendi un compresor de aire, de estos con calderin, cerca de la maquina laser y me corto la conexion por usb, por eso digo lo de que lo suyo seria filtrar la señal de usb. Pero bueno, me conformo con que no salte con el soplador este de pecera.

Cuando tenga todos los cables reogarnizados y funcionando todo posteare a ver si he tneido exito o no.

Gracias de nuevo

Un saludo
 
Muchas gracias a todos por contestar.

He puesto un varistor entre los contactos del interruptor que enciende el motor y parece que se ha solucionado. Digo parece, porque puede que en unos dias vuelva a pasar (ya me ha pasado que creia que lo habia solucionado pero a la siguiente vez que lo ponia, saltaba)

Tengo que reordenar los cables dentro de la caja porque mezclo cables de alterna con los de continua y siguiendo los consejos que me habeis dado, alejare todo lo que pueda los cables de alterna y continua.

Y ya me queda claro que las interferencias son cosas de hacer pequeños cambios y que todos sumados son los que las filtran.

Lo que veo mas logico de como atajar el problema (solo que no tengo los conocimientos ni la experiencia) seria colocar una serie de filtros que filtraran la señal del usb. Entiendo que es como debe estar hecho en el portatil mac y eso ayuda a que no tengas que estar aislando todo el entorno para que no te salte la señal.
En una ocasion encendi un compresor de aire, de estos con calderin, cerca de la maquina laser y me corto la conexion por usb, por eso digo lo de que lo suyo seria filtrar la señal de usb. Pero bueno, me conformo con que no salte con el soplador este de pecera.

Cuando tenga todos los cables reogarnizados y funcionando todo posteare a ver si he tneido exito o no.

Gracias de nuevo

Un saludo
Pon un varistor entre L-N L-Pe y N-Pe. Tres en total
Los filtros filtran lo que yo te diga; si que filtran pero no es un pasa-no pasa. Es un dejo pasar mucho dejo pasar poco.
Si el ruido es muy fuerte poco de mucho sigue siendo mucho.
Se le puede poner un arranque suave al motor en lugar de un contacto electromecánico y muchas otras cosas.

Lo mejor de los ruidos es no generarlos, mucho mas que luego eliminarlos.
 
Tené cuidado cuando filtras las señales por el cable usb, porque un excesivo filtrado puede modificar los pulsos propios de las señales, al ser señales discretas de forma cuadrada, el exceso de filtro puede generar que se redondee los vértices y se modifica su forma, y despues tenes otro problema.
 
Siguiendo con las pruebas he visto que la señal viene por la alimentacion. Cuando cierras el contacto del interruptor del motor se genera un ruido que entra por la fuente de alimentación de la placa y de alli al usb.

Poniendo varistores como me recomienda Scooter se mejora mucho pero no lo elimina del todo.

Lo que si que ha eliminado del todo el efecto es conectar el motor a otro enchufe directamente, uno que esta muy alejado del que alimenta la fuente de la placa controladora.

Buscando por internet he visto que es un efecto tipico que pasa y que encima con la placa controladora que es una copia chinorris de un diseño open source, hace que el efecto se agrabe mas.
He probado con un arduino uno original y un shield para controlar motores a traves de unos drivers (tipico conjunto para controlara una impresora 3d o un pequeño router cnc) y cuesta mucho mas que aparezca el efecto, pero a la larga sigue ocurriendo.

Lo suyo es usar una conexion directa de 220v de la fuente que alimenta la placa. Lo que no acabo de entender es porque en una fuente de alimentacion de marca buena, no filtran mejor la señal de entrada. Supongo que no debe haber un filtrado universal, cada situacion debe necesitar un tipo de filtrado.

De momento reordenare la caja para poder alimentar po un lado a los motores de 220v (soplador de pecera y extractor) y por el otro todo lo demas. Con eso y los varistores en los interruptores ya queda solucionado. No me gusta mucho porque tener que usar dos enchufes es un poco engorro, pero sino se me ocurre usar un rele de estado solido para encender los motores. Aunque asi lo que hago es liarlo todo mucho mas.

Seguire poninedo mis avances
 
... No me gusta mucho porque tener que usar dos enchufes es un poco engorro, pero sino se me ocurre usar un rele de estado solido para encender los motores. Aunque asi lo que hago es liarlo todo mucho mas.

:oops: No pibe, enchufar lejos es un test para identificar por donde se mete el ruido. El paso siguiente siguiente es reacomodar los cables y poner un filtro de línea a la alimentación.
Si estás usando un transformador común , el primer paso son condensadores de 10n en paralelo con cada diodo del puente rectificador.
 
:oops: No pibe, enchufar lejos es un test para identificar por donde se mete el ruido. El paso siguiente siguiente es reacomodar los cables y poner un filtro de línea a la alimentación.
Si estás usando un transformador común , el primer paso son condensadores de 10n en paralelo con cada diodo del puente rectificador.

ah vale, pues yo ya pensaba usarlo como método alternativo hasta que aprendiera a diseñar un filtro :ROFLMAO:.
Tengo puesto un filtro antes de la fuente que alimenta la placa controladora de la marca Prax, modelo PX-1A40-006-F1. Es un filtro de estos que llevan conectores faston y que con el osciloscopio no veo que mejore mucho la señal que sale de la fuente.

Para alimentar la placa controladora uso una fuente de alimentacion Mean Well modelo LRS-50-12. Esta fuente no la puedo modificar, lo que querria hacer es filtrar la señal de entrada o sino los 12v dc de salida d ela fuente.


¿Como se controla ese motor?¿Con un relé?
Usa un triac con detector de paso por cero.

Un un interruptor normal y corriente que corta linea y neutro del motor. entre los contactos he puesto unos varistores como me recomiendaste tu y ha mejorado mucho la señal, pero no la limpia del todo.

He pensado en usar un triac como el que dices. Para activar el triac podria utilizar los 12v dc que obtengo de la fuente que alimenta la controladora? O seria mejor que no para no mezclar la fuente que quiero limpiar la señal junto con el motor que me genera el ruido.

Muchas gracias a los dos
 
...Tengo puesto un filtro antes de la fuente que alimenta la placa controladora de la marca Prax, modelo PX-1A40-006-F1. Es un filtro de estos que llevan conectores faston y que con el osciloscopio no veo que mejore mucho la señal que sale de la fuente.

Conectalo asi:

Filtro.jpg

Y que los cables del circuito del soplador estén alejados del resto.
 
Conectalo asi:

Ver el archivo adjunto 268655

Y que los cables del circuito del soplador estén alejados del resto.

Lo tengo conectado de otra forma porque al principio lo conecte asi y el soplador perdia fuerza y el extractor ni se encendia.
Lo tengo conectado asi y en el osciloscopio se veia la linea mas limpia que sin el varistor.

Sin título-1.jpg

Acabo de hacer la prueba de usar un rele de estado solido para encender el motor del extractor (que mete mucho mas ruido en la linea que el del soplador) y me ha funcionado perfecto, ningun corte. He usado los mismos 12V DC de la fuente que alimenta la controladora para activar el rele de estado solido y ningun problema. Es una buena solución porque solo tengo que añadir dos componentes mas y cablear un poco.
 
Arriba