funcionamiento de auriculares con microfono

#1
Hola buenas tardes...
Le agregue una entrada auxiliar al estereo de mi auto q funciona de 10 al usarlo con un mp3 o cualquier dispositivo de audio (se conecta por la ficha de auriculares de 4 polos pero solo 3 polos estan conectados -masa,salida derecha,salida izquierda de parlante-) pero al momento de conectar mi celular (que originalmente su conector de auricular es de 4 polos) tengo el problema q mi celular no lo detecta como auricular. El esterio reproduce la musica de mi celular pero el celular no desactiva su parlante externo entonces tengo las 2 cosas sonando.
Cabe aclarar que el auricular de mi celular ademas de los parlantes tiene microfono y un boton de control de llamadas.

Como puedo hacer para q al conectar esta ficha el celular detecte como si se hubiera conectado el auricular? :D

Gracias.
 

capitanp

Miembro irreconocible
#2
Quisas bajando la impedancia de entrada, prueba intercalando dos resistencias de 22Ω en masa y R, masa y L

saludos
 
#3
Hola buen dia, que bien por tener la cortezia de saludar, pasando al tema aunq nose exactamente como es el funcionamiento de la salida de audifonos de un celular presumo que de los cuatro pin's que tiene dos an de cerrarse al conectar los audifonos, estos dos pin's al cerrarse seguramente activan un "rele", por asi decirlo, que conmuta de (x) salida, caso del parlante a (y) salida, caso audifonos, desactivando, cortando la salida al parlante, esto lo presumo poniendole algo de logica al asunto, porq de otra forma no veo como se desactiva el parlante del celular
 

capitanp

Miembro irreconocible
#4
Hola buen dia, que bien por tener la cortezia de saludar, pasando al tema aunq nose exactamente como es el funcionamiento de la salida de audifonos de un celular presumo que de los cuatro pin's que tiene dos an de cerrarse al conectar los audifonos, estos dos pin's al cerrarse seguramente activan un "rele", por asi decirlo, que conmuta de (x) salida, caso del parlante a (y) salida, caso audifonos, desactivando, cortando la salida al parlante, esto lo presumo poniendole algo de logica al asunto, porq de otra forma no veo como se desactiva el parlante del celular

que logica complicada tenes...
 
#5
hola desarmando mis auriculares aprendi q entre 2 pines como bien dijo @caucanito, hay una resistencia de 1.3k ohm asi q se la agregue a mi conector y probando con solo parlantes anda, pero ahora cuando lo conecto al estereo del auto sigo en la misma.
A la entrada del esterio tengo una resistencia de 500k que es lo q me parece logico una resistencia teniendo a "infinito".Pero esto es un problema para mi ya que ahora es como si no tuviera parlantes por lo que el celular no detecta el conector y no deshabilita el parlante del mismo.
intente ponerle una R de diferentes valores entre masa y la salida de audio, se habilita el auricular pero el sonido no llega al estereo
como puedo hacer para bajarle la R al estereo?
gracias
 
#7
por que ponerle a la entrada una resistencia tan alta de 500k, ni que se le fuera a conectar un mega amplificador con la voz de dios, jejej... con una de 10k es sufuciente y eso que la salida de un celular es muy baja y con 500k no oirias es nada, y mejor utiliza el mismo cable de tus audifonos conectandolo desde el celular hasta la entrada de ampli por que la clave esta en el mismo audifono que al conectarse cierra, como si fuere una resistencia, un circuito que inactiva el parlante, ejemplo tenemos cuatro pines (a)(b)(c)(d) digamos que (a) es GND (b) es salida audio (c) es entrada microfono (d) es datos al introducir el "jack" de audifonos estilo usb, nose como le llamaran, (a)&(b) se unen por medio del audifono como si fuesen un jumper de baja resistencia lo que hace que el GND (a) pase al (b) al ahora el (b) ser polarizado por el (a) envia una se￾0Š9al a algun conmutador interno que abre los contactos del parlante desactivandolo, esto enpocas palabras esq (a)&(b) deben unirse por una R de bajo valor para que asi se desactive el parlante, lo malo esq si la R es de bajo valor bloqueara la salida del audio a un 98% hay lo que yo haria seria probar con diferentes valores de R



Posdata: "espero encuentre la manera, hay que ensaNar y ver como es el funcionamiento de los cosas, hay que ingeniarselas, ser recursivos, saludos, hasta dentro de 3meses."
 
Última edición:
#8
gracias a todos por su respuesta...

1)aclaro unas cosas que dijeron los 500k son propios ya del esterio de mi coche.
2)el conector que hice anda de 10 con un parlante de 8 ohm, es decir q enchufo la ficha en el celular y se pone en modo audifonos y desactiva el parlante. Asique supoongo q no es ese el problema.

Lo q supongo q es el problema es que necesita una resistencia menos 50k para q pase de modo normal a modo auriculares al momento de conectarle los mismos (esto lo se por diversas pruebas que hice). Y como el esterio tiene una R tan grande de entrada es como si "no tuviera nada conectado el celular".

Hay alguna forma de poner una especie de aislacion(estilo un actoacoplador o un transformador) para hacer q de un lado tenga menos de 50k y del otro tenga otra resistencia para que las dos paltaformas funcionen correctamente?
Para simplificar todo supongamos q es mono es decir solo tengo un cable de masa y otro de audio

les adjunte, para q se entienda mejor, un esquema de lo trato de hacer.
 

Adjuntos

#12
Amigo, dudo que funcione de esa manera ya que al existir tan abismal diferencia de impedancias. El nivel de transferencia sera bajo.
Deberas usar una etapa intermedia activa, como por ejem. un preamplificador.
 
Arriba