Funcionamiento de circuito ON/OFF de indicador de balanza

#1
Tengo un pcb el cual funcionaba con un microcontrolador WINBOND W78E052C40DL el cual está dañado. He levantado parte de la información de la placa la cual básicamente contiene lo siguiente:

p1:Circuito para manejar las señales de las celdas de carga
p2:Circuito para manejar los displays 6x7SEG de cátodo común.
p3:Circuito de alimentación con encendido y apagado con dos pulsadores.

La parte 1 no me interesa por el momento y aparentemente no hay problema.
La parte 2 funciona bien, usa un 74HC595 y ULN2003 para controlar por barrido los displays de 7 SEG. Esa parte la he probado independientemente y va bien.
La parte 3, la fuente de alimentación es la que tiene una parte que no puedo verificar si va bien o no puesto que no puedo hacer que funcione correctamente.
Estas placas suelen soportar doble alimentación la de una fuente AC/DC y la de batería.
Luego esa tensión va a un regulador de 5V cuyo código no veo pero parece ser el 7805.
El detalle está en que la tensión de 9V no llega directamente al regulador, sino que pasa por un arreglo de resistencias (5), diodo (1), pulsadores (2) y transistores (2).
El problema que tengo es con los dos transistores que aparentemente se tratan del 2AS1213 (NY SMD)y el BC817 (6B SMD). Subo una imagen sobre el detalle de esa parte del circuito para ver si alguien me puede decir cómo funciona exactamente. El micro (pines 23 y 24) y el inversor no están energizados previamente al conectar la alimentación a la placa recién encienden al presionar el sw6.
Asumo que luego el mcu al prender pone el pin23 a salida y en LOW cosa que TR3 se encarga de activar la base de TR2. Luego con el SW7 se desactiva TR3, lo cual apaga el TR2 o debería. Parece ser que uno de los componentes está fallando porque a veces prende, y a veces no. Igual no me queda claro qué hace o haría el pin24. Me gustaría que me ayuden a identificar como debería funcionar el circuito correctamente.
 

Adjuntos

Última edición:
#2
Hola, al parecer el pin 23 y 24 trabajan en el enclavamiento de encendido y apagado de dicho mecanismo. Pues estando apagado el mismo, al presionar el botón ON , el diodo D5 se aterriza a GND, el micro detecta ese cambio de estado a través del pin 24. Luego el pin 23 cae a GND para encender al transistor BC 817. De ésta manera, conduce también el transistor PNP.
Cuándo se presione el pulsador OFF. El transistor NPN, entra en corte haciendo caer la alimentación del sistema.
 
Última edición:
#3
Hola, gracias. Pasa que el micro recién prende al apretar el pulsador ON ya que el regulador de 5V es el que lo energiza al igual que al 74HC14. Que el pin24 sea entrada es algo que también estaba pensando aunque realmente no me quedaba claro. Ahora más o menos pensaba similar con lo que me has descrito y había probado una simulación y resulta que el circuito en cuestión no apaga/desactiva completamente a TR2.
 
#4
Gracias... efectivamente tenías razón, la placa tenía un comportamiento errático cuando probaba esa parte, resulta que el 74hc14 al energizar apretando ON hacía el enclavamiento automáticamente sin importar que el pin 23 estuviese al aire (de hecho no había MCU) y aún así enclava. Pero el hecho de que yo haya pensado que había un problema en algún componente era que en las pruebas que realizaba en algunas ocasiones al prender usando ON se encendía algunos displays y en otras no. Tomé ese encendido como prueba de que realmente había enclavamiento y cuando no había displays encendidos pensé que fallaba un transistor o cosa parecida. Pero luego que medido los voltajes en la entrada/salida del regulador al margen del si prende o no los displays noto que siempre hay enclavamiento.
Lo cual me indica que prende o no aleatoriamente dependiendo de lo que arrojen las salidas del shiftregister (74HC595) lo cual no puede ser controlado inmediatamente después de un arranque.
GRACIAS.
 
#5
Buenas. ¿Alguien me puede ayudar con la reparación de una tarjeta de una balanza electrónica de 500 Kg?
Al mantener oprimido el pulsador, enciende, al soltarlo, se apaga.
Ya probé el pulsador y no es. Ayuda.
 
Última edición por un moderador:
#7
Hola, al parecer, el sistema no se autoenclava cómo lo hacen muchos controladores, que al presionar ON/OFF, detectan el cambio de estado, y toman acción.
El pulsador que tú dices, es un pulsador y nada más.
El problema está en la tarjeta.
Si tú mantienes presionado el botón, funciona todo cómo debe? Y sostengo la petición de Fogonazo, hay que ver esquema, foto o algo, así sólo se especula.
 

pandacba

Rocker Bear
#8
Mide el botón es muy común que se arruine y no haga contacto, saclo de la placa, al presionar no debe tener resistencia.
Si la tensión de alimentación esta correcta hace un punte momentaneo si la tarjeta esta bien deberia encender .
Si no enciende por lo general llevan un regulador de tres terminales, habría que verificar si todo esta bien.
Normalmente es un regulador de tres terminales tipo 7805
 
Arriba