Generar ruido blanco

#1
Estoy necesitando contruir un generador de ruido blanco, alguien conoce algún circuito o si es un integrado que lo genere directamente es mejor.

Desde ya muchas gracias
 
#2
Puedes colocar un transistor, preferiblemente NPN, al cual en su base le coloques un condensador de baja capacidad, una resistencia de 1K en su colector y el emisor a masa. Has de sacar la señal del colector.

El condensador lo que hace es desacoplar la señal que le entras, puesto que no esta en paralelo, eso genera ruido que el transistor amplifica.

Espero que te sirva.
 

Cacho

Antiguo tableador
#6
...tengo a la salida un ruido "blanco" pero en una señal de -15V, a que es debido esto?
Primero que nada: ¿Cómo mediste eso?

Siguiendo con las causas, puede ser porque:
-Alimentaste el circuito con una sola polaridad.
-Conectaste la resistencia de 1M a las patas 6 y 4 y de ahí a la 3 y al pote de ganancia.
-Cualquier otra cosa.

Si caemos en la tercera, sacá el transistor del circuito y fijate si sigue apareciendo esa tensión en la salida. De ser así, seguimos viendo desde ahí.

Saludos
 
#7
#8
Buenas Cacho, por partes:

- Medí eso, con un osciloscopio y me da una señal de -15V con un ruido de una amplitud de 40mV y con la FFT de la señal me dice que no hay ningun armónico, por lo que deduzco que es ruido blanco.

- Estoy seguro que alimento con las dos polaridades y que no está conectada la resistencia de 1M a las patas 4 y 6.

- Mañana por la mañana continuo con el montaje (en España son las 23:00 h) y te comento los resultados, pero, ¿Por qué tengo -15V a la salida del operacional?, no lo entiendo.
En la entrada del operacional tengo 0 Voltios en una y -4 V en otra --> cosa que contradice la teoria de los operacionales, estos dos valores con un ruido acoplado de media 0 (ó -4, en su caso).

Te puedo dar los valores que quieras en cada parte del circuito, si lo consideras necesario

SAludos!!

Gracias Eduardo, mañana por la mañana comprobaré todo esto!!
 
Última edición:
#10
Buenos días, adjunto el esquema del circuito que he realizado para generar un ruido blanco y añadirsele a una señal (V2).

El circuito consta de 3 partes claramente diferenciadas:

1. Generador del ruido blanco propiamente dicho
2. Filtro pasa altos para eliminar bajas frecuencias
3. Adaptador de impedancias para limitar el consumo del ruido
4. Circuito sumador para meter el ruido blanco a la señal V2, yo la he usado para generar ruido a una onda senoidal

Si teneis alguna consulta no dudeis en contactar conmigo

Saludos!
 

Adjuntos

#13
buenas tardes yo estoy armando un generador de ruido blanco pero tengo muchos problemas ya... lo que ocurre es que el ruido sale del transistor 2n2222 y despues entra al OPAMP (configuracion sumador no inversor y se suma con una señal para el ADC de 1v o 1.5v de un microcontrolador) pero el problema es que cuando sale sale un valor DC :/ de 1.5v aprox. y bueno nose que paso con el ruido es como si no se hubiera sumado en el opamp :/ no le veo sentido.. aunque solo he armado este circuito en hoja y bueno el papel aguanta todo, ahi les mando mi diseño bueno adaptacion... las fuentes del opamp son 5v y GMD y la del transistor es salida digital de un microcontrolador entre 4.5v y 5v.

la etapa del ruido si funciona bien, lo que no funciona es la etapa sumadora, pensaba que podia ser el ancho de banda... la verdad ya notengo idea.

agradesco su tiempo ojala me puedan ayudar...
 

Adjuntos

#15
ya lo intente mi problema fue de que en la salida no pasaba la señal AC del generador de ruido ese circuito que esta en el pdf que pasaron arriba tambien lo adapte pero tengo el mismo problema es el opamp lo que me no me trabaja como debe ser quizas sea en ancho de banda por eso es que tenia mi duda... gracias
 
#16
Dudas que me surgen. En tu circuito inicial, en cuánto se amplifica la señal AC de ruido? Para qué colocaste el capacitor en el emisor? Mediste la señal a la salida del amplificador (eliminando la del sumador) para estar seguro que efectivamente esa etapa está funcionando como debe? La etapa del sumador no la entiendo. Sin armar el circuito, a ojo las resistencias R85 "mata" a la señal AC y R86 agrega un nivel DC. Por otro lado, como dices que tienes un ADC del microcontrolador no especificas si es fijo o variable este valor. Asumiendo que es fijo, porque indicas que es 1v ó 1.5v entonces el capacitor C28 no debería estar ahí. Sería bueno que le des una segunda mirada al circuito del link que te brindó ezavalla. De igual forma, si has hecho modificaciones, sube el circuito que has hecho y las mediciones que hiciste para ver si podemos ayudarte.
 
#17
si tienes razon ya lo revisare de nuevo el condensador C28 no va ahi... y si es un valor DC.
con r85 hice una prueba mas kitandola y conectandolo con un cable y pues si pasaba bien el ruido pero el sumador cuando sumaba el DC con el AC el DC lograba quedarse y la AC casi ni se notaba.

de cual condensador me hablas cuando dices que lo puse en el emisor.
hace unos momentos probe quitandole las resistencias de el pin 10 con el pin 11 del opamp cosa que ya no amplificara nada solo sumara y por ahora es suficiente... pero sigo viendo la señal DC en la salida antes del capacitor... :)

si necesitas volveria a subir el circuito siguiente para que veas como quedo... :) agradesco su tiempo
 
#18
ahi esta el circuito que dije... he hecho esos cambios... ya funciona aunqe no funcionaria como debe de ser porque solo cuando toco un pin del condensador de la base del transistor, supongo que me comporto como una antena y por eso amplifica ese ruido que yo genero, y a la salida puedo apreciar un ruido aunque no como que el que esperaba, no parece ruido blanco mas parece otra cosa.. gracias por su tiempo :)
 

Adjuntos

#19
El capacitor que mencionaba era el C25. Trata de hacer esto, desconecta la conexión de C27 al LM3900 y verifica que efectivamente la amplificación se esté dando como esperas. Incluso al medirlo, prueba quitando el capacitor que mecioné y colocándolo otra vez para que veas si hay alguna diferencia. Una vez que hayas corroborado que hasta aquí todo funciona bien entonces coloca la etapa del sumador. Te recomiendo que una vez que estés seguro de las etapas anteriores, ahora sí coloques la resistencia que habías quitado la R85 para ajustar la ganancia y quites la R86. Observando tu circuito, no estoy seguro que el transistor 2N2222 te genere el ruido blanco de esa forma, lo tenías bien en tu primer circuito. En la etapa del sumador, debes calcular el valor de las resistencias R91 y R92. Por último no veo qué señales se están sumando, solo veo la señal de ruido, por lo que básicamente estás haciendo un amplificador, no un sumador. La conexión del micro a la salida es para enviar o para recibir? Te dejo este link, que tal vez te ayude más: http://www.mundomanuales.com/electricidad-y-electronica/electronica/amplificador-sumador-no-inversor-2330.html
 
Última edición:

Temas similares