inconvenientes con un rele de 12v

#1
hola amigos, bueno disculpen mi ignorancia, brevemente les cuento, cree un software que permite accesar a las personas a los gimnasios, para la apertura le pedi a un electronico que me ayudara usando el puerto rs232 de una pc para que me mandara un pulso, asi lo hizo envio por el pin 3 y 4 en este caso seria TXD,DTR generalmente desde una board generan 24v y este los saca cuando yo le digo por medio de mi codigo fuente que me verifique si hay dato de trasmision y cierro de nuevo el puerto,, hasta ahi iba bien, resulta que utilizo un rele de 12v, donde lo alimento con un adaptador de 12v de 1000 map, y el pulso le llega 12v ya que yo lo bajo con un resistencia de 1000 ohm.

mi pregunta es la siguiente.

Porque cuando yo mando el pulso el rele se activa y me deja pasar 120v en este caso es una cantonera, el rele sigue mandan penticiones de apertura sabiendo que el puerto esta cerrado. Lo que me preocupa es que cuando no conecto la cantonera electrica, este funciona muy bien.
Espero que alguien me ayude ...

foto del rele de 12 v
 

Adjuntos

Última edición:
#2
El capacitor, para que lo utilizas? esta muy grande!!, y el diagrama esquemático? ese es el que interesa, con la imagen no se como van conectadas las cosas. Bueno me imagino que es un simple transistor como interruptor.

- No veo el diodo de protección para el transistor (ya que utilizas una carga inductiva, el relevador).
- Manejas tensión de 110V/220V y controlas otra carga inductiva (el cerrojo), sin protección contra picos de tensión (puede generar arcos en los contactos del relevador).

La señal la tomás directamente del puerto RS232 de la computadora? o utilizas algún driver (max232 por ejemplo?)

Yo creo que el capacitor tarda en descargarse y esto retarda que el transistor pase de saturación a corte, prueba cambiando el valor a uno más chico.
Dices que funciona sin la cantonera, prueba colocando otro tipo de carga (foco incandescente 100W, 60W, etc.) y ve su funcionamiento, si funciona bien (enciende y apaga el foco con normalidad) entonces es debido al tipo de carga de la cantonera (inductivo) y genera problemas, esto lo puedes solucionar colocando un filtro amortiguador a la red, cerca del relevador (interruptor electromecánico). Hay mucha información en el foro sobre ellos.
 
Arriba