Interface USB para protocolo DMX512

#62
Miraaa... si no me equivo el diseño origial es con un SN75176 es el receiver mas comun en los sistemas dmx. lo hice tal cual esta... saludos
 
#63
Me parece que no le diste bola a mi comentario, si te bajás las dos hojas de datos te vas a poder dar cuenta si la posición de los pines es la misma o no, para eso sirven.
 
#67
Si, generalmente son lo mismo... esas letras adicionales o bien te indican el fabricante o las caracteristicas como tensiones y temperaturas de operación y cosas asi...
 
#71
Hola gente!! hoy traigo un reto mas que se me presento para seguir mejorando el circuito y llevarlo a la version 2.0. el circuito anda barbaro y es simple, ahora se me ocurrio poner optoacopladores en la salida para proteger tanto el circuito como nuestro preciado puerto usb de posibles fallas en las luces que conectemos, seria desastrozo que nos entrara 220v por el DMX :S estuve leyendo bastante sobre optoacopladores pero todavia no estoy seguro de como se conectarian o en que parte del circuito los pondria. dejo el esquematico del proyecto. a alguien se le ocurre o tiene idea como modificarlo para optoacoplar las salidas??
 

Adjuntos

Última edición:
#73
Cómo en nuestro proyecto no se está usando RX (que de todos modos creo que es de gusto) habria solo que poner un opto entre el pic y el semiconductor entonces?, me estaría quedando el GND del dmx sin cubrir y peligraría mi puerto USB. esto es asi o solo me estoy enredando?? Muchas gracias y saludos!!!
 
Última edición por un moderador:
#74
Como en nuetro proyecto no se esta usando RX (que de todos modos creo q es de gusto) habria solo que poner un opto entre el pic y el semiconductor entonces?, me estaria quedando el GND del dmx sin cubrir y peligraria mi puerto USB. esto es asi o solo me estoy enredando?? muchas gracias y saludos!!!
si tienes que cubrir el gnd por eso lleva el convertidor dc-dc solo que en la foto que subi que es de open dmx lo pusieron asi unido pero deberia ir mas o menos asi
0optodmx.JPG
esquematico en eagle
Ver el archivo adjunto untitled.zip
es un ejemplo no mas no te digo que tiene que armarlo asi por que no lo pude probar no se si funcionara pero mas o menos te da una idea
 
#75
Lo use varios dias ,,mediante el manual en español que trae pude aprender a grabar escenas y jugar con varias funciones que trae.
Al otro dia lo prendo y conecto el led movil,,cargo la escena para que reprodusca lo que hice el dia anterior y no pasa nada.
Ahora traté de cargar de nuevo el led desde el directorio y nada, ni siquiera lo detecta al led.
Despues probé con otro cabezal que tengo y tampoco lo detecta.
Estoy recordando si configuré alguna función sin querer o si toque algun botón que esté impidiendo que el interface detecte los equipos.
Estoy leyendo el manual atentamente pero no hay ninguna explicacion de esta falla.
La interface prende la luz roja y la verde que quiere decir que está funcionado supuestamente.
El problema es que tengo que hacer unos eventos de iluminacion y prescso que alguien pueda darme una solución.
Ya que el interface esta buena, por que los primeros dias que lo use tenia toda las funciones necesarias para realizar un evento..
 
Última edición por un moderador:
#76
Mirá , yo creo que lo que te pasa es un problema de canales, fijate bien que el equipo que cargaste en freestyler tenga puesto el mismo canal de inicio que le pusiste al cabezal o equipo que conectás, me entendiste ?
 
Última edición por un moderador:
#79
que tal compañeros les comento que arme la interface usb dmx y les comento que todo salio muy bien apenas lo termine ayer esta algo rustico pero funciono a la primera el pic lo grabe con un grabador que dan aqui mismo el que lleva 3 led , use mi lap top ,tenia mis dudas si usar mi lap o una de escritorio ya que mencionaban que no dan el voltage para programar y si haciendo pruebas antes de grabar el pic cheque que solo me daba 11.36 vol pp , como compre 2 pic me anime a hacerlo y para mi sorpresa se grabo perfectamente sin error, use el ic-prog y hay algo mas antes de todo lo anterior mi grabador despues de armarlo lo probe poniendo un pic que tenia una tarjeta de una caja fuerte 16f84, lo podia leer y borrar pero no podia volverlo a grabar con su misma informacion me daba error al igual que a otros compañeros asi que probe cambiando configuraciones al ic-prog y di con algo que esta en "miscelanea - prioridad del proceso, estaba en " normal " le marque a tiempo real , me dejo de dar errores " lo use con freestyle y andubo bien lo seguire probando
 

Temas similares

Arriba