LM331 Frecuencia a Voltaje

#1
Hola, buen día :)

No he podido hacer funcionar el CI para convertir de frecuencia a voltaje y quería ver si me pueden ayudar.

Primero armé el circuito y como no funcionó, lo simulé en Proteus7 para ver si lo había alambrado mal.. pero sigue sin funcionar (no había usado Proteus, así que también ahí pude haberlo conectado mal :eek:).
Lo he probado como dice la hoja de especificaciones, con un voltaje de 15V. y he estado variando la frecuencia y nada.
De preferencia me gustaría usarlo con un voltaje de 5V para mayor practicidad. Lo que pretendo hacer, es enviar un Beep(Frec, Time) desde mi laptop (usando el cable de sonido) y que dependiendo de la frecuencia, varié el voltaje para después diferenciar el rango de voltaje con Op-Amps.
La amplitud que recibe el circuito proviene del puerto de sonido de mi laptop, que es de 2 Vpp, también lo he probado con un amplificador previo a ésta para tener una mayor amplitud.

Ammm.. adjunto un .RAR con la simulación en Proteus, el datasheet y una imagen de mi proto :p (941.42 Kb).

Y por acá una imagen de la simulación:


y una del datasheet:



Bueno, espero que me puedan orientar en esto.
De antemano, gracias!!
 

Adjuntos

#2
que tal, mira justamente yo tambien estoy trabajando ahorita con un lm331. y arme el mismo diagrama que muestras y si me funciona. lo he alimentado a 15 y 5V y funciona. solo que la frecuencia que le puedes meter solo es de 0 a 10 kHz.

todos los valores los deje igual salvo el de los capacitores de 470pF y Ct, que no recuerdo que valor use exactamente, esos capacitores los puse de poliester, dado que la hoja de datos asi lo pide(mylar).

El potenciometro lo tengo en la minima resistencia. y el voltaje que te da es de acuerdo a la formula que aparece justo abajo de ese diagrama y es bastante exacta la formula.

Lo he probado con un generador de funciones. Lo que a mi me causa problemas es que no se cuanta corriente me da a la salida, por que nisiquiera puedo prender un led.

Checa tus conexiones seguro te fallo algo por ahi.
 
#3
que tal, mira justamente yo tambien estoy trabajando ahorita con un lm331. y arme el mismo diagrama que muestras y si me funciona. lo he alimentado a 15 y 5V y funciona. solo que la frecuencia que le puedes meter solo es de 0 a 10 kHz.

todos los valores los deje igual salvo el de los capacitores de 470pF y Ct, que no recuerdo que valor use exactamente, esos capacitores los puse de poliester, dado que la hoja de datos asi lo pide(mylar).

El potenciometro lo tengo en la minima resistencia. y el voltaje que te da es de acuerdo a la formula que aparece justo abajo de ese diagrama y es bastante exacta la formula.

Lo he probado con un generador de funciones. Lo que a mi me causa problemas es que no se cuanta corriente me da a la salida, por que nisiquiera puedo prender un led.

Checa tus conexiones seguro te fallo algo por ahi.
Amigo estoy trabajando en el mismo circuito con 5 voltios. podrias indicarme los capaciores que usaste?
 

Temas similares

Arriba