Manejo de modulos TLP434 y RLP434

#61
Los HT no sirven para aislar electricamente. Al enviar datos en forma digital es necesario un protocolo, estos IC se encargan de esto. Lo que hacen es poner los datos (niveles de tensión) tomados de 4 pines (al mismo tiempo, en paralelo) y los envían en serie. De ahi en más le colgas los módulos de 433MHz para la transmisión (por RF, no por IR).

De igual forma, supongo que es posible ir poniendo datos por estos pines e ir habilitando/deshabilitando el IC para que envie o no. Aunque sería bastante engorroso para un gran volumen de datos y la velocidad sería pésima. Pero si son pocos datos anda bien.

Lo del puerto serie también lo podés probar, debería funcionar.
 
#62
Bien chaD , ahora me queda mas claro. Estuve viendo por ahi y efectivamente muchos usan estos decoders.
Te cuento lo que quiero hacer, basicamente seria un transmisor y N receptores. Los receptores tendia un pic que manejaria un motor que abre una puertita(0,25,50,75,90 grados) (servo o paso a paso no decidi) lo unico que tendria que enviar el trnasmisor son 2 bits uno para habilitar la puerta elegida por ejemplo "puerta A" y el otro bit le incaria cuantos grados de apertura , Osea cero volumen de informacion.
Ah me olvidaba , estuve viendo el catalogo de componentes de cika y no aparecen los tlp por ningun lado, a lo mejor tengo que llamar por te y preguntar.

Saludos ,un abrazo
 
Última edición:
#63
Si tu idea es hacerlo con los HT, podes ponerle a cada puertita una dirección distinta (8 bits=256 puertitas máximo) y luego con los otros 4 bits podés darle 16 órdenes distintas. Incluso podes hacer 90/16=5.63, es decir, que la puerta tenga distintos niveles de apertura, cada 5.63º. En fin, las posibilidades estan, todo depende de tus requerimientos.

El direccionamiento del encoder (a que puertita le vas a enviar) y los datos que envias lo haces con el PIC.

Vos decis que con un bit enviarías el grado de apertura. Un bit tiene 2 estados, o sea, podrías hacer abierto o cerrado únicamente.
 
Última edición:
#64
Perdón me exprese mal, quise decir byte . Pero la verdad no le encuentro necesidad de usar encoders por lo que vos me dices. Si la comunicacion via rs232 funca bien solo tendria que hacer esto:

Desde el transmisor:(por ejemplo quiero hablar con la puerta "A")
a=1;
printf(" %u",a); //el receptor en puerta A dice " estan hablando conmigo" ¿cuantos grados habro la puerta?
y dps le mandas los grados de igual manera
printf("%u", grados);

y asi con las demas puertas, no se parece facil , no creo que lo sea tanto pero es lo que se me ocurre ahora.
Gracias ChaD
 
#66
Buenos dias a todos en mi trabajo estoy trabajando con estos dos modulos necesito envia un archivo desde un computador al otro y viceversa, para ello hice un comunicacion full duplex la cual me permite comunicar la dos computadoras sin embargo se podrido mandar caracteres mediante el uso de hyperterminal aun no he podrido mandar un archivo sastifactoriamente. Seras q alguien ha hecho algo parecido para q me puedas ayudar??
 
#67
No he hecho, pero supongo que el problema puede venir por la forma en que estas abriendo el archivo, ya que no deberia haber problemas, aún podrías mandar el archivo caracter por caracter. Cómo lo estas haciendo? Que tipo de archivo es?
 
#68
Bueno estoy tratando de envía archivo txt el cual tiene un mensaje corto. El archivo lo mandó con hypertérminal usando 2 computadores el cual configuró para q uno sea el transmisor y el otro el receptor. He utilizado de tx rx de mismo frecuencia y de distintas frecuencias y aún así no lo envía
 
#69
Gringo, no entiendo como estas mandando un txt por hyperterminal. Si estas usando un programa hecho por vos, ese debe ser el problema (si con el hyperterminal ya te anda bien). Si es así, creo que tu problema es mas bien el software. De todos modos, sería bueno que abrieras un nuevo post para tu problema, ya que queda medio descolgado aca
 
#70
Hola gente...estoy tambien haciendo pruebas con estos modulitos...puedo comunicarlos pero todavia estoy experimentando para lograr un alcance adecuado...Les comento que la salida de Linear Out no se utiliza como una salida lineal, la funcion de ese pin es la de control de sensibilidad, mejor dicho, chequeo de sensibilidad. Ese pin entrega un nivel de tension analogico que es proporcional a la sensibilidad del receptor..es decir, a la potencia de recepcion.. se puede utilizar para calibrar el receptor y comprobar con cuanto potencia se recibe en determinadas situaciones...

Bueno, espero haber ayudado un poco...Saludos
 
#71
Kaneda, ese pin se llama RSSI (receive signal strenght intensity) y es justamente para lo que vos decís. Ahora bien, tengo varios módulos y en ninguno de ellos he podido hacer alguna medición correcta de intensidad con ese pin. Vos lo has probado? Pudiste hacerlo andar?
 
#72
Hola a todos, disculpen ya lei todo lo que aqui dice y aun no me queda muy claro como utilizar los HT, es necesario usarlos para transmitir y recibir con los modulos TPL434 y RLP434? para que sirven los pines de direccion, como se utilizan? yo estoy intentando comunicar estos modulos por medio de un pic, sin los HT, pero no se si esta bien, ya que a veces la comunicacion me responde bien pero despues de un tiempo siempre se bloquea mi pic del receptor y tengo que reiniciarlo.

Gracias espero alguien me pueda ayudar
 
#73
hola, tengo un "tlp-434 wenshing" segun lo que se lee en el dispositivo, el problema es que tiene 6 patas, la 1 y 2 estan puenteadas, al igual que la 3 y 4, lo que nos da un total de 4, pero necesitaria que alguien me diga cual es cual (Vdd, ground, data in, antena) ya que me pase horas buscando la informacion tecnica y ni el mismo "wenshing" se acuerda que los fabrico, jeje....gracias
 
#74
Bienvenido al foro! No es ese el nombre oficial para los Wenshing, por eso no lo encontrás. Los TLP y RLP son de Laipac. De todos modos desde la página de Wenshing se encuentran fácil (http://www.wenshing.com.tw/Products/RF_Module/). El modelo que debés tener es el RWS-371-6.

No se que problema tengo que no me deja adjuntar el datasheet. En la PRIMER página de este thread Andrés subio unas hojas de datos, lo baje y es correcto el pinout. Es su tercer ardjunto. Saludos,
 
#75
Hola, es la primera vez que utilizo el foro para hacer una pregunta. Espero me puedan ayudar. Estoy realizando un proyecto donde mis modulos de radio frecuencia, transmisor tlp434A y receptor rlp434 (http://www.laipac.com/easy_434_eng.htm) deben activar un led y un motor de manera independiente atravéz de un Ht12E y un Ht12D. No encuentro un diagrama donde no venga un microcontrolador y no puedo usar uno. Al conectar los modulos para prueba no tengo ningun problema pero al conectar a los Ht no funciona. Quisiera saber si me podrían explicar como deben funcionar los modulos y si puedo conectar a los ht sin ese microcontrolador.
 
#76
Quisiera saber si me podrían explicar como deben funcionar los modulos y si puedo conectar a los ht sin ese microcontrolador.
si.. si se pueden conectar sin mictrocontrolador, los HT codifican y decodifican....

en la ficha tecnica viene el diagrama..... no se si ya lo sabieron por este tema...
 

Adjuntos

#77
tengo dos Modulos RF TX(FST-3) RX(CZS-3) - 315Mhz / 433.92Mhz . experimente con una fuente para los dos y me funciono bien pero al haserlo con otra fuente(fuentes separadas) y a la misma distancia no funciono . alguien me podria decir q fue lo que paso ... notngo idea y me estoy arrancando los pelos..
 
#78
tengo dos Modulos RF TX(FST-3) RX(CZS-3) - 315Mhz / 433.92Mhz . experimente con una fuente para los dos y me funciono bien pero al haserlo con otra fuente(fuentes separadas) y a la misma distancia no funciono . alguien me podria decir q fue lo que paso ... notngo idea y me estoy arrancando los pelos..
Yo tengo el mismo problema... he leido que tienen problemas de ruido y que en los protos no funcionan adecuadamente...

mi posible hipótesis es blindarlos y hacer la PCB.... veremos!!!!

Este es el resultado de mi hipotesis.. casi no creo pero tambien ya he intentado de todo incluso con tres modulos diferentes....

Dibujo.JPG
 
Última edición:
#79
Gracias lubeck por responder. pero ayer queme 2 integrados 16f628a al intentar miles de configuraciones en el proto, aun asi estuve determinado el dia siguiente a que funcione asi que compre otros y aorita me funciono bien(con un poco de inerferencia supongo que por el proto)con las dos fuentes separadas,no se que fue pero ice el mismo procedimiento y estavez funciono...??? :) .ahora mi otra inquietud es si lo paso a un impreso y lo pongo en una cajita funcionara mejor o peor que en el proto.....??.;)y culquier informacion q necesiten me lo hacen saber yo lo posteo el circuito y programa q utilice...:unsure:
 
#80
Andaba todo bien mis codes los probe casi todo un dia y sin problemas, pero en la noche se prendieron los 4 leds de salidas del ht12d, sera alguna señal que interfirio por ahy?, ya no puedo apagarlos con ningun boton solo desconectado la fuente,:unsure:
 

Temas similares

Arriba