Osciloscopio de 100 leds con LM3915 y CD4017

#1
Buenas compañeros, recientemente acabo de entrar a cursos de electrónica donde he aprendido a realizar cálculos con transistores, y por iniciativa propia quise realizar en físico un osciloscopio o vúmetro con efecto de analizador de espectro, he hecho una simulaciones en Proteus y va de maravilla [Para que me corriera mejor la animación cambié la configuración de SPICE Option, fui a System>Set Animation Options>SPICE Options>Seleccioné "Settings for Better Convergence" y le di a Load] (Es el diagrama que dejaré abajo). Ahora bien, he querido modificar mi primer diagrama agregando transistores en las filas como en las columnas y no he logrado que me funcione como debería. Estaba planeando introducir BJT, como los BC337 y BC327 por ser conocidos como transistores amplificadores, y al momento de correrlo la intensidad de luz del LED es demasiada baja o imperceptible. Y pues el motivo de que le quiera agregar transistores es para asegurarme que mi matriz de 10x10 encienda bien y de igual forma sea como una medida de seguridad por si hay una sobrecarga.
Les agradezco su ayuda :D
1555102578533.png
 

Dr. Zoidberg

Well-known-Papá Pitufo
#2
Las filas las maneja el LM3915 que tiene salidas de corriente constante, por lo que no requieren de ningun transistor adicional (probá leyendo el datasheet). El CD4017 si requiere transistores, pero como no mostras la forma en que los pusiste, no se puede decir nada al respecto.
Por ultimo, eso no es ni por cerca un analizador de espectro por que le faltan los filtros que discriminan las frecuencias. Mas bien es una especie de osciloscopio con escala logaritmica de amplitud, que sirve para poco mas que jugar...
 
#3
Las filas las maneja el LM3915 que tiene salidas de corriente constante, por lo que no requieren de ningun transistor adicional (probá leyendo el datasheet). El CD4017 si requiere transistores, pero como no mostras la forma en que los pusiste, no se puede decir nada al respecto.
Por ultimo, eso no es ni por cerca un analizador de espectro por que le faltan los filtros que discriminan las frecuencias. Mas bien es una especie de osciloscopio con escala logaritmica de amplitud, que sirve para poco mas que jugar...
Puse el BC337, y al momento de correrlo, los leds se encienden en función del LM3915 y no del CD4017, no sé si me explico, cuando pasa el contador a una columna de la matriz no hace nada. Tiene dos resistencias, en modo de una polarización fija en el transistor. Está conectada una resistencia de 10k ohms en la base y una de 470 ohms en el colector.
1555110327646.png

Y gracias por lo del efecto de analizador de espectro, supongo que teniendo este funcionando, me investigaré como realizar el filtro de banda :)
 

Daniel Lopes

Miembro Geconocido
#4
Puse el BC337, y al momento de correrlo, los leds se encienden en función del LM3915 y no del CD4017, no sé si me explico, cuando pasa el contador a una columna de la matriz no hace nada. Tiene dos resistencias, en modo de una polarización fija en el transistor. Está conectada una resistencia de 10k ohms en la base y una de 470 ohms en el colector.
Ver el archivo adjunto 178014

Y gracias por lo del efecto de analizador de espectro, supongo que teniendo este funcionando, me investigaré como realizar el filtro de banda :)
Hola a todos , en ese circuito NO hay como enciender los LEDs porque su respectivos Anodos nesecitan de +B (alimentación) y esa condición NO es atendida.
Serias nesesario agregar transistores PNP entre lo +B y los anodos de los LEDs y los NPN actuando en las bases de los respectivos PNP por meo de resistores de limitación de base.
!Suerte en los desahollos!.
Att,
Daniel Lopes.
 
Última edición:
#5
Hola a todos , en ese circuito NO hay como enciender los LEDs porque su respectivos Anodos nesecitan de +B (alimentación) y esa condición NO es atendida.
Serias nesesario agregar transistores PNP entre lo +B y los anodos de los LEDs y los NPN actuando en las bases de los respectivos PNP por meo de resistores de limitación de base.
!Suerte en los desahollos!.
Att,
Daniel Lopes.
Gracias compañero! hice los cambios que me mencionaste y al momento de simularlo funciona el CD4017 en conjunto con el LM3915 (anexo imagen de la nueva conexión)
1555114845120.png
Solo algo que noté fue que cuando el pin 3 se desactivaba es que solo esa columna se encendía. Eso mismo pasaba con el pin 2 y 4. Anexo fotografía, pensé que sería efecto contrario, que se apagaría esa columna y las demás columnas se mantendrían encendidas.
1555115144078.png
 

Daniel Lopes

Miembro Geconocido
#6
Gracias compañero! hice los cambios que me mencionaste y al momento de simularlo funciona el CD4017 en conjunto con el LM3915 (anexo imagen de la nueva conexión)
Ver el archivo adjunto 178017
Solo algo que noté fue que cuando el pin 3 se desactivaba es que solo esa columna se encendía. Eso mismo pasaba con el pin 2 y 4. Anexo fotografía, pensé que sería efecto contrario, que se apagaría esa columna y las demás columnas se mantendrían encendidas.
Ver el archivo adjunto 178018
?? Descurpe amigo , ahora fue yo quien no entiendi , quieres todas colunas aciendidas y que apague una a cada ves?
Si for eso entonses NO hay la "multiplexación" .
Debes despues canbiar de filtro pasa banda a misma cadencia del "U2" o sea tienes que selecionar cada filtro pasa banda correspondente a la coluna selecionada por lo contador de decada "U2".
En tienpo : olvidaste de poner lo resistor de limitación de curriente de base del transistor PNP tal cual como te recomende en mi post , su valor puede sener de 10Komios.
!Suerte !.
Att,
Daniel Lopes.
 

Temas similares


Arriba