Problema con oscilador Pwm con ug3526

#22
el circuito que se muestra en la imagen por lo que veo fue hecho con el simulador livewire y en este simulador no coniene al integrado SG3526. utilizar un Dual IN line no es lo mismo que el propio CI.

mejor utiliza el multisim 10.
 
#23
hice un pequeño inversor cuando convierto de dc a ac puedo fijar un voltaje y una frecuencia elegida por mi pero el problema es que aplicando consumo el voltaje se atenúa la carga que aplico son bobillos de 100w el inversor pierde alrededor de 5v por bombillo por lo que veo el ancho de pulso no varia debidamente ¿como puedo arreglar la compensación? en este caso utilice censar el voltaje de los surtidores en la etapa de potencia para la compensación
 

Adjuntos

#24
hice un pequeño inversor cuando convierto de dc a ac puedo fijar un voltaje y una frecuencia elegida por mi pero el problema es que aplicando consumo el voltaje se atenúa la carga que aplico son bobillos de 100w el inversor pierde alrededor de 5v por bombillo por lo que veo el ancho de pulso no varia debidamente ¿como puedo arreglar la compensación? en este caso utilice censar el voltaje de los surtidores en la etapa de potencia para la compensación

yo te diria que leas un poco sobre como ingresar la realimentacion en un integrado de pwm, que es un amplificador de error, como funciona y para que esta, eso que hiciste (red de realimentacion) esta mal (muy).

1ro. la señal de realimentacion debe entrar por pata 2, no por la salida del amplificador de error, (la salida del amplificador de error entrega precisamente la señal de error, osea, la diferencia entre la referencia y la señal de muestra, para poder realimentar.

2do. estas tomando como señal de muestra la tension generada en el primario del trafo, y las caidas de tension en éste?, para poder compenzar correctamente deberias medir la salida.

3ro, la señal de muestra debe ser un valor continuo, con una componente alterna de frecuencia menor a la vigesima parte de la frecuencia de oscilacion del pwm, osea, si el pwm es de 50hz, lo que ingrese en la entrada del amplificador de error debe estar en el orden de 2.5hz o menos (en la practica debe ser mucho menor) con lo cual deberias saber como integrar la señal de realimentacion.

4to, cuando integras una señal de alterna, lo que obtenes es el valor promedio de dicha señal, no el valor eficaz, y este ultimo es el que interesa, y aca esta el dilema, porque por ej, en una señal senoidal (rectificada) el valor medio (Vm) ≈ Vp x 2/Π osea, 0.636V por cada volt de cresta, y el valor eficaz (Vrms) ≈ Vp /√2 osea, 0.707V por cada volt de pico, entonces la relacion de tension media y eficaz en una señal seno es siempre constante, independientemente de su amplitud

pero en una señal rectangular, o senoidal modificada, la cosa cambia.

por ejemplo, el valor medio de una señal rectangular (Vm) = Vp x Ton / T
pero el valor eficaz Vrms = Vp x √(Ton / T)

osea, el valor medio depende de una funcion lineal, y el eficaz de una funcion √ donde interviene la tension de cresta, pero tambien el tiempo de conduccion y la duracion del ciclo.

entonces, cuando hagas la integracion de la señal de realimentacion, deberias ver como obtener una tension continua que represente al valor eficaz mas que al valor medio.

busca info sobre conversores RMS-DC, como referencia busca sobre el integrado AD536
 
#26
sobre el integrado que me dices encontré mucha información sobre el funcionamiento http://www.fceia.unr.edu.ar/enica3/ad536.htm pero no entiendo mucho de como usarlo adecuadamente tampoco encuento un esquema para guiarme
por casualidad ya lo usaste ¿tienes algún esquema que me puedas enseñar ?

una pregunta se puede hacer con un opto-acoplador osea censar el voltaje de salida con un opto-acoplador?
 
Última edición:
#27
Estoy tratando de generar una señal PWM con el SG3526 usando la configuración Single-Ended dada en el manual del fabricante Figura 8 (http://www.ti.com/lit/ds/symlink/uc3526.pdf).

SG3526 Single-Ended.png

Pero el problema radica en que en el pin 14 obtengo una señal PWM pero con una amplitud de 400mV, según mediciones en el osciloscopio. Pero necesito un voltaje decente para pasarlo por una compuerta NOT, digamos 5V para el nivel alto, esto para formar dos señales PWM complementarias.

También armé el circuito adicional con el transistor y los dos resistores pero no funciona, no obtengo una señal PWM que varié entre OV (Low) y 5V o VCC=15V (High).

Sugerencias para solucionar este inconveniente.
 

Daniel Lopes

Miembro Geconocido
#28
Hola caro Don yorsk2004 ,premeramente lo transistor "Q1" debe sener un PNP y NO un NPN , cuanto a tener solamente 400mV de amplitud en lo pino 14 a mi mas parece que ese CI estas estropiado o es un trucho Chino , cosa desafortunadamente comun en los dias de hoy :( :( :(
Te recomendo chequear lo transistor "Q1" que tiene que sener PNP y tanbien lo CI si no estas estropiado o en realidad es falsificado.
Cuanto a los valores de los resistores "R1" y "R2" , eses deben sener de modo a saturar lo transistro "Q1" pero sin exceder los limites de curriente que lo pino 14 puede drenar. ;) :eek:
!Suerte , seguimos conectados !.
Att,
Daniel Lopes.
 
Última edición:

Daniel Lopes

Miembro Geconocido
#30
¿Cual debería ser la amplitud del voltaje que tendría que salir en teoría? En el Datasheet no dice nada acerca del modo Single-Ended. Gracias.
Debe sener de Vcc a cuasi cero , entre los pinos 14 y 13 o 16 hay un transistor NPN y ese transistor funciona como uma llave "on -off" .
En lo dibujo aportado los pinos 13 y 16 (emisores) son conectados a la tierra o masa y lo pino 14 (colector) es conectado a los resistores "R1" y "R2".
Con lo transistor interno al CI cortado la tensión en lo pino 14 debe sener de +Vcc y cuando saturado esa debe sener de unos 0,5Voltios (VCE de saturación).
En ese estado la tensión del colector del transistor "Q1" debe sener de +VCC una ves que ese ahora estas saturado (VCE Sat.) porque hay una circulación de curriente por "R1".
Att,
Daniel Lopes.
 
Última edición:

Daniel Lopes

Miembro Geconocido
#32
Te recomendo verificar si los resistores "R1" y "R2" estan de acuerdo con la maxima curriente que lo pino 14 puede drenar , chequear ese dato en la hoja de datos técnicos del CI en questón .
!Suerte !.
Att,
Daniel Lopes.
 
#33
Te recomendo verificar si los resistores "R1" y "R2" estan de acuerdo con la maxima curriente que lo pino 14 puede drenar , chequear ese dato en la hoja de datos técnicos del CI en questón .
!Suerte !.
Att,
Daniel Lopes.
En la hoja de datos técnicos dice que Imax (pino 14) es de 200mA.

Por lo tanto estoy colocando R1=100Ω (Limita la corriente a menos de 200mA) y R2=10kΩ (Pull-up).
 
Última edición:

Daniel Lopes

Miembro Geconocido
#34
En la hoja de datos técnicos dice que Imax (pino 14) es de 200mA.

Por lo tanto estoy colocando R1=100Ω (Limita la corriente a menos de 200mA) y R2=10kΩ (Pull-up).
Recordese que esa curriente es la misma de Base del transistor "Q1" (PNP) , asi hay que chequear si el transistor suporta esa curriente sin estropiar.;):cool:
Att,
Daniel Lopes.
 

Temas similares

Arriba