Problema con Pic en un vehiculo

#1
Hola compañeros, Muy buenas noches a todos, les escribo porque estoy medio mosqueado con un circuito muy simple que no logro estabilizar , el circuito esta realizado con un pic 16f84A con su circuito (su cristal y sus resistencias y demás para ponerlo en vida) y aparte me he creado un rectificador con condensadores en sus entrada de voltaje para evitar caídas y demás, tiene su 7805 y todo. ahora bien , este circuito se utiliza o se va a utilizar en un coche pero tengo un problema que no me saca bien , es que cuando voy a darle arranque al vehículo el circuito me empieza desde ''0'' , esto es por el motivo que el arranque tira por el hasta el punto que tira por la corriente que le llega al pic y por esto mismo lo resetea.

He realizado varias cosas, como otro rectificador superior al que tenia, también conectarlo a otras partes del vehículo y nada , también pensé en utilizar una batería pequeña para el pic pero no lo veo una opción primaria.

Me gustaría saber si a alguno de vosotros le ha pasado esto y ha solucionado el problema , porque el pic no se debe apagar cuando el vehículo arranque.

saludos y gracias ¡
 
#2
La mayoría de oos vehículos desconectan TODO en el arranque. Si necesitas que siga funcionando pon una pequeña batería o un condensador enorme
 
#3
El detalle es que la bateria de tu carro ya esta viejita jejejej

No se podra solucionar con algo asi.



Malvado Scooter me has ganado la respuesta jejeje
 

Adjuntos

#4
Hola Scooter gracias por tu respuesta, realmente es un jeep y lo de desconectar todo no lo hace automático, sino cuando tira el arranque , es tan fuerte el tirón que ''chupa'' por todo el tendido eléctrico, yo pensando ahora , antes de colocar un 7805 ¿si coloco un zener a 5v? lo digo porque el 7805 necesita para funcionar como minimo 7v y el zener da igual contar que no quede por debajo de 5v el pic deveria de seguir funcionando..... no se solo es teoria casera....

también un condensador con 2 co....nes seguro que no falla... tiene 1 de 200uf y después pequeños de poliester para rectificar pequeñas cosas...

salu2

El detalle es que la bateria de tu carro ya esta viejita jejejej

No se podra solucionar con algo asi.



Malvado Scooter me has ganado la respuesta jejeje
acabo de ver tu mensaje perdona ;) , la batería esta bien porque solamente tiene 2 años, lo que pasa que es un jeep con un gran arranque.... jeje

tengo armado el mismo circuito pero sin el inductor que presentas (o bobina)
 
Última edición:
#9
Díodo + condensador es una opción :unsure:

No me digas que meti la patota :cry:

Es que asi me pasaba en un circuitillo que tenia en el carro y cuando puse eso se soluciono, segun esto es un filtro pi lc no ponga la formula porque no hay editor de jejejeje, bueno el inductor es bueno para los picotes de corriente que se general al dar marcha!! o ya mejor me cierro la bocota hummm mejor dicho dejo en paz las manos :oops:


Son veloces con las manos!!!
 

DOSMETROS

High 2m Modereitor
#11
Claro el díodo es para que el capacitor no alimente hacia atrás (radio por ejemplo), y fijate de hacerle esa alimentación solamente para el Pic ;)

Podes usar además el zener (y)

Ajna , no había visto tu dibujo :rolleyes:
 
Última edición:
#12
Ajna el circuito que has puesto anteriormente es el correcto, pero algo me quede corto, el condensador o algo...

Claro el díodo es para que el capacitor no alimente hacia atrás (radio por ejemplo), y fijate de hacerle esa alimentación solamente para el Pic ;)

Podes usar además el zener (y)
vale bien , pero que es mejor el zener o el 7805 ?


saludos chicos ¡
 
#14
Que se yo , habría que probar cual consume menos (por el capacitor) :unsure:

me apuesto una comida que el zener consume menos,, y mas para un pic que maneja un diodo solo.... si señores ,,, un diodo XD pero este diodo tiene que marcarme sin reiniciar el pic en todo momento. ;)



chicos os dejo me voy al sobre, mañana os cuento si pruebo el circuito , un saludo chicos y gracias por todo ¡¡
 
Última edición:
#15
Me queda re lejos españa si no pues si te apostaba la comida a !Que quien sabe¡ Por cierto si puso la tipica de 10K del pin RST a VCC, luego muchos la omiten para ahorrar ya que de entrada traen una interna que hace lo mismo, pero es tan debil que apenas tocas RST y rajale se resetean
 
#16
hola chicos, he realizado el circuito y he puesto el diodo y un condensador de mil microfaradios y despues un 7805, en la practica con la fuente de alimentacion iva de perlas, pero en el coche en el primer arranque el 7805 algo le paso y el pic se fastidio porque le salio humillo.

lo he sacado y mirado y el 7805 no responde y el pic tampoco, he mirado todo y todo ok, ustedes creen que por falta de la bobina que esta en el circuito expuesto aqui tenga algo que ver en esto, o es porque el 7805 vino mal?

saludos chicos.
 
#17
hola chicos, he realizado el circuito y he puesto el diodo y un condensador de mil microfaradios y despues un 7805, en la practica con la fuente de alimentacion iva de perlas, pero en el coche en el primer arranque el 7805 algo le paso y el pic se fastidio porque le salio humillo.

lo he sacado y mirado y el 7805 no responde y el pic tampoco, he mirado todo y todo ok, ustedes creen que por falta de la bobina que esta en el circuito expuesto aqui tenga algo que ver en esto, o es porque el 7805 vino mal?

saludos chicos.
quita el 7805 y coloca un cargador de celular que de 5V
es mas eficiente y calienta menos
 
#18
Y como le hacemos para obtener 127V de la bateria, eso estaria mas complicado analogico.

Talves deberias poner el diagrama de tu circuito
 
#20
:cabezon: Haaa pues eso si :LOL:

Aunque la verdad estaria incomodo traerlo pegado en el encendedor, talves desarmado y conectado de forma que no se vea, por cierto la mayoria de esos cargadores que he destapado traen el IC MC34063
 
Arriba