Problema con Pic en un vehiculo

#21
Yo hace un tiempo le cambié el intermitente de mi coche por uno electrónico a base de un PIC10F204, y después de comprobar que en el banco de pruebas el circuito funcionaba bien, al instalarlo en el coche se me presentaron 2 problemas.

Cuando bien ponía las luces de emergencia, o bien en el arranque del coche, o cuando accionaba los elevalunas o los limpiaparabrisas (mientras el intermitente estaba activo, el circuito se "colgaba") y se quedaban encendidas fijas las luces intermitentes.

El problema de las luces de emergencia lo solucioné vía diodo 1N4001 + condensador 1000uF/16V, de esa forma la alimentación del micro no se desconectaba momentaneamente al accionar el conmutador de emergencia (cambia de alimentación directa, a alimentación controlada por el contacto, ya que las luces de emergencia tienen que poder activarse sin las llaves puestas).

El problema del cuelque al accionar motores, lo solucioné forrando con cinta adhesiva de papel de aluminio la cajita de plástico donde quité el antiguo relé y puse la circuitería electrónica, de modo que le construí una caja de faraday para inmunizarlo frente a parásitos externos.

PD: si hubiera usado un 12F629 en lugar de un 10F204, habría usado el watchdog por hardware para resetear el pic y así no me dejaría tirado el intermitente en caso de cuelgue por POR u otro tipo.
 
#22
Concluyo que los PIC son muy sensibles entonces. Con los avr no he tenido esos problemas tan graves.
 
#23
hola a mi me paso y le puse un cap electrolitico de 10v 4700uf a los 5v no en la entrada de el 7805 para que mantenga el pic se puede mejorar. no me hizo falta modificar mas nada.
 
Arriba