Problema con programador ezpic! (un desafio)

Vengo en busca de ayuda, pues tengo un problema bastante interesante.

el programador que arme es un ezpic programmer les dejo el link

http://www.kmitl.ac.th/~kswichit /ezpic/index.html

intente para empezar probar grabando un 16f84a usando el ic-prog, pero me sale el tipico error de verificación de la posición 0000h.

ahora los detalles:

- revise mi puerto serial. funciona correctamente
- revise mi cable serial. funciona correctamente. quisiera poder conectar el grabador directamente, pero no da porque el conector de video esta justo a lado y se hace imposible.
- tengo configurado el ic-prog con jdm programmer, y el puerto com 1. verifique que ese sea conectando un mouse serial.
- ya probe con 2 chips y nada
- esta desactivada la protección de codigo, CP.
- intente tambien usar el winpic800 pero el mismo resultado, no es capaz de grabar por eso falla la verificación ya que solo lee del pic 3FFF (osea blanco como saben)
- es mas, con winpic me sale dispositivo desconocido. pero si es capaz de leerlo y borrarlo.
- estoy usando una pc de escritorio, nada de laptops.
- utilice el ic-prog para medir la tensión en el pin 1 (MCLR) y tierra, y obtuve 13v. eso debería ser suficiente. para probar active la casilla del MCLR, y se prendió el LED tranquilamente.
- cada vez que leo, borro o grabo se enciende e LED lo cual me hace dudar sobre el origen del problema

una duda con el winpic, a parte de elegir JDM y el puerto com1, existe alguna otra modificacion en su configuración? con respecto Vpp o Vdd? es lo ultimo que se me ocurre

ya no tengo mas ideas! ya no se donde puede estar el problema, estaba ilusionado con este programador porque lo hice con zócalo y todo, pero nada.

ya estoy pensando conseguirme un pickkit 2 clone, pero uno que tenga zif y listo, aunque ahi mi problema seria el firmware porque no tendria como programarlo.

que ideas tienen? donde puede estar el problema?? ayuda por favor! gracias :)
 
Tinvicemp06

Espero que no hayas dañado tus Pic16F84A dado que el pin #1 del mismo no corresponde al ingreso del MCLR, te adjunto una imagen donde apreciaras que conexiónes debes realizar para el Pic16F84A.

Saludos. JuanKa.-
 

Adjuntos

  • Conexiones16F84a.jpg
    Conexiones16F84a.jpg
    16.4 KB · Visitas: 7
Tinvicemp06

Te reitero, la tensión de VPP aproximadamente 13 Volt's debe ingresar al pin #4 del Pic16F84A. Si no es asi, el microcontrolador no entrara en modo de programación.

Yo verificaria que en la posición que debo colocar el microcontrolador y en donde iria el pin #4 del mismo tenga 13 Volt's con respecto a donde iria el pin #5 al momento del Hardware Check.

También verificaria que tuviese los +5Volt's de VDD en donde iria el pin #14 con respecto a donde iria el pin #5 al momento del Hardware Check u obligando a que el IcProg me genere la misma tensión. Recuerda que el resto de los 17 pines del Pic16F84A no estan pensados para recibir tensiones superiores a +0,5 V + V de VDD.

Saludos. JuanKa.-

Post Editado: Ese programador no deja de ser una de las tantas variantes del JDM. Muchas PC's modernas con los puertos Serie integrados en la MotherBoard, sobre todo las Notebooks y Netbooks suelen tener problemas para programar algunos microcontroladores. Me ha pasado a mi con otro parecido hace unos 15 días y lo solucione usando el Programador II de la pagina de Pablin.
 
Última edición:
Arriba