Problema de RESET en un flip-flop

#1
Hola. Tengo un problema con un circuito (ver esquema). Se trata de una alarma, representada por un diodo LED, que se activa al cierre de un interruptor (SW1) y que queda activa aunque el interruptor se abra, es decir, que la alarma sólo se desactiva tras el reseteo por un pulsador que la vuelve a armar.

Para ello he utilizado un flip flop 74LS109, con activación en flanco de subida (al cerrar el SW1 conectándolo a 5V) y quedando enclavado hasta el reset ( puesta a masa de pines 1 y 15 del integrado).

Hasta ahí bien, lo he montado en la proto y ocurre que al conectar los 5V y cerrar el SW1 unas veces me luce el LED y otras no, y cuando no lo hace basta con pulsar RESET y todo va bien. Deduzco que al iniciar, el pin 4 (entrada del clock) unas veces está en estado alto, y no detecta el flanco de subida al cerrar el SW1, y otras en bajo y es cuando lo detecta funcionando correctamente. O sea, creo que la solución sería poner un RESET automático al conectar el circuito para que el reloj del JK siempre salga de un estado de "bajo" y pueda detectar el flanco de subida.

Si estoy en lo cierto, pido ayuda porque no sé hacer este AUTORESET inicial, y si no también para que me explique alguien lo que pasa.
(Y si ven algún otro disparate en el circuito, por favor, me lo comuniquen también).


Muchas gracias.
 

Adjuntos

#2
Buenas noches.

La Resistencia de 330Ω (R1) ponla de 10KΩ

En paralelo con el Pulsador de Reset pon un Condensador Electrolítico de 10µF.

Con estas dos cosas, seguramente la cosa mejore.

Sal U2
 
#4
Muchas gracias Miguelus.
Probado y resuelto. Funciona.

Saludos.

Me lo temía :)...

Ahora solo queda poner un Diodo tipo 1N4148 en paralelo con la Resistencia de 10K (R1)

El Cátodo lo conectas a VCC y el Ánodo al punto de unión de la Resistencia con el Condensador Electrolítico.

La misión de este Diodo es descargar el condensador cuando se desconecta la alimentación.

Sal U2
 

Temas similares

Arriba