Programador de microcontroladores PIC y memorias por puerto USB PICKIT2 CLONE

Hola me pueden ayudar?

mi problema es el siguiente
Implemente el PicKit2 Clon segun los esquemas y firmware que aparece en el primer post
cargue el firmware usando un PicKit2 original sin ningun problema, y he revisado y el firmware se encuentra grabado en el PIC ok.
Cuando conecto el cable USB en el PC no me aparece nada solamente enciende un led que en este caso es de color verde
habro el software del pickit2 v.2,50 y no reconoce que el clon este conectado
trate de actualizar el firmware usando MPLAB pero al entrar en <pogramer><select programer> la opcion 7 en donde sale Pickit2 aparece en gris y no se como habilitarla
cuando conecto el PicKit2 original en MPLAB, tampoco me permite habilitar esta opcion como para poder revisar y actualizar el firmware con el pickit original
que estara pasando?
el software que trae el pickit2 v2.50 deberia reconocerme el Clon?

hay algun otro firmware para el clon o alguna variacion? yo descarge e implemente un rar que se llama pickit2_moyapic_version_153.rar

y la verdad es que he estado leyendo todos los post desde el primero, pero aun voy en la 5 pagina

les agradesco su ayuda de antemano
 
Última edición:
Okuart

El archivo "ESQUEMA.pdf" que encontraste dentro del "pickit2_moyapic_version_153.rar" tiene un error a pesar de las correcciones que se le habian realizado.

El error en cuestión es:

El pin 15 (#15) del PIC18F2550 corresponde a la señal "D-" y no D+ como esta indicada en ese archivo.

El pin 16 (#16) del PIC18F2550 corresponde a la señal "D+" y no D- como esta indicada en ese archivo.

Resumiendo, si has conectado tal cual el Esquema ese, solo debes invertir las conexiones de ambos pines.

Controla bien lo que has conectado y si ese es el problema, cambialo y proba. Ese punto fue comentado en algun lugar de este extenso thread.

Apenas tenga un tiempo disponible subire las fotos de mi PicKit2-Clone y del ZIF.

Saludos. JuanKa.-
 
Okuart, si aún así como dijo J2C persiste tu problema:

El soft debería dar con cualquier versión de firmware, y de la misma manera el clon debería ser reconocido con tu sistema con cualquier firmware que éste tenga.

Me parece que tienes un problema en tu hardware, seguramente algún corto circuito por algún lado, si lo tienes en placa algún componente mal soldado o si lo tienes armado en proto alguna mala conexión.

Revisa tu hardware, por ahí el cristal puede estar malo o el condensador de 470nf, aunque estos componentes generalmente no fallan.

saludos.
 
Última edición:
Gracias J2C y gracias Cryn por sus respuestas

En un pricipio tenia un error con el USB y la cosa no funcionaba pero lo resolvi haciendolo con un cable directamente.
Habia armado con un USB mini de 5 pines y ahi tenia un error, luego lo reemplace por un cable USB cortado con los pines 15 D- blanco y 16 D+ verde y ahi voy. solamente me enciende el LED Verde, esta grabado firmware y el software original del pickit no lo reconoce.

tengo algunas otras observaciones

en la lista de materiales que hay en un archivo .txt el orden de los materiales no es el mismo que aparecen los componentes el el diagrama que esta en pdf

el el pcb aparecen tres componentes que estan conectados entre Vcc y GND, en el diagrama solo encontre dos condensadores, uno de 100n y uno de 100u o tal vez sea una extension de Vcc y GND ... en el PCB estan bajo el SW NA

pero me aclaran mi duda perfectamente, voy a revisar si hay algun error aun que ya lo revise, el PCB no es compatible con el software que tengo yo asi que lo dibuje denuevo.
para eso use uno que se llama ExpressPCB usando como referencia el digrama.pdf y no el pcb.pdf

entonces con el firmware que esta en el paquete deberia funcionar! si ?

se les agradece su respuesta y me voy a revisar

okuart
 
okuart yo tambien hice el pcb, con express pcb, se me hace mas facil :LOL:, podrias subir tu pcb, sobre los capacitores, le ayuda a la alimentacion tener esos 2 o 3 capacitores, con 2 basta, y los capacitores debajo de sw es para ayudar a quitar los rebotes producidos por el boton cuando se presiona, y si debería funcionar con cualquier version de firmware
saludos
 
vdfe
hice el pcb para componentes de superficie
intentare subir el archivo para expressPCB y el pfd para que lo puedan ver todos
la resistencia R11 que aparece, no la encontre como componente de superficie cuando compre los materiales asi que use una de 1/8 W y una de las patas la use como puente
ahora seguire revisando para ver si puedo solucionar el problema
les cuento
saludos
okuart

otra consulta, alguien me puede ayudar?
sucede que para actualizar el firmware del pickit2 hay que usar el programa MPLAB
en las opciones <Programer> <Select Programer> <7 Pickit2>
no me aparece la opcion 7 del pickit2
Estoy usando un pickit original e intento ver el firmware del clon
como puedo hacer para que esta opcion me aparesca habilitada en MPLAB ??
se agradece de antemano

okuart
 

Adjuntos

Última edición:
Buenas, gracias a todos por este gran aporte y especialmente a blessed por que arme su grabador y salio andando en el primer intento.

Gracias!!!!!!!!!!!!!!!!!! ya no tengo que lidiar mas con computadores viejos y sus puertos, ahora con este grabador por usb me conecto a cualquier maquina y listo.

Aca les dejo unas imajenes de como quedo, una joyita no?
PD:ahora que veo las fotos me di cuenta de que me falto pegarle el stiker de la ubicacion de los micros!!!
 

Adjuntos

Última edición:
yo tambien dije eso de ya no usar los computadores antiguos con puerto serial... pero de veras::
a veces se me desconfigura el pic quemador de mi eclipse y debo regrebarlo con un serial ,, aveces tambien mi eclipse no quema a otros chip eclipse osea si los programa pero no logra quemar en un tercer pic osea no se me autoreproducen ,, debo usar el puerto serial para programar un pic programador ,, quisiera saber si a alguien le paso lo mismo con el pickit2 para mudarme graciass
 
HOla arme el circuito PICkit 2 clone, una ves que lo arme me lo detecto la compu, y todo bien pero al principio me marcaba el siguiente error:

VPP Voltage error. Check target and retry operation

Y a veces me dejaba leer el contenido del micro que queria grabar, y en el MPLAB me salia el siguiente error

PK2Error0049: VPP Voltage error.

Alguien sabe a que se debe, arme el circuito tal cual, ademas de que de la nada dejo de detectarlo la compu ya esta como muerto, ayuda porfavor!!!!!!!!!!!!!!!!!!!!!!!
 
No se preocupen por los puertos series y/o paralelos. Con el tiempo aparecerán más y más grabadores de todo tipo para grabar PIC de USB.

Felicidades que funcinara muy bien, el de las fotos quedó como un profesional con caja incluida.
 
bienas, para que sirve el interruptor y que indican los leds?
sirve para actualizar el firmware (si no me equivoco) y para detener el proceso cuando está en el modo de analizador lógico, también para programming-to-go, que hace uso de las memorias eeprom del circuito original, para grabar sin PC. Que este clone no dispone.

HOla arme el circuito PICkit 2 clone, una ves que lo arme me lo detecto la compu, y todo bien pero al principio me marcaba el siguiente error:

VPP Voltage error. Check target and retry operation

Y a veces me dejaba leer el contenido del micro que queria grabar, y en el MPLAB me salia el siguiente error

PK2Error0049: VPP Voltage error.

Alguien sabe a que se debe, arme el circuito tal cual, ademas de que de la nada dejo de detectarlo la compu ya esta como muerto, ayuda porfavor!!!!!!!!!!!!!!!!!!!!!!!
Para mi que es algún problema de hardware, algún corto circuito involuntario o una falsa conexión, revisa tu hardware.
 
Última edición:
hola soy seguidor del post ya que me parece interesante; por fin me decidi a hacerme este gran programador y cuando ya tengo acabao el programador en una placa microperforada, no me lo reconoce el ordendador; para que me lo reconozca necestia tener algun pic para leerlo.
¿quiero decir tiene que haber algun pic conectao en el zocalo o no?