Regulador de temperatura con secador y plaCa Peltier

Buenos dias.

Para un trabajo en la universidad, hemos diseñado un circuito que con la ayuda de un secador de pelo y una plaza peltier, regula la temperatura de un sensor de temperatura con una placa Netduino.

Estaba realizando pruebas para afinar el funcionamiento del software, y resulta que de forma aleatoria cuando se debe activar el secador (a través de un relé) se activa el relé pero el secador no funciona y pierdo conexión con el ordenador (Teniendo que reiniciar la ejecución del programa).

Queda destacar que en general el circuito funciona correctamente, pero hay veces que ocurre lo comentado anteriormente.

Sería de gran ayuda que pudieran decirme alguna causa que se les ocurra de que esto suceda.

Gracias por su tiempo, como se puede observar no tengo muchos conocimientos de electrónica
Tanto el secador como la placa Peltier se activan a raves de un relé (Un relé para cada uno). La placa Peltier esta conectada una fuente de alimentación conectada a la corriente eléctrica doméstica y el secador conectada directamente a la corriente eléctrica doméstica
 

Fogonazo

"Qualified exorcist approved by the Vatican"
¿ Que es una "Plaza" Peltier ?

Casi con seguridad el problema es el pico de inducción/consumo del relee sobre la alimentación, seguramente compartida por el Netduino

Consulta en el Foro por problemas similares y como se solucionaron.
 
Para
¿ Que es una "Plaza" Peltier ?

Casi con seguridad el problema es el pico de inducción/consumo del relee sobre la alimentación, seguramente compartida por el Netduino

Consulta en el Foro por problemas similares y como se solucionaron.
Error al escribir quise poner Placa.

Muchas gracias, buscaré información acerca de ello
Apuesto lo que sea que está el código plagado de delays
Adjunto foto del código.

El código que estoy usando para hacer ensayos del funcionamiento tiene un único delay de 1 segundo, crees que ese puede ser el problema

1639749308187.png
 
Arriba