Reparar y mejorar inversor chino 12VDC / 230VAC - 500W Onda Pura Senoidal

Hola, he vuelto a retomar el tema del inversor Reparar y mejorar inversor chino 12VDC / 230VAC - 500W Onda Pura Senoidal

Este lleva un EGS002 que incorpora 2 IR2110S, ahora que estoy entendiendo como funciona la parte alta HO (la que siempre me ha dado problemas), sospecho que los diodos bootstrap que traen no son muy grande y por eso termine cargandome el IR2110S y los Mosfet/IGBT que estoy probando ahora.

¿Que alternativa más solida hay a usar diodos bootstrap? He visto gente que esta usando optoacopladores TLP250 pero aun no he visto como gestionan la parte alta HO

Los que trae el modulo EGS002 son de 10 uF ¿no es mucho y sobrado para que me diera problemas la parte alta por ese motivo?

Gracias
 
Yo me refiero para alimentar la parte entre VS y VB del IR2110.

Ahora lo que no tengo claro es por que se queman los mosfet en la parte HO, si el condensador del bootstrap no tiene la suficiente capacidad y se vacía, ¿que es lo que pasa? ¿Aparecen tensiones negativas en HO que superan los -20V y por el GATE mueren los mosfet?
 
He retomado este inversor y he conseguido que funcione de nuevo, tenia una mala conexión en la linea VS2 del EGS002 que me lo quemaba instantáneamente junto a los mosfet.

La parte primaria que eleva de 12V a 400V nunca ha fallado, pero la manejada por el EGS002 me parece tan poco robusta... originalmente llevaba los mosfet K15A50D en el SPWM del EGS002, estaba probado con los IGBT FGH60N60SMD-D y notaba un incremento de consumo con la fuente regulable de 0,600 A a 2A al subir la tensión de 12V a ~13V en el secundario 350~ a 385~.

No se por que estos IGBT y otros mosfet TO−247 me pasa esto, de parecer no admitir más de 350V pero son de 600V, he vuelto a probar los K15A50D y no tienen problema puedo subir a más de 14V (en el secundario 400~420) sin incrementar los 0,600A.

Mi idea es poner unos mosfet/IGBT más robustos en la salida ¿En que parámetro del datasheet me tengo que fijar para que esto no ocurra?

Gracias
 
Añado imágenes ya que se perdieron:

SAM_1045.JPG
Esto con los IGBT que me consumen en exceso cuando el voltaje aumenta de ~350V en el DC

SAM_1046.JPG
Aquí modelo de los que traía, sin problema de sobre-consumo en vacío al subir a ~420V en DC

SAM_1048.JPG
SAM_1049.JPG
Esto ocurre al ponerle el soldador de control electrónico JVC blanco, con el soldador amarillo también, con control electrónico no da problemas
2º Foto al conectarlo al revés

SAM_1051.JPG
SAM_1052.JPG
Tanto en vacío como con carga de un ventilador de 45W no hay problemas la onda perfecta, sin ruidos raros en el motor

SAM_1054.JPG
SAM_1058.JPG
Los soldadores de pruebas y los mosfet/IGBT

No se por que ocurre eso con el soldador siendo una carga relativamente muy pequeña.
Me sigo preguntando por que no puedo sustituir los mosfet que traía por otros más potentes sin que me consuma en vacío, también modifiqué el "dead time" del EGS002 de 300nS a 1,5uS, no he apreciado ninguna diferencia en nada incluso con los IGBT y su consumo en vacío.

Y para construir un inversor lo más robusto posible que no se me quemen los mosfet por sobretensión, que supongo que es lo que me ha pasado al conectar y desconectar cargas inductiva de forma fortuita, ¿Es mejor uno donde el EGS002 controle baja tensión y usemos un trasformador toroidal grande para elevar a 230VAC?

Gracias
 
La parte primaria que eleva de 12V a 400V nunca ha fallado, pero la manejada por el EGS002 me parece tan poco robusta... originalmente llevaba los mosfet K15A50D en el SPWM del EGS002, estaba probado con los IGBT FGH60N60SMD-D y notaba un incremento de consumo con la fuente regulable de 0,600 A a 2A al subir la tensión de 12V a ~13V en el secundario 350~ a 385~.

No se por que estos IGBT y otros mosfet TO−247 me pasa esto, de parecer no admitir más de 350V pero son de 600V, he vuelto a probar los K15A50D y no tienen problema puedo subir a más de 14V (en el secundario 400~420) sin incrementar los 0,600A.
El problema de esto parece que he encontrado la solución, para alimentar la placa EGS002 se usan 2 reguladores de 12V y 5V, el de 12V siempre que me reventaba algo se iba (le he puesto un diodo para evitar quemarlo al meterle un pico inverso de 400V y un zener para sacar 14V y por ahora aguanta ;)) y entonces pasaban entre 28 a 32~ VDC a los driver y los GATE de los Mosfet/IGBT siendo estos de +-20V y los K15A50D de +-30V, así que creo que ese era el sobreconsumo que ahora no me esta haciendo.

Tambien he encontrado esto 78.54C$ 19% de DESCUENTO|SUNYIMA Placa de inversor de onda sinusoidal modificada, 2000W, Kits Diy con disipadores de calor DC380V/AC16V a AC220V|sine wave|pure sine wavepure sine - AliExpress que he pedido, que parece tener un buen filtrado del PWM y para investigarlo
 
Bueno he seguido investigando, y parece que lo mas importante para que sea estable con los dimmer es el filtro de salida, sobre todo la bobina, el condensador de 2,2uF que trae coincide con casi todos los kits que venden y parece ser adecuado.

Traía este de 4,3 mH y parece que se satura enseguida y suena cuando se le pone un dimmer:

SAM_1067.JPG

Me he hecho este con una ferrita toroidal que tenia también consiguiendo 4,3 mH y con este consume algo más en vacío como 300mA pasando de 700mA a 1A en el primario a 12V y funciona mucho mejor, funciona el dimmer y el soldador electrónico aunque no al 100% a veces en algún punto suena y falla la onda
SAM_1068.JPG

Me he dado cuenta que hay diferentes tipos de ferritas, al parece una especifica para crear este tipo de filtro SPWM con alta permeabilidad:
Hf63c3e2662ca4c63acd070cc284e358f0.jpg

Anillo magnético de ferrosilicono-aluminio MS-225125-2 57,2*35,6*14,0 permeabilidad: 125

Inversor de onda sinusoidal, núcleo SENDUST​

Al parecer suelen estar pintadas de azul o negro, por eso supongo que la bobina original viene de azul.

He probado también con el carrete de hilo de cobre restante al aire me da unos 10 mH y támbien funciona muy bien incluso consume menos que con la ferrita que he hecho y como esta al aire supongo que es muy dificil de saturar.



¿Alguien sabe de esta ferrita especifica para SPWM? y sí como los filtros de altavoces pasivo que recomiendan hacerlos al aire ¿es posible hacer este filtro también al aire o es mejor que lleve su núcleo especifico de ferrosilicono-aluminio?

PD: Sigo esperando recibir el kit que compré
 
Última edición:
... IGBT FGH60N60SMD-D y notaba un incremento de consumo con la fuente regulable de 0,600 A a 2A al subir la tensión de 12V a ~13V en el secundario 350~ a 385~.

No se por que estos IGBT y otros mosfet TO−247 me pasa esto, de parecer no admitir más de 350V pero son de 600V, he vuelto a probar los K15A50D y no tienen problema puedo subir a más de 14V (en el secundario 400~420) sin incrementar los 0,600A.
Explicación:

 
Arriba