Señales a control de Xbox one con Arduino

Buenas a toda la comunidad, soy un poco nuevo en el mundo de la electrónica y recién aprendo Arduino y fundamentos de electrónica. Tuve la idea de abrir un control de Xbox one y mandarle pulsos para que cada cierto tiempo se active el botón "A" sin necesidad de apretar el botón. Soldé un cable a un punto de la pista del botón A. Le mandé pulsos con Arduino. Mi intención es que cada 2 segundos o 4, etc, se active el botón, en la programación le pongo un High o Low y su respectivo delay, sin embargo me encuentro con que el control de plano no respeta la señal, con el simple hecho de conectarlo a voltaje, sin importar que sea alto o a bajo, al Arduino o no, este se activa simplemente. Disculpen, pero recién aprendo, espero puedan ayudarme. Saludos!!!
 
Ojo con la diferencias de tensiones, el Arduino mayormente trabajan con 5V, otros con 3,3V.
El mando no tengo ni idea del voltaje, pero puede que no sea precisamente 5V.
Aparte habria que ver si el boton va referenciado a masa, o es multiplexado.
Mejor sube fotos claras, nitidas y bien iluminadas del mando, y de todo como lo tienes conectado. Aparte del codigo del Arduino.
Lee aca como hacerlo;

 
Ojo con la diferencias de tensiones, el Arduino mayormente trabajan con 5V, otros con 3,3V.
El mando no tengo ni idea del voltaje, pero puede que no sea precisamente 5V.
Aparte habria que ver si el boton va referenciado a masa, o es multiplexado.
Mejor sube fotos claras, nitidas y bien iluminadas del mando, y de todo como lo tienes conectado. Aparte del codigo del Arduino.
Lee aca como hacerlo;
https://www.forosdeelectronica.com/threads/tuto-¿cómo-subir-archivos-xenforo.157730/
http://www.acidmods.com/forum/index.php/topic,43981.0.html. Mira aquí fue donde revisé las conexiones, use las TP21 que son las conexiones al botón A y a GND.
 
¿Pero estas seguro de que los botones van a GND o van a VCC o lo más normal, van en una matriz en la que no hay ni VCC ni GND?

Si es como tú dices, es sencillo. Una mala conexión.
Si es otra cosa, tendrás que investigar un poco más.
A lo mejor necesitas un relé o un switch analógico tipo 4060 (si no me he equivocado de referencia)
 
Me parece que usa 3,3V, mira que tu arduino trabaje con ese voltaje, de lo contrario la vas a liar.
Tiene conexion I2C, porque no miras por ahi?
 
Arriba