Sensor de temperatura con LM35

No se que tan dificil sea alla pero aca es complicado encontrar resistencias del 1%, es mas facil y barato usar un 358 o 324.
 
Un LM358 es utilizado para audio como amplificador de potencia para salida directa a parlante, con la configuracion que propones del LM35 trabajas con muy baja tension lo cual es un problema a la hora de discriminarla
Si no me equivoco el LM358 es operacional... creo que tu te refieres al LM386

Cierto que para medir temperaturas de 100ºC pues necesitariamos unas tensiones de alimentacion altas, pero para temperaturas de hasta 40ºC creo que con 9V es suficiente, y si lo alimentas con 12V perfecto.

No se que tan dificil sea alla pero aca es complicado encontrar resistencias del 1%, es mas facil y barato usar un 358 o 324.
Por otra parte, creo que con resistencias de 5% tambien funcionaria, quiza perderiamos algo de precision? La cuestion es que, como tenemos un trimmer se puede ajustar el voltaje de salida para la temperatura dada; asi que, si tienes otro LM35 (o otro medidor) y lo calibras con este, pues ya esta...

Es que tambien hay que tener en cuenta que si amplificas la señal de temperatura del LM35 con un operacional tambien tienes un error dependiendo sobre todo del offset del operacional y cuanto amplifiques dicha señal.
 
Es que tambien hay que tener en cuenta que si amplificas la señal de temperatura del LM35 con un operacional tambien tienes un error dependiendo sobre todo del offset del operacional y cuanto amplifiques dicha señal.
a eso yo no le veo mucho problema, quizas lo veria si necesitara un display de la temperatura, pero solo sirve para tomar un punto de referencia, es decir si ajustando el potenciometro que dispare a los 28º reales y el sensor indica que son 30º pues no importa, importaria si tuviera un dispaly que indicara 30º y en realidad fueran 28º.

Honestamente yo no le veo problema al circuito que puse, quizas solo reajustar las resistencias de amplificador no inversor si es necesario y de las histeresis para alimentarlo con 12V, en lugar de 15V, que es mas comun, o en su defecto el voltaje que se necesite.
 
Última edición:
Bueno, no se, solo lo propuse como otra solucion, nunca dije que lo que pusiste anteriormente tuviera ningun problema. Y efectivamente algunos errores se pueden corregir calibrandolos.

Esto que puse lo saque del datasheet, lo vi y me parecio muy ineresante, el sistema es muy parecido a lo que usa un LM317 para ajustar el voltaje, solo que aqui ese voltaje ademas varia con la temperatura.

Aplicandolo en tu circuito, creo que serviria como el sustituto de U2A
 
Esto que puse lo saque del datasheet, lo vi y me parecio muy ineresante, el sistema es muy parecido a lo que usa un LM317 para ajustar el voltaje, solo que aqui ese voltaje ademas varia con la temperatura.
La verdad es que si esta interesante, me gusto como para usarlo con un microcontrolador sin amplificador. algun dia lo probare a ver que tal.

con respecto al circuito que puse (que no lo hice yo), como que no le veo caso sustituirlo puesto que si utiliza un LM358(quitando el seguidor), le sobraria un amplificador mejor usarlo no?, o si es un 324 le sobrarian Dos amplificadores. digo solo por practicidad usarlos si ya estan XD. si hicieran falta para otra cosa estoy totalmente deacuerdo en intentarlo.
 
Última edición:
Apaa... No me conecto un día y ¡Bummmm!

Ahora me volvieron más loco. ¿Qué hago entonces?, que recomiendan, hay algunas cosas que no entiendo de lo que hablan, como la histeresis (Por lo que he entendido, es una retroalimentación.. ¿con qué fin?, no lo se aun).

Pero en fin... ¿Qué me recomiendan?, tengo este circuito:

http://www.pablin.com.ar/electron/circuito/varios/cooler/index.htm

Me gusto, y más o menos lo entiendo, solo el MOSFET creo que es el ícono rojo... un quilombo!

Saludos y gracias por las respuestas! :D
 
Ahora me volvieron más loco. ¿Qué hago entonces?, que recomiendan,
:unsure: pues yo ya te recomende un circuito facil que parece que funciona, o que comiences con proyectos mas sencillos.

como la histeresis
la histeresis, en pocas palabras es que fijas dos voltajes, por decirlo asi en un rango de 5V, fijas 3.5V y 2,5.

cuando vayas incrementando el voltaje de comparacion se activara a los 3.5V, pero al decrementarlo no se desactivara a los 3.49V sino que hasta que llegue a los 2.5V. (esto es un ejemplo)

si no tuviera esa histeresis, que es como un rango de operacion, y fuera fijo en la activacion de 3.5V cuando cambie a 3.49V se desactivaria y cuando suba a 3.5V se activaria, y si vuelve a bajar a 3.49 se desactiva, lo que produce que el rele se active y desactive vibrando, como si prendieras y apagaras una luz rapidamente, produciendo una oscilacion indeseable.

el circuito que pones tiene dos comparadores con histeresis, si consigues ese integrado te puede servir igual.
Dibujo.JPG

en el diagrama interno del integrado que pusiste el simbolito que esta en el circulo rojo en el operacional que esta como comparador indica que tiene histeresis que tambien se llama bascula schmitt trigger (o algo asi)

segun la ficha tecnica tiene una histeresis de 5ºC lo que quiere decir mas o menos que si fijas la temperatura a que active a unos 28º, se desactivara hasta que baje a los 23º si no me equivoco.
 
Última edición:
Ahora que me doy cuenta, no puedo usar el LM56. La aplicación es para un acuario, y necesito un sensor tipo el LM36, que lo puedo cablear, aislarlo y dejarlo en el agua, no como un integrado.
 
Características principales del LM358:
- Funciona con fuente simple y con fuente partida (3V a 32V - ±1,5V a ±16V)
- Posee buena calidad vs costo
- Fácil de conseguir
- Bajo offset para muchas aplicaciones
- Gran rechazo al modo común
- Compenzado internamente en frecuencia y temperatura
- Bajo consumo
 
Hola! Soy nuevo por aquí.

He estado leyendo temas de este mismo foro y no he encontrado lo que busco, lo más parecido ha sido esto pero no es lo que necesito. El caso es que en la universidad para aprobar una asignatura nos han dicho que tenemos que hacer un circuito que mida temperatura corporal con LM331, un optoacoplador, una protoboard y lo que queramos.

Así que se nos ha ocurrido usar un LM35 (aunque estamos usando un LM34 para las pruebas) que nos devolvería un valor de 0,35 V para una temperatura de 35 V y conectarlo a un LM331 para cambiar de tensión a frecuencia, un optoacoplador, un LM331 para cambiar de frecuencia a tensión y por último un amplificador para compensar las pérdidas y multiplicar por 10 el valor de la tensión, de tal forma que con 35 grados obtendrías 3,5 V, cerraríamos el circuito con una resistencia y usaríamos un voltímetro como un "display". El problema es que no funciona, hemos aislado el sensor y no cambia siquiera de tensión al cambiar la temperatura.

Ruego cualquier tipo de ayuda o consejo, dejo aquí el circuito que hemos montado.

Muchas gracias!
 

Adjuntos

Porque necesitan convertir tensión a frecuencia? y viceversa?
Porque nos obliga el profesor, para añadirle algo de dificultad al circuito. Suena estúpido pero es así -_-"

Del mismo modo que no nos dejan usar chips integrados. Pero bueno, usando eso conseguiríamos pasar de corriente alterna a continua con bastante precisión, lo que facilita la lectura de la misma.
 
Empezando y a simple vista con R15 haciendo conducir al TR del opto no creo que logres hacer nada mas, colócala a GND en ves de a +B.

Igualmente las resistencias y los capacitores deben estar muy bien calculados para que se alcancen a carga y/o descargar en el tiempo(o periodo) que le da la frecuencia que trabajen.

Es todo muy "tirado de los pelos".

Ric.
 
Última edición:
Empezando y a simple vista con R15 haciendo conducir al TR del opto no creo que logres hacer nada mas, colócala a GND en ves de a +B.

Igualmente las resistencias y los capacitores deben estar muy bien calculados para que se alcancen a carga y/o descargar en el tiempo(o periodo) que le da la frecuencia que trabajen.

Es todo muy "tirado de los pelos".

Ric.
Los valores de resistencias y capacitores de los LM331 son los recomendados por el fabricante... Hice un cálculo para ver si el filtro de frecuencia de entrada del segundo LM331 funcionaría con la frecuencia dada por el primero y aparentemente sí. Lo de R15 tienes toda la razón del mundo, lo acabo de cambiar pero el segundo LM331 no da voltaje a la salida según Proteus.
 
Última edición:
En las condiciones de trabajo, estas seguro que la salida del LM es capaz de encender el led del opto? compara ambas hojas de datos y verifica que eso ocurra por que si no el TR que conmuta a C4, no podrá hacerlo.
Seria de ayuda a los que te ayuden que incluyeras la simulación del Proteus por que si quiero verificar algo me obligas a que tenga que dibujarlo.

Ric.
 
Bueno el archivo de Proteus está un poco improvisado porque no sé usarlo, lo tengo sobretodo para tener un esquema del circuito. De hecho la última parte del amplificador no me la hace y es raro, pero la parte del opto sí. Para que funcione el segundo LM331 he tenido que conectarle otra fuente en Proteus eso sí.

Pero con la protoboard real el problema que tenemos ahora mismo es que el sensor no cambia su voltaje. Y no es problema del sensor porque lo hemos cambiado varias veces.

Muchas gracias por toda la ayuda que me estais dando.
 

Adjuntos

Arriba