Transmisor PLL FM 1 a 8w, tsa5511 & pic16f628

#81
TSA5511: No he trabajado con este chip, pero estuve viendo el data sheet de este y el charge-pump output (PD pin 1) trabaja parecido al LM7001 la única diferencia radica en que el TSA5511 tiene un buffer no inversor (UD pin18) interno y utilizan un transistor en su salida para formar el filtro pasabajos activo inversor y el LM7001 utiliza 2 transistores para este fin, pero te debe funcionar y enganchar bien en toda la banda de FM, ya que las modificaciones hechas al VCO son para aumentar el rango de sintonía de 87.5 – 108MHz con un voltaje comprendido entre 2.6 a 8.8 Voltios, posiblemente nada más tengas que modificar un poco los valores del filtro pasabajos del TSA5511 para ajustar el paso de las frecuencias más bajas del espectro de audio.

El problema que tengo es que sube la potencia de salida al calentarse, voy a probar la temperatura de las diferentes partes con una termocupla tipo K y un controlador de temperatura Maxthermo que tengo y atacar por Alli el problema.

Saludos.
 
#82
Es curioso, al mio, cuando se calienta, baja la potencia sensiblemente. ...Quizá el driver...

Saludos.
 
#85
Mira, Yo utilicé como PLL el LM7001 con el Microcontrolador PIC16F873A y LCD 2x16, el LM7001 utiliza dos transistores en configuración Darlington para el voltaje de error que controla al VCO.
El sonido es muy bueno, pero tengo un problema con la potencia que al encenderlo arranca con 3W y después de media hora queda en 3.4W, pero el problema no esta en la adaptación del PLL porque ya hice las pruebas para constatar este, la temperatura en el final no supera los 60 grados C (calentamiento normal). Cuéntame si tienes el mismo problema en el original del autor y en el que modificaste.
Tiago, publicara las modificaciones hechas al VCO en un *.jpg pero no he tenido respuesta por parte del autor del proyecto en su correo, ya que quiero tener su consentimiento. Por tu parte as podido comunicarte con el?
Saludos. Jarod10
Jarod, en todolo que he hecho con los diseños de éste autor he requerido su permiso, incluso hemos hablado mucho sobre simplificar parte de algunos montajes y sustituir componentes de dificil localización por otros.

De todos modos, le puedo preguntar sobre el asunto y que nos dé consentimiento, por cierto, eso del filtro pasabajos para las frecuancias bajas, que me invitas a revisar no se donde cae. ¿En el PLL? Te envio una foto del VCO experimental que he montado. Este va bien pero me desengancha cada 4 - 5 Mhz. Estoy ya con las modificaciones que me has sugerido, aunque no tengo resultados aún

vco bnc.jpg

Saludos

PD: He hecho las variaciones que me has recomendado, y la linealidad cuando recorres con el PLL la banda es muy superior, sin embargo una pequeña parcela se me escapaba, allá por los 107 - 108.

Intentando rehacer la bobina un poco mas precisa, al final he terminado por que no me funciona, ni me engancha. Así que si fueses tan amable de mostrarme que bobina has acoplado, ya me situo de nuevo en el buen camino, diametro de hilo, seccion interior ...Y si puede ser una foto :D:D

Resaludos.
 
Última edición:
#86
Saludos a todos.

Bueno ya he hablado con el autor sobre las modificaciones que he hecho y los efectos que pueden tener en el VCO, dentro de un rato subo el esquema con las modificaciones. Debo aclarar que en el mercado no pude conseguir el PLL y el prescaler que lleva el diseño original y lo reemplace por el LM7001. Pero los cambios hechos en el VCO deben trabajar con el TSA5511, de todas maneras voy a exponer tambien los motivos por el cual el VCO fue diseñado así. para que puedan elegir el que mejor se ajuste a sus necesidades.

Jarod10.
 
#88
Aquí están las modificaciones hechas para cubrir toda la banda de FM sin ajuste del VCO:

modif.JPG

Debo decirles que el autor tuvo unas muy buenas razones para hacer el diseño que solo cubriera unos pocos MHz con el PLL, expresa el autor:

• La razón esta en el ruido de fase que tienen los PLL, y que
aumenta a medida que se le amplia el rango de cobertura. Esto se debe en
parte a la mayor ganancia de lazo necesaria, que aumenta el "tironeo" de
frecuencia causado por los pulsitos de salida del comparador de fase, y
por otra parte también influye que para un mayor rango de frecuencia se
necesita que una mayor proporción de la capacidad total del tanque este
en los varactores, y estos tienen un factor Q muchísimo mas bajo que los
condensadores normales. Y un más bajo Q significa mayor presencia de
resistencia parasita, y la resistencia introduce ruido térmico.

• El rango de frecuencia que cubre el PLL es solamente el necesario para
garantizar que se mantenga enclavado ante todo cambio de temperatura, y
envejecimiento de componentes, que se pueda esperar. De esa manera se
maximiza la calidad de señal, al reducir el ruido de fase del PLL.

• Por esa razón yo privilegie la calidad de señal sobre la agilidad de frecuencia.

• Toda la cadena amplificadora también esta diseñada para ser ajustada a
la frecuencia de transmisión exacta, y no cubre toda la banda en buena
forma con un ajuste fijo. Esto también influye en la calidad de señal
producida, al mejorar la pureza espectral.

Estas razones les pueden servir a los lectores para entender mejor el asunto, y saber en que puntos poner atención si hacen esta modificación, ya que con estas modificaciones es probable que se tengan por lo menos unos 6 o 7 dB mas de ruido de fase.

Para el ajuste del VCO con esta modificación se realiza de la siguiente manera:

• Seleccionar 87.5MHz
• Colocar el trimmer C20 en la posición central.
• Con un voltímetro digital medir la tensión en el punto de unión entre L3 y C19, si la tensión es demasiado alta se puede esparcir un poco L3 o quitar una espira para que aumente la frecuencia de oscilación del VCO, y si e demasiado baja se pueden cerrar más las espiras de L3 hasta conseguir medir en el voltímetro una tensión cercana a los 2.5 a 3.5V.
• Luego con C20 darle un ajuste fino a este voltaje aproximadamente 3V DC.

Saludos, Jarod10.

La segunda imagen es la del filtro pasa bajos que yo he utilizado con 2 transistores en configuracion darlington (solo LM7001).

Jarod10.
 

Adjuntos

Última edición:
#89
Que fiera este Manfred. Un abrazo para él.
Gracias Jarod por la parte de investigación que has realizado.
Subo unas fotos con las modificaciones que he hecho y que al final me engancha en toda la banda, a excepcion de 2 ó 3 puntos en los que hay que retocar ligeramente el trimmer,creo que con un ultimo cambio de bobina lo coseguiré.
Dejo foto con modificaciones.

modificado.jpg
Al final has cambiado el otro varicap tambien?
Saludos.
 
Última edición:
#91
Muy bien, ya sabiendo la inductancia de la bobina. Voy a modificar y testear de nuevo. los transistores son los 2sc 668 del diagrama original. Y los BF 199 Que usé en el prototipo original del autor tambien van perfectos.

Saludos.

PD: despues de someter a prueba este circuito, me doy cuenta que engancha sin problema en un amplio segmento de la banda. Pero a partir de los 100 Mhz, compruebo que la lectura del frecuencimetro es correcta,la que indica el PLL, pero el display me muestra "UNLOCK" , y el led está apagado.

Cuando esto ocurre hay pequeñas oscilaciones de algunos Khz arriba y abajo,(Algo que solo ocurre en este caso) Tambien aparece un pitido agudo e intenso. ¿Puede ser cosa del VCO? ¿Que condensadores son los recomendados? Yo le he puesto ceramicos reciclados.

Edito:Bien, ahora si me anda por toda la banda, pero a partir de los 104 Mhz tengo un ruidito muy agudo de fondo,será cosa del PLL pero no se como eliminarlo.

Saludos.
 
Última edición:
#92
Edito:Bien, ahora si me anda por toda la banda, pero a partir de los 104 Mhz tengo un ruidito muy agudo de fondo,será cosa del PLL pero no se como eliminarlo.

Saludos.
Tiago, recuerda que, el PLL, es un dispositivo digital en el cual se generan pulsos a determinadas ratas de frecuencia y que tu TX es modulado en frecuencia (FM).

La tensión, supuesta DC puro, que debe controlar el VCO (Eso es lo que es, un oscilador controlado por voltaje), no debe tener encima ningún rastro de AC. Así que, debes hacer hasta lo imposible por filtrar, aún lo que pueda parecerte imperceptible rastro de AC, sobre la conexión de control proveniente desde el PLL hasta el VCO. Incluso ocupate de blindar, tanto el PLL mismo, como el VCO.

Recuerda también que, el audio modulante, se aplica exáctamente al mismo punto donde aplicas las señal DC de control del PLL.

Saludos:
 
#93
El pitido es por la frecuencia de referencia que usa el TSA5511, en mi caso no sucedió ya que la referencia que utilizo es de 100khz muy por encima del rango auditivo, además también hay que tener en cuenta el diseño del filtro pasabajos que utilizas.

El autor sugiere que se mida el ruido de fase del oscilador, y te asegures de que
es aceptable. Puedes obtener una buena idea escuchando la señal del oscilador en un buen receptor, subiéndole bastante el volumen. Fíjate en el siseo que se escucha, que
te da al menos una idea del ruido de fase comprendido dentro del ancho
de banda del receptor.

Si no hay problemas con todo eso, entonces úsalo así... Pero si escuchas el pitito de la frecuencia de referencia, o si el ruido es mayor al que sea aceptable para ti, entonces mejor vuelve al circuito original!

Jarod10.

Tambien intenta modificando el filtro pasabajos para que el voltage de control sea lo más puro posible.
 
Última edición:
#94
Bien, mis conclusiones han sido las siguientes: Creo que era cuestion de eliminar un silbido residual procedente del PLL y que se colaba por la entrega de voltaje de control al VCO, como Jarod decía. y Como Mcrven afirmaba con su aplicacion de la tension de control y el audio modulante, que se suelen aplicar casi en el mismo punto, o exactamente en el mismo punto. Esas han sido las pistas.

Si nos fijamos en el esquema de la modificación de Jarod, la entrada al VCO encuentra un condensador de 1N, entre la entrada y tierra, antes del choque que ya se conecta con el Varicap.

Si ponemos en paralelo con éste condensador uno de 10N y otro de 47µF/25 Volt no volveremos a escuchar el letal silbidito, me ha costado pero ahora ya me puedo ir a dormir :D. Solo lo he probado, pero mañana subire foto del arreglo final,que aconsejo hacerlo en la placa del PLL, ...Si son individuales.

Saludos.
 
Última edición:
#95
Observa el FPB que he utilizado, de la salida de los colectores de los transistores hay 2 resistencias (10k y 560) y un condensador (100nF), analiza la resistencia 1.2k y el condensador de 22uF, tambien es un punto importante para un optimo trabajo del FPB.

Saludos.
 
#97
Bien, en vista que el VCO anteriormente expuesto no me ha convencido totalmente por la problematica que he tenido en acoplarle una etapa amplificadora que funcionase, he decidido montar el proyecto que originalmente se propuso en éste hilo.

Voy con la versión de 1'5 Watios, ya que tengo casi todos los componentes, incluso algun transistor MRF237 que probaré de hacer funcionar cuando consiga que éste montaje funcione con los componentes originales (4427)

Me hubiese gustado saber algo mas de los transmisores que se montaron al principio y que pocos han posteado detalles de funcionamiento. El proyecto quedó abandonado casi en seco.
Lo retomo y probaré que tal baila éste transmisor que tengo ya desarrollado a falta de algunos componentes.

1'5 Watt PLL foro.jpg

Saludos.
 
Última edición:
#98
Muito bonita seu trabalho...

Mas está funcionando ?


Bien, en vista que el VCO anteriormente expuesto no me ha convencido totalmente por la problematica que he tenido en acoplarle una etapa amplificadora que funcionase, he decidido montar el proyecto que originalmente se propuso en éste hilo.

Voy con la versión de 1'5 Watios, ya que tengo casi todos los componentes, incluso algun transistor MRF237 que probaré de hacer funcionar cuando consiga que éste montaje funcione con los componentes originales.

Me hubiese gustado saber algo mas de los transmisores que se montaron al principio y que pocos han posteado detalles de funcionamiento. El proyecto quedó abandonado casi en seco.
Lo retomo y probaré que tal baila éste transmisor que tengo ya desarrollado a falta de algunos componentes.

Ver el archivo adjunto 72344

Saludos.
 
#99
Aún me falta el diodo varicap y el mosfet de doble puerta, creo que estará funcionando en un par de semanas.

Saludos.
 
hola tiago saludos, una consulta yo tengo armado todo el pll con el tsa5511 y un pic16f84 pero no engancha, con la diferencia que uso el tsa5511T SMD adjunto foto del que uso, sera este TSA.que no me sirve?? lo has probado ?? ya que es fácil conseguirlo esta en selectores de canales de tv.. agradezco respuesta tiago ó algún amigo del foro que lo aya armado gracias..
 

Adjuntos

Temas similares

Arriba